Bug 202965 - Add field for LTC reporters
Add field for LTC reporters
Status: CLOSED WORKSFORME
Product: Bugzilla
Classification: Community
Component: Bugzilla General (Show other bugs)
devel
All Linux
medium Severity medium (vote)
: ---
: ---
Assigned To: PnT DevOps Devs
David Lawrence
: FutureFeature
Depends On:
Blocks: 426880
  Show dependency treegraph
 
Reported: 2006-08-17 11:00 EDT by David Cantrell
Modified: 2013-06-23 22:50 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-05-05 08:50:09 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description David Cantrell 2006-08-17 11:00:30 EDT
Bugs opened by IBM's LTC for Fedora and RHEL always have the LTC bug number in
the summary line.  I find this annoying and useless for Red Hat's purposes.  IBM
obviously wants to attach an LTC number to each bug they open, so why not have
an LTC field for them just so we can keep it out of the summary line.  I'd
rather not see bug report summaries that look like this:

LTC 3842630180301874017526741908230143265461234125346723 - dhcp failure on ppc64
Comment 1 David Lawrence 2006-08-17 11:07:20 EDT
This is a great use for the External Bug Reference section that has been
implemented in our Bugzilla for quite some time. IBM's Linux Technology Center
is in our current list of bug repositories in the drop down menu. They can even
set the value at the time the new bug is created. How do we make sure they know
about this and use it?
Comment 2 David Cantrell 2006-08-17 11:27:29 EDT
See, I knew we'd have some sort of system in place to handle that already.  I
have no idea how IBM's black box LTC works, so getting them to use the external
bug reference may be difficult.  But I really think we should push for that. 
Maybe just a simple matter of telling people for a while until they "get it".

Or, could you trap new bug reports in the submit phase.  If the summary line
starts with LTC[0-9\ ]+ then you could stop at a page that says "use the
external bug reference, yo."
Comment 3 Chris Ward 2008-08-15 08:01:42 EDT
David, did you determine yet if the External Bug functionality works for IBM? I'm interested to know if they're using it yet...or planning to.
Comment 4 David Cantrell 2008-09-24 17:26:22 EDT
I have mentioned it to several IBM people and those who I have mentioned it to agree that it is a problem and like the idea of using an external bug reference, but so far I have not seen IBM change their ways.
Comment 5 Emily Ratliff 2008-09-24 19:06:16 EDT
The External Bug functionality used to work but appears to have been broken in the move to Bugzilla 3.0. Clayton Arndt from the IBM mirror tool team is looking into it.

From a release feature request perspective, the External Bug field doesn't solve the whole problem because IBMers track the LTC Bugzilla reference number and additionally the DevTrack reference number. I believe that having the DevTrack reference number in the title may be an unnecessary hold-over that we can solve by changing the IBM process - I'll see if I can get sufficient buy-in at IBM for doing this. Meanwhile, once the bug is mirrored over the first time, subsequent changes to the title don't get mirrored back to the LTC Bugzilla so if you have an intern who needs hazing, just set him to editing bug short descriptions and you will feel happier in no time.
Comment 6 Chris Ward 2009-03-17 08:52:27 EDT
What's the latest on this?
Comment 7 Noura El hawary 2009-03-19 05:10:19 EDT
just a question, how does IBM create bugs in bugzilla ? using the xmlrpc interface? if that is the case then they can change their xmlrpc scripts that create the bugs to add the LTC value to the whiteboard field in the bug report or as mentioned before they can just update the external bug reference, if that is a good solution then we can look at implementation examples.

Noura
Comment 8 Chris Ward 2009-04-06 02:42:00 EDT
Noura, I believe they are using the xmlrpc interface. They claim that they were using the ext reference successfully until it suddenly broke on 03-13-2009, a few weeks ago. They're investigating the issue.
Comment 9 Chris Ward 2009-04-22 04:06:18 EDT
Okay, so IBM has fixed their issue. Their bug bot is now (again) using the external bug field. See bug #496820 for example. I'm working with them now to get ride of the LTC info in the summaries
Comment 10 David Lawrence 2009-04-22 10:49:19 EDT
So can this be closed then or should we wait for them to clean the summaries? Seems like we can close as the summaries will just be clean for new bugs only anyway.

Dave
Comment 11 Chris Ward 2009-04-22 10:58:53 EDT
Let's leave it open until we get a thumbs up from them or not that they'll be removing the ltc info from the summaries. That way once this is closed, we'll know that future bugs shouldn't have it, so if they do, we've hit a 'regression'.
Comment 12 Chris Ward 2009-05-05 08:50:09 EDT
Okay, i'm going to go ahead and close this issue out. IBM is using the external bz field now. They still add LTC info to some of the headers, but in general, they appear to be much shorter than they used to be and more readable. If anyone has a problem again with their LTC summaries, please re-open this bug.

Note You need to log in before you can comment on or make changes to this bug.