This service will be undergoing maintenance at 00:00 UTC, 2016-09-28. It is expected to last about 1 hours
Bug 202998 - datatype error message from yum makecache
datatype error message from yum makecache
Status: CLOSED CURRENTRELEASE
Product: Red Hat Network
Classification: Red Hat
Component: RHN/Backend (Show other bugs)
rhn500
All Linux
medium Severity medium
: ---
: ---
Assigned To: Bryan Kearney
:
Depends On:
Blocks: 195503
  Show dependency treegraph
 
Reported: 2006-08-17 14:41 EDT by Beth Nackashi
Modified: 2013-01-10 05:10 EST (History)
2 users (show)

See Also:
Fixed In Version: beta2
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-12-22 19:02:01 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Beth Nackashi 2006-08-17 14:41:32 EDT
Description of problem:
yum makecache doesn't seem to work.  It spits out this error message:

[root@bnackash-64 etc]# yum makecache
Setting up repositories
rhel5-beta-client-i386-te 100% |=========================|  672 B    00:00
Error: Error: requested datatype other not available


Version-Release number of selected component (if applicable):
yum-2.9.3-2

How reproducible:
always

Steps to Reproduce:
1. Register an i386 rhel5 system to webqa.  It should auto-subscribe to the
RHEL5 beta i386 channel.
2. yum makecache
3.
  
Actual results:
[root@bnackash-64 etc]# yum makecache
Setting up repositories
rhel5-beta-client-i386-te 100% |=========================|  672 B    00:00
Error: Error: requested datatype other not available


Expected results:
This should either complete or give a more interpretable error message.

Additional info:
Comment 1 James Bowes 2006-08-17 15:16:07 EDT
The error occurs because yum tries to cache the 'other' repo metadata (changelog
entries for the rpms, basically), and does not find a location for the
other.xml.gz file in the Repository's repomd.xml file.

We do not generate the other.xml.gz file through RHN yet, and so do not point to
it in the repomd.xml file.

Anyways, I think that yum is fine how it is, but that RHN should be generating
other.xml.gz
Comment 2 James Bowes 2006-08-17 15:18:26 EDT
Jeremy can correct me on this if I'm wrong, but I don't think any of the key
updating tools (pup, pirut) use the data in other.xml.gz.
Comment 5 James Bowes 2006-09-13 14:49:08 EDT
This is fixed in the rhn 500 branch, but it might be worth releasing before
then, so we can get testing with the rhel betas.
Comment 6 RHEL Product and Program Management 2006-12-22 19:02:01 EST
A package has been built which should help the problem described in 
this bug report. This report is therefore being closed with a resolution 
of CURRENTRELEASE. You may reopen this bug report if the solution does 
not work for you.

Note You need to log in before you can comment on or make changes to this bug.