Bug 203086 - cvs -p -r<tag> <binary-file> produces corrupted file
cvs -p -r<tag> <binary-file> produces corrupted file
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: cvs (Show other bugs)
5
All Linux
medium Severity medium
: ---
: ---
Assigned To: Jiri Moskovcak
Ben Levenson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-08-18 09:11 EDT by Michael Schmitz
Modified: 2015-02-01 17:47 EST (History)
2 users (show)

See Also:
Fixed In Version: 1.11.22-6.fc5
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-07-26 05:50:34 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Michael Schmitz 2006-08-18 09:11:56 EDT
Description of problem:
When I update a binary file to standard output, the file is corrupted, while
simply updating the file in the working directory works fine.

This happens at least if the repository resides on a remote CVS server. 

Version-Release number of selected component (if applicable):
cvs-1.11.22-2.FC5

How reproducible:
always

Steps to Reproduce:
> cvs up -r BR_DEV_int_cont sesys2.ER1
cvs update: warning: sesys2.ER1 was lost
U sesys2.ER1
> cvs up -p -r BR_DEV_int_cont sesys2.ER1 > stdout-sesys2.ER1
===================================================================
Checking out sesys2.ER1
RCS: 
/cvs/sesys2/epa-10003154-sesys2/05._Leistungserbringung/5.2_Analyse-Design/5.2.4_Dokumente_Sesys_v2.x/5.2.4.4_Datenmodell/sesys2.ER1,v
VERS: 1.92.4.5
***************
> ls -l sesys2.ER1 stdout-sesys2.ER1
-rw-r--r-- 1 mschmitz mschmitz 456008 Aug 18 15:19 sesys2.ER1
-rw-r--r-- 1 mschmitz mschmitz 455982 Aug 18 15:19 stdout-sesys2.ER1
  
Actual results:
The files sesys2.ER1 and stdout-sesys2.ER1 differ.

Expected results:
The files sesys2.ER1 and stdout-sesys2.ER1 are identical.

Additional info:
Comment 1 Martin Stransky 2006-08-31 08:57:48 EDT
Are these files marked as binary? (in CVS repository)
Comment 2 Michael Schmitz 2006-08-31 09:31:24 EDT
Yes.

> cvs stat sesys2.ER1 
===================================================================
File: sesys2.ER1        Status: Up-to-date

   Working revision:    1.105
   Repository revision: 1.105  
/cvs/sesys2/epa-10003154-sesys2/05._Leistungserbringung/5.2_Analyse-Design/5.2.4_Dokumente_Sesys_v2.x/5.2.4.4_Datenmodell/sesys2.ER1,v
   Sticky Tag:          (none)
   Sticky Date:         (none)
   Sticky Options:      -kb
Comment 3 Michael Schmitz 2006-08-31 09:32:42 EDT
Whoops, I forgot to paste the following:

> cvs log sesys2.ER1|grep 'keyword substitution'
keyword substitution: b
Comment 4 Jiri Moskovcak 2007-07-26 03:00:17 EDT
I can't reproduce this bug. Do you still experience this behaviour with the
latest cvs?
Comment 5 Michael Schmitz 2007-07-26 04:43:40 EDT
No, I tried to reproduce the problem with cvs-1.11.22-6.fc5, but everything
works fine.

Note You need to log in before you can comment on or make changes to this bug.