Bug 203130 - python traceback: 'local_manifest' referenced before assignment
python traceback: 'local_manifest' referenced before assignment
Status: CLOSED CANTFIX
Product: Fedora
Classification: Fedora
Component: duplicity (Show other bugs)
5
All Linux
medium Severity medium
: ---
: ---
Assigned To: Robert Scheck
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-08-18 11:10 EDT by Guy Streeter
Modified: 2016-02-09 20:32 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-10-31 19:40:30 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Guy Streeter 2006-08-18 11:10:25 EDT
Trying to use duplicity to make an incremental backup, I'm getting this (after
entering my gpg key):

Traceback (most recent call last):
  File "/usr/bin/duplicity", line 373, in ?
    if __name__ == "__main__": main()
  File "/usr/bin/duplicity", line 362, in main
    check_last_manifest(col_stats)
  File "/usr/bin/duplicity", line 342, in check_last_manifest
    last_backup_set.check_manifests()
  File "/usr/lib/python2.4/site-packages/duplicity/collections.py", line 128, in
check_manifests
    if local_manifest: remote_manifest = local_manifest
UnboundLocalError: local variable 'local_manifest' referenced before assignment

This is completely reproducible.
It doen't look like the duplicity package or the python package has changed
since the last time this worked sucessfully.
The destination is a file:// url.
Comment 1 Robert Scheck 2006-08-19 20:03:09 EDT
Can you please provide the command you're using for duplicity? BTW, hopefully 
you're using the correct file:///foo/ and not the wrong file://foo/ ;-)
Comment 2 Guy Streeter 2006-08-23 17:33:31 EDT
$ duplicity --exclude=/home/hsv/streeter/ext-trees/
--exclude=/home/hsv/streeter/tmp/ /home/hsv/streeter
file:///net/toaster/vol/home/oldhome/hsv/streeter/backup
Comment 3 Guy Streeter 2006-09-12 15:55:05 EDT
I updated to duplicity-0.4.2-3.fc5 and I still see the same failure.
Comment 4 Guy Streeter 2006-09-13 15:11:45 EDT
I emptied out my backup directory, and the problem went away.
Comment 5 Michael J Knox 2006-09-13 15:18:05 EDT
Interesting. After you have recreated your backup, if you backup again, do you
still get a trace back?
Comment 6 Guy Streeter 2006-09-13 15:32:22 EDT
No, I've run the command several times and it is working.
Comment 7 Robert Scheck 2006-10-29 13:16:26 EST
Can I assume, that your problem is solved or were you able to reproduce the 
traceback in the meantime?
Comment 8 Guy Streeter 2006-10-30 10:30:38 EST
I have not seen this problem since wiped my backup directory and started fresh.

Note You need to log in before you can comment on or make changes to this bug.