Bug 203150 - x failed, when fc is boot off USB storage
x failed, when fc is boot off USB storage
Status: CLOSED WORKSFORME
Product: Fedora
Classification: Fedora
Component: xorg-x11 (Show other bugs)
5
All Linux
medium Severity low
: ---
: ---
Assigned To: Adam Jackson
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-08-18 13:01 EDT by LarryT
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-04-02 16:27:05 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description LarryT 2006-08-18 13:01:29 EDT
Description of problem: I have succesfully installed FC5 on usb mass storage. It
works fine, but each time i try to boot from different pc, x failed, and i have
to update the xorg.conf file.
---> Would it be possible to have a kind of autodection mode for video ? 
Video is the only thing that hurts ; all other devices work.


Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Adam Jackson 2006-08-18 18:09:49 EDT
You should try using FC6 without any xorg.conf file.
Comment 2 LarryT 2006-08-19 11:33:31 EDT
No : i get exactly the same with fc6-test2 :-(
video card change makes x to fail ! After three trys, i have the display screen,
just like with fc5.
Comment 3 Matěj Cepl 2006-12-22 13:13:15 EST
Could you try once more with the current FC6? What you ask for (X w/o xorg.conf)
SHOULD work with FC6.

Could also please attach your X server log file (/var/log/Xorg.*.log) to the bug
report as individual uncompressed file attachments using the bugzilla file
attachment link below.

We will review this issue again once you've had a chance to attach this
information. Sorry for dealy in dealing with the bug.

Thanks in advance.
Comment 4 Adam Jackson 2007-03-27 11:15:48 EDT
NEEDINFO as per comment #2.
Comment 5 LarryT 2007-03-27 11:27:49 EDT
Okay, I just need to make a fresh install on usb drive :-/, or at least refresh
my install ....
Come back asap
Comment 6 LarryT 2007-03-28 05:35:37 EDT
No problem now !
It works.
But it was the same computer : I just change video card from radeon to GForce.
Editing the xorg.conf I can see in xorg.conf.back radeon driver, and in
xorg.conf (the new one) nv driver.
Autodection did work perfectly, without any hang or problem.
Nice shot guys ;)

I will try asap with a diffrent computer, and I keep you in touch...
Comment 7 Adam Jackson 2007-04-02 16:27:05 EDT
Closing as WORKSFORME as per comment #6
Comment 8 LarryT 2007-04-03 01:14:55 EDT
Yes : it is okay. THX !
Comment 9 LarryT 2007-10-10 08:58:26 EDT
Hi there
I am currently trying to use F7 installed on External USB drive. It works well,
but since i try to boot off my F7 from another computer, video detection failed
; then I need root passwd and new detection and so on... this is not a big deal,
but definitly not good for a non-expert computing boss :-p

Is there something to do, to enable a kind of auto video detection ?

What kind of info do you need ?
thx
Larry

Note You need to log in before you can comment on or make changes to this bug.