Bug 203185 - fc6test2 graphical installation hangs during install
fc6test2 graphical installation hangs during install
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: xorg-x11-drv-i810 (Show other bugs)
6
All Linux
medium Severity medium
: ---
: ---
Assigned To: X/OpenGL Maintenance List
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-08-18 15:57 EDT by David L.
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-11-26 10:51:52 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
X log after post text install attempt to startx (19.05 KB, text/plain)
2006-08-18 15:57 EDT, David L.
no flags Details
Sucessful 865G file on a Dell computer. (2.80 KB, text/plain)
2006-08-19 00:22 EDT, Jim Cornette
no flags Details
X log with Jim's xorg.conf (50.33 KB, text/plain)
2006-08-21 17:30 EDT, David L.
no flags Details
Xorg.0.log file when screen blanks (after I hit control-alt-backspace) (52.29 KB, text/plain)
2006-08-21 17:40 EDT, David L.
no flags Details
It works on my end - 865G (2.86 KB, application/octet-stream)
2006-11-03 12:36 EST, Jim Cornette
no flags Details
It works on my end - 865G (2.86 KB, text/plain)
2006-11-03 12:36 EST, Jim Cornette
no flags Details
Xorg log file with rhgb and selinux disabled (51.62 KB, text/plain)
2006-11-16 12:48 EST, David L.
no flags Details

  None (edit)
Description David L. 2006-08-18 15:57:58 EDT
Description of problem:
fc6test2 graphical installation hangs during install.
Text install works but system-config-display and startx fail.
Changing i810 to vesa in xorg.conf fixes the problem after the
text install.

Version-Release number of selected component (if applicable):
version in fc6test2 ... still fails after yum update on 20060818
~12:00 GMT.

How reproducible:
Always.

Steps to Reproduce:
1. Try to do a graphical install of fc6test2 (from hard drive images)
2.
3.
  
Actual results:
Install hangs after trying to startx

Expected results:
install continues.

Additional info:
yum update after text install changed the behavior, but did not fix the problem.
Comment 1 David L. 2006-08-18 15:57:58 EDT
Created attachment 134471 [details]
X log after post text install attempt to startx
Comment 2 Jim Cornette 2006-08-19 00:18:52 EDT
Looking over the X log and trying to figure out the failure cause led me to
question this portion of the log.
II) I810(0): I2C bus "DVOI2C_E" initialized.
..
(EE) I810(0): Unable to read from DVOI2C_E Slave 112.
..
EE) I810(0): Unable to read from DVOI2C_E Slave 236.
..
QUESTIONS: What slave? Where is the controller?

Since I have a computer which did not exhibit this error which has an 865G card
and was an upgrade for several generations, I will include the xorg.conf file as
an attachment.

Brief history to getting the 865G card working on this computer was to get rid
of the buggy BIOS (A03 to A04), set the modes in BIOS, (legacy video to 8M) and
Shared video to 128M.

The BIOS might be buggy. The video memory in the log reflects the legacy to be
set to 8M and shared to be 64M if I am reading the log correctly.

Give the attached i810-xorg.conf file a try that I have sucess with. You will
have to rename the file to xorg.conf. Then try to start X again.
Comment 3 Jim Cornette 2006-08-19 00:22:12 EDT
Created attachment 134498 [details]
Sucessful 865G file on a Dell computer.

Rename file to xorg.conf and use in place of your present xorg.conf files.
Report back if it works or not.
You may need to investigate BIOS upgrades, video settings and the like if it
does not work.
Comment 4 David L. 2006-08-21 10:11:34 EDT
The xorg.conf that Jim provided in attachment id 134498 did work.  The default
one that didn't work looks like this:

# XFree86 4 configuration created by pyxf86config

Section "ServerLayout"
        Identifier     "Default Layout"
        Screen      0  "Screen0" 0 0
        InputDevice    "Keyboard0" "CoreKeyboard"
EndSection

Section "InputDevice"
        Identifier  "Keyboard0"
        Driver      "kbd"
        Option      "XkbModel" "pc105"
        Option      "XkbLayout" "us"
EndSection

Section "Device"
        Identifier  "Videocard0"
        Driver      "i810"
EndSection

Section "Screen"
        Identifier "Screen0"
        Device     "Videocard0"
        DefaultDepth     16
EndSection

Comment 5 Adam Jackson 2006-08-21 13:57:58 EDT
(In reply to comment #4)
> The xorg.conf that Jim provided in attachment id 134498 did work.  The default
> one that didn't work looks like this:

That's really strange.  Other than changing the default depth to 24 I don't see
anything materially different between the two.  Can you attach X startup logs
(/var/log/Xorg.0.log) from after attempted starts with both the old and new configs?
Comment 6 David L. 2006-08-21 17:30:35 EDT
Created attachment 134599 [details]
X log with Jim's xorg.conf

This is the attachment for Jim's xorg.conf that does work.
Comment 7 David L. 2006-08-21 17:40:37 EDT
Created attachment 134602 [details]
Xorg.0.log file when screen blanks (after I hit control-alt-backspace)
Comment 8 David L. 2006-08-21 17:52:20 EDT
(In reply to comment #5)
> (In reply to comment #4)
> > The xorg.conf that Jim provided in attachment id 134498 did work.  The default
> > one that didn't work looks like this:
> 
> That's really strange.  Other than changing the default depth to 24 I don't see
> anything materially different between the two.  Can you attach X startup logs
> (/var/log/Xorg.0.log) from after attempted starts with both the old and new
configs?

I tried a depth of 24 with the same results, so I don't think that's the difference.
Comment 9 Jim Cornette 2006-08-21 20:49:33 EDT
The problems that I supposed were related to the display not being addressed
correctly.
Regardless, I'll hold onto the xorg.conf which has worked on the computer that I
installed many FC versions ago and have only upgraded the system.

To verify if default depth is the problem, you could change the default depth in
the provided file to 16 and see if the display functions normally.

I did have a problem in the other OS where the monitor would go blank when
resolutions were changed. Powering off and then back on the monitor brough the
display back to visible mode.

I'm glad that you can use the i810 driver successfully now.
Comment 10 David L. 2006-09-20 16:13:44 EDT
fc6t3 graphical installation gets past the point where it was hanging in fc6t2
graphical installation.  I haven't tested X after an installation due to an
unrelated installation problem.
Comment 11 David L. 2006-09-20 17:59:20 EDT
fc6t3 still doesn't work for me after installation.  On first boot, the monitor
light started flashing like there was no signal.  I waited maybe 10 seconds and
then hit ctrl-alt-backspace to see if I could get a command-line login.  Whether
it was in response to the ctrl-alt-backspace or not I don't know, but soon
thereafter, I got the first boot configuration GUI.  However, when I booted into
fc6t3 after successfully completing the first boot configuration, my monitor
acted like there was no signal.  I tried control-alt-backspace, but it kept
re-trying to start X or something... I could never get a non-graphical log in
and the graphical login was broken.  I haven't yet tried to replace the X conf
file because I can't log in.  I'll get to it from another partition when I have
some time.
Comment 12 Jim Cornette 2006-09-20 19:52:48 EDT
When grub starts for the computer, press any key in order to unhide the menu.
Next, highlight the kernel that you want to boot from. Pres the "a" key in order
to append information for booting the kernel in runlevel 3. To do this,
backspace out the "rhgb quiet" phrases on the line.
On the command line where you backspaced out the rhgb quiet information enter
the number 3 after a space. Now press the Enter key to start the boot process.
This will start in runlevel 3.
now in the terminal, enter your login name and password, navigate to where you
stored the file, copy it over the /etc/X11/xorg.conf file that is not sufficient
enough for X to start on your computer.
After you replaced the file, reboot and allow the computer to start up in
runlevel 5 (GUI) and you should see the login screen instead of the blank screen
that you currently have.
If you wanted to test the configuration to see if all is well, login another
terminal as a regular user and type startx to start X. If your screen still
blanks, ctl-alt-backspace should not respawn X. This is a problem only with
runlevel 5 where gdm (display manager) keeps respawning. Runlevel 3 does not
start the display manager but can run the GUI from a user terminal.
Comment 13 David L. 2006-09-21 13:58:39 EDT
Using Jim's xorg.conf from comment #6 fixes the problem again.  So although the
graphical installation no longer hangs, X is still broken after installation in
fc6t3 on my hardware.
Comment 14 David L. 2006-10-31 15:36:26 EST
fc6 hangs completely for me on the first (and subsequent) boot after
installation.  I'm not sure if this is the same problem or not, but it happens
around the time that the graphical interface starts.  The symptoms are similar
to before... the power saving light on my monitor goes on after I see the boot
message about starting udev, so I suspect that this problem is related to the X
problem I've been having with fc6 on this machine.  However, using Jim's
xorf.conf didn't seem to help this time.
Comment 15 Jim Cornette 2006-10-31 18:09:02 EST
I did not upgrade my system in the conventional installer mode but updated it
via yum. The display worked fine for me after the yum upgrade to FC6.
I also experimented with the setup and ran system-config-display to get a
successful reconfigured display.

Try changing the driver to "vesa" temporarily by booting up your system in
runlevel 3 by pressing any key to display the menu choices followed by pressing
the letter a
This will give you the line with the booting options. Remove the rhgb quiet
option and add a space followed by the number 3
Afterwards, press enter to start the booting. You should get a login prompt, put
in root if you want to change the driver to vesa temporarily until a fix is in
place.
I would first login as a regular user and type startx to see if X hangs or boots.

There is a specific bug in place for error signal 11 for the 865G video. You
might want to hunt for that bug report. I wasa hit by it when I was watching the
displayed screensavers. The problem went away for me shortly sfter letting the
processes like prelink complete their tasks.

I'll provide an X configuration which I use on the new FC6 system tomorrow since
I reconfigured it successfully in FC6.
Comment 16 David L. 2006-11-01 10:45:38 EST
I booted in runlevel 3 by adding a grub entry like this:
title Fedora Core ul3 (2.6.18-1.2798.fc6xen)
        root (hd0,1)
        kernel /xen.gz-2.6.18-1.2798.fc6 
        module /vmlinuz-2.6.18-1.2798.fc6xen ro root=LABEL=/1 3
        module /initrd-2.6.18-1.2798.fc6xen.img

I changed i810 to vesa and it still crashes when I startx.  It crashes so badly
that I can't even ping this computer.  Should I reassign this bug to xorg-x11
since it crashes with vesa too?
Comment 17 Jim Cornette 2006-11-01 21:43:05 EST
I would reduce the severity level of the bug. you cannot go into graphics mode,
but this bug does not cause severe filesystem damage.

Back on topic, I have a computer with an Intel 815 integrated video which also
does not work with the vesa driver. It crashed badly with the vesa. This problem
might still be specific to your i810 driver. One of the X maintainers mentioned
using the vesa driver with an i810 video problem, I figured my computer was just
specially mixed up. The vesa driver displayed diagonal lines on my 815 card.

Anyway, I assumed that you were using an 865G video but do not see any
information from the program lspci which shows your hardware type. Can you
specify your video type or include the output from lspci?

Also, I think the xen kernel is buggy. Are you trying to run virtualized
systems? What happens if you install the run of the mill kernel version instead
of xen?
Running a regular and more refined kernel versus a sort of experimental xen
kernel variation could be adding additional problems to your system. Intel video
cards use shared memory with the system. Xen pigs out on additional memory which
might limit the memory available to your shared memory video and the xen
environment.

Let's try to set your system choices to a more sane environment and see if we
can unmangle the chain of bugs that you are experiencing.

How much system memory do you have? What BIOS settings do you have for shared
memory and for legacy video mode? (vesa, I believe). Legacy should be set to
about 8MB and system set to 128MB or higher for shared memory. (865G setting)
On the lesser Intel 815, I have legacy video set to 1MB, its maximum and shared
memory to 64MB.
I hope this explanation and questioning addition is clear to understand.
Comment 18 David L. 2006-11-02 02:04:03 EST
Here's the lspci output.  I have 2GB of RAM.  I'm not at work right now, so I
can't check the BIOS settings (or at least I don't know how to check them
without rebooting).  I reverted the severity to medium, but I can't use fc6 with X.

00:00.0 Host bridge: Intel Corporation 82865G/PE/P DRAM Controller/Host-Hub
Interface (rev 02)
00:02.0 VGA compatible controller: Intel Corporation 82865G Integrated Graphics
Controller (rev 02)
00:1d.0 USB Controller: Intel Corporation 82801EB/ER (ICH5/ICH5R) USB UHCI
Controller #1 (rev 02)
00:1d.1 USB Controller: Intel Corporation 82801EB/ER (ICH5/ICH5R) USB UHCI
Controller #2 (rev 02)
00:1d.2 USB Controller: Intel Corporation 82801EB/ER (ICH5/ICH5R) USB UHCI
Controller #3 (rev 02)
00:1d.3 USB Controller: Intel Corporation 82801EB/ER (ICH5/ICH5R) USB UHCI
Controller #4 (rev 02)
00:1d.7 USB Controller: Intel Corporation 82801EB/ER (ICH5/ICH5R) USB2 EHCI
Controller (rev 02)
00:1e.0 PCI bridge: Intel Corporation 82801 PCI Bridge (rev c2)
00:1f.0 ISA bridge: Intel Corporation 82801EB/ER (ICH5/ICH5R) LPC Interface
Bridge (rev 02)
00:1f.1 IDE interface: Intel Corporation 82801EB/ER (ICH5/ICH5R) IDE Controller
(rev 02)
00:1f.3 SMBus: Intel Corporation 82801EB/ER (ICH5/ICH5R) SMBus Controller (rev 02)
00:1f.5 Multimedia audio controller: Intel Corporation 82801EB/ER (ICH5/ICH5R)
AC'97 Audio Controller (rev 02)
03:0b.0 Ethernet controller: Intel Corporation 82541EI Gigabit Ethernet
Controller (Copper)


Here's some output from fc5 X log:

(II) I810(0): Primary V_BIOS segment is: 0xc000
(II) I810(0): VESA BIOS detected
(II) I810(0): VESA VBE Version 3.0
(II) I810(0): VESA VBE Total Mem: 12288 kB
(II) I810(0): VESA VBE OEM: Intel(r)865G Graphics Chip Accelerated VGA BIOS
(II) I810(0): VESA VBE OEM Software Rev: 1.0
(II) I810(0): VESA VBE OEM Vendor: Intel Corporation
(II) I810(0): VESA VBE OEM Product: Intel(r)865G Graphics Controller
(II) I810(0): VESA VBE OEM Product Rev: Hardware Version 0.0
(II) I810(0): Tweak BIOS image to 12288 kB VideoRAM
(--) I810(0): Pre-allocated VideoRAM: 8060 kByte
(==) I810(0): VideoRAM: 65536 kByte
(==) I810(0): video overlay key set to 0x101fe
(**) I810(0): page flipping disabled
(==) I810(0): Using gamma correction (1.0, 1.0, 1.0)
(II) I810(0): BIOS Build: 2919
Comment 19 Jim Cornette 2006-11-02 17:43:32 EST
The video chipset that you have looks similar to the one that I use.
Your memory range is set pretty low if I'm reading the information correctly.
Your  "legacy" video is set to 1MB which would give you better graphical
response if set to 8MB. Your shared video memory is set to 64MB which might
benefit your system if set to 128MB or 256MB. Since you have 2GB of memory, it
would not harm the performance of your system as far as I can tell.
My system with an 865G video adapter is a work system also. I did not copy my
working file because I was involved with another project. I can add the working
FC6 configuration file to the report tomorrow when I get to work.

In the meantime, I would suggest running the normal kernel. You can install it
if not already installed with yum or rpm. If it is already installed, try
booting into the standard kernel to see if video is alright.

As a reference regarding your current video settings, the settings are what I
can get maximum from another computer that I have at home that has an Intel 815
video chipset. 3D graphics are not very good.

Regarding accessing your BIOS settings. The settings are pretty critical so you
should know what you are setting them to. If you are not familiar with them,
check to see if there is a reference manual so you can get familiar with them. 
Also, depending upon the type of computer that you have. The upgraded BIOS
settings should be located in the support area of the manufacturer.

since I have to upgrade the Intel 815 system and its legacy and shared memory
settings are similar to the settings that you have for the video, i will try to
upgrade the system to see if the video still works after upgrade. I have a test
setup which I will try clean to see what it does and also a working FC5 system
that I can upgrade to FC6.
I'll add report information for both system trials.

Again about accessing BIOS, some systems use F2 as with this Dell computer. Most
computers use the del key that I have seen. You might hunt online for
information related to your computer vendor practices.
Comment 20 Jim Cornette 2006-11-03 12:32:05 EST
Just reporting back!
I am still using the same version of xorg.conf from July 2004 to operate 
normally. I attempted s-c-display and that is where I had problems with signal 
11 error.
Also, a posting on the fedora-users list explained that they were having 
trouble getting video to work when running the xen kernel. They still had 
problems with their setup but had some things working.
Trying the normal kernel may allow you to work with the xorg.conf file with 
the additional settings from July 2006.
I will attach the file once again to ensure I did not tweak it, though the 
date says it was dormant since 2004 with changes.
Comment 21 Jim Cornette 2006-11-03 12:36:42 EST
Created attachment 140291 [details]
It works on my end - 865G

lspci output of my computer for comparison:

00:00.0 Host bridge: Intel Corporation 82865G/PE/P DRAM Controller/Host-Hub
Interface (rev 02)
00:02.0 VGA compatible controller: Intel Corporation 82865G Integrated Graphics
Controller (rev 02)
00:1d.0 USB Controller: Intel Corporation 82801EB/ER (ICH5/ICH5R) USB UHCI
Controller #1 (rev 02)
00:1d.1 USB Controller: Intel Corporation 82801EB/ER (ICH5/ICH5R) USB UHCI
Controller #2 (rev 02)
00:1d.2 USB Controller: Intel Corporation 82801EB/ER (ICH5/ICH5R) USB UHCI
Controller #3 (rev 02)
00:1d.3 USB Controller: Intel Corporation 82801EB/ER (ICH5/ICH5R) USB UHCI
Controller #4 (rev 02)
00:1d.7 USB Controller: Intel Corporation 82801EB/ER (ICH5/ICH5R) USB2 EHCI
Controller (rev 02)
00:1e.0 PCI bridge: Intel Corporation 82801 PCI Bridge (rev c2)
00:1f.0 ISA bridge: Intel Corporation 82801EB/ER (ICH5/ICH5R) LPC Interface
Bridge (rev 02)
00:1f.1 IDE interface: Intel Corporation 82801EB/ER (ICH5/ICH5R) IDE Controller
(rev 02)
00:1f.2 IDE interface: Intel Corporation 82801EB (ICH5) SATA Controller (rev
02)
00:1f.3 SMBus: Intel Corporation 82801EB/ER (ICH5/ICH5R) SMBus Controller (rev
02)
00:1f.5 Multimedia audio controller: Intel Corporation 82801EB/ER (ICH5/ICH5R)
AC'97 Audio Controller (rev 02)
01:07.0 Ethernet controller: 3Com Corporation 3c905C-TX/TX-M [Tornado] (rev 74)

01:0c.0 Ethernet controller: Intel Corporation 82540EM Gigabit Ethernet
Controller (rev 02)
Comment 22 Jim Cornette 2006-11-03 12:36:51 EST
Created attachment 140292 [details]
It works on my end - 865G

lspci output of my computer for comparison:

00:00.0 Host bridge: Intel Corporation 82865G/PE/P DRAM Controller/Host-Hub
Interface (rev 02)
00:02.0 VGA compatible controller: Intel Corporation 82865G Integrated Graphics
Controller (rev 02)
00:1d.0 USB Controller: Intel Corporation 82801EB/ER (ICH5/ICH5R) USB UHCI
Controller #1 (rev 02)
00:1d.1 USB Controller: Intel Corporation 82801EB/ER (ICH5/ICH5R) USB UHCI
Controller #2 (rev 02)
00:1d.2 USB Controller: Intel Corporation 82801EB/ER (ICH5/ICH5R) USB UHCI
Controller #3 (rev 02)
00:1d.3 USB Controller: Intel Corporation 82801EB/ER (ICH5/ICH5R) USB UHCI
Controller #4 (rev 02)
00:1d.7 USB Controller: Intel Corporation 82801EB/ER (ICH5/ICH5R) USB2 EHCI
Controller (rev 02)
00:1e.0 PCI bridge: Intel Corporation 82801 PCI Bridge (rev c2)
00:1f.0 ISA bridge: Intel Corporation 82801EB/ER (ICH5/ICH5R) LPC Interface
Bridge (rev 02)
00:1f.1 IDE interface: Intel Corporation 82801EB/ER (ICH5/ICH5R) IDE Controller
(rev 02)
00:1f.2 IDE interface: Intel Corporation 82801EB (ICH5) SATA Controller (rev
02)
00:1f.3 SMBus: Intel Corporation 82801EB/ER (ICH5/ICH5R) SMBus Controller (rev
02)
00:1f.5 Multimedia audio controller: Intel Corporation 82801EB/ER (ICH5/ICH5R)
AC'97 Audio Controller (rev 02)
01:07.0 Ethernet controller: 3Com Corporation 3c905C-TX/TX-M [Tornado] (rev 74)

01:0c.0 Ethernet controller: Intel Corporation 82540EM Gigabit Ethernet
Controller (rev 02)
Comment 23 David L. 2006-11-09 12:54:12 EST
I had problems trying to get a non-Xen kernel running, so I re-installed fc6 and
this time didn't enable Xen ... now I can get it X to work with the vesa driver
but not with the i810 driver.  I guess there was a separate bug with Xen.
Comment 24 Jim Cornette 2006-11-11 00:48:58 EST
It is great that you now have sort of a GUI to use. I also tried the vesa driver
on the 865G which loaded X, did not have very much memory and nautilus popped up
about 5 instances of a file manager. Changing back to 1810 helped matters a lot,
since it works fine for my system.
Now that you took the effects of a XEN kernel out of the direct problem list, I
think that we can investigate your failure problem with the intel driver.
The problem can be related to BIOS settings, config files, the driver itself or
security Linux modes and the security content of your system.
I guess we can try a few of the  items to see if we can narrow down the problem
somewhat.
Try changing the driver back to i810 in the xorg.conf file and remove 'rhgb
quiet' from the boot line and add 'enforcing=0 3' to see if it boots up without
SELinux in warn only mode and removing rhgb which could be causing your lockup
problem.
You most likely want to boot into runlevel 3 so you can save the /var/Xorg.0.log
file if the system does not start X. Runlevel 5 will overwrite the log every
time it does not respawn correctly.
This file only contains your current session, so starting X another time will
overwrite the file. Copy the file somewhare where you can submit it later to a
bug report.
Comment 25 David L. 2006-11-16 12:48:10 EST
Created attachment 141391 [details]
Xorg log file with rhgb and selinux disabled
Comment 26 David L. 2006-11-16 12:49:53 EST
Disabling rhgb and selinux didn't help... I attached the log.
Comment 27 Jim Cornette 2006-11-17 22:52:03 EST
Thanks for trying out the possibilities. I read through the log and see no
reason why it does not work for you. It seems to not kill the server if I'm
reading the log correctly. There were what looked like errors with locating
items in spots.

Is it possible to find another monitor to try this out on? Maybe the monitor and
X with the i810 driver do not work well together. I'm thinking that the driver
specifies better specs than what the monitor is capable of.

Does it reconginize your monitor type in system-config-display? You might try to
specify a generic monitor with 1280x1024 or something along those lines for the
monitor settings.
Comment 28 David L. 2006-11-20 15:38:22 EST
(In reply to comment #27)
> 
> Is it possible to find another monitor to try this out on? 
Not easily, but...

> Maybe the monitor and
> X with the i810 driver do not work well together. I'm thinking that the driver
> specifies better specs than what the monitor is capable of.
I tried running system-config-display and manually picking a monitor and
resolution and it worked with the i810 driver!  I will attach a working
xorg.conf.  I have a Sony Multiscan 20sf II monitor which wasn't listed as an
option, so I chose the Multiscan 17sf.  Then I selected the i810 driver and
exited X and it worked when X came back up.  I haven't tried rebooting entirely
yet, but I think it's using the i810 driver successfully for the first time with
fc6 on this computer.
Comment 29 Jim Cornette 2006-11-20 21:01:32 EST
I'm glad that picking an almost like monitor now lets X work for you. Until
later when you can get the monitor information added to the hardware file with
yet another report to the developers.
I remember some statements that you can report bugs to get your monitor listed
by filing a bug report. If I remember correctly, they need information from some
windows inf file that comes with the monitor which they think you'll be using
the other OS. I cannot recall my monitor coming with any disks or CDs though.

I couldn't see anything wrong with the output of Xorg.0.log, so I assumed
monitor problems.

I guess you can choose fixed with other users assistance to close the report. :-)
Comment 30 David L. 2006-11-26 10:51:52 EST
Thanks for all of your help Jim.  I don't see how change the status to fixed,
but I'm inclined to leave it open anyway.  To me, fixed means that another user
with the same IBM ThinkCentre won't have the same problem I'm having (at least
not in FC7).  Arguably this bug should be closed and another one opened with a
better summary and perhaps a different component (I'll do that myself if anybody
wants to suggest a summary and component based on the symptoms), but there is
still a problem.  On a related topic, I'm getting a warning I didn't get in fc5
about 3D not being available.  I'll have to type it in the next time I see it. 
But I guess that's another bug too.  Sigh.
Comment 31 Jim Cornette 2006-11-26 21:00:03 EST
You might be able to add a bug against system-config-display regarding your
monitor not being listed along with the specs that your monitor has. You should
be able to get that information from the manual or on the Internet somewhere.

Regarding X, it appears that the problem is actually not specific to 1810 but to
the monitor. The problem is also more in regards to the fact that your monitor
does not give usable results when using queries detection from the server to get
the usable range.

One possibility with the 3D problem might be that you have something missing in
the xorg.conf file that the i810 driver needs for 3D or somehow the monitor you
chose was not 3D capable by specs. 

Are you sure that the driver is set to i810 and not vesa. Vesa surely is sort of
a failsafe driver with not much capability in the 3D arena.

If you open up new reports that are more specific to the symptom and problem,
the display seems to be the culpret. 

Note You need to log in before you can comment on or make changes to this bug.