Bug 203210 - PATCH: add volume control to playmus interactive mode
PATCH: add volume control to playmus interactive mode
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: SDL_mixer (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Brian Pepple
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-08-18 17:52 EDT by Hans de Goede
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version: 1.2.7-1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-08-26 00:20:02 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
PATCH: add volume control to playmus interactive mode (584 bytes, patch)
2006-08-18 17:52 EDT, Hans de Goede
no flags Details | Diff

  None (edit)
Description Hans de Goede 2006-08-18 17:52:24 EDT
Hi,

I've been working on getting d1x (descent 3d-shooter linux port) to play to
music from the original game. Now, 2 full days further I'm getting there.

Because of <insert long story here if you really want to know ask> I cannot use
SDL_mixer directly from d1x, so I'm using popen("playmus -i xxxx", "w") to start
playmus todo the playback and I control it (-i is interactive mode) by writing
the nescesarry commands to the stdin FILE * returned by popen.

However by default playmus' interactive mode doesn't allow changing the volume,
which I need to be able todo. The attached patch adds this capability to
playmus, and is otherwise harmless. I hope you can incorperate this patch into
playmus, so that I don't have to ship a modified version as part of the d1x package.

Thanks!


p.s.

d1x is in that other repo because it comes with a no commercial use allowed clause.
Comment 1 Hans de Goede 2006-08-18 17:52:25 EDT
Created attachment 134489 [details]
PATCH: add volume control to playmus interactive mode
Comment 2 Hans de Goede 2006-08-18 17:58:19 EDT
p.s.

I've send this patch upstream also I'll let you know their response.
Comment 3 Brian Pepple 2006-08-18 18:25:49 EDT
I'll try to give this a look over the weekend.
Comment 4 Brian Pepple 2006-08-26 00:20:02 EDT
Patch applied.  It will be available in SDL_mixer-1_2_7-1_fc6.

Note You need to log in before you can comment on or make changes to this bug.