Bug 203221 - konsole does not display bold characters
konsole does not display bold characters
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: kdebase (Show other bugs)
5
All Linux
medium Severity medium
: ---
: ---
Assigned To: Ngo Than
Ben Levenson
: Regression
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-08-19 05:28 EDT by Konrad Karl
Modified: 2007-11-30 17:11 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-08-21 10:48:05 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Konrad Karl 2006-08-19 05:28:56 EDT
Description of problem:

no bold characters displayed in konsole since
update to kdebase-3.5.4-0.2

How reproducible:

try "man ls" or use lynx w/o colors and url underlining--- 
kdebase-3.5.4/konsole/konsole/TEScreen.cpp.k       2006-08-19 
02:26:34.000000000 +0200
+++ kdebase-3.5.4/konsole/konsole/TEScreen.cpp  2006-08-19 02:27:02.000000000 
+0200
@@ -501,7 +501,7 @@
 void TEScreen::effectiveRendition()
 // calculate rendition
 {
-  ef_re = cu_re & (RE_UNDERLINE | RE_BLINK);
+  ef_re = cu_re & (RE_UNDERLINE | RE_BLINK | RE_BOLD);
   if (cu_re & RE_REVERSE)
   {
     ef_fg = cu_bg;
     ef_fg = cu_bg;
--- kdebase-3.5.4/konsole/konsole/TEWidget.cpp.k       2006-08-19 
02:26:34.000000000 +0200
+++ kdebase-3.5.4/konsole/konsole/TEWidget.cpp  2006-08-19 02:27:02.000000000 
+0200
@@ -677,6 +677,18 @@
   }

   // Paint text
+  if (attr->r & RE_BOLD)
+  {
+    QFont currentFont = paint.font();
+    currentFont.setBold(true);
+    paint.setFont( currentFont );
+  } else {
+    QFont currentFont = paint.font();
+    currentFont.setBold(false);
+    paint.setFont( currentFont );
+  }
+
+
   if (!(blinking && (attr->r & RE_BLINK)))
   {
     // ### Disabled for now, since it causes problems with characters



Additional info:

found a patch, recompiled and it works again.
konsole in current Rawhide has the same problem.




--
Konrad
Comment 1 Ngo Than 2006-08-21 10:48:05 EDT
yes, the bug has been fixed in KDE-3.5 stable branch. The new kdebase-3.5.4-4
now includes the fix. For FC5-update, i will build it soon.

Thanks for your report.
Comment 2 Boyan Anastasov 2006-08-23 18:48:52 EDT
With this patch now in kdebase-3.5.4-4 bold characters are really missing. 
Unless I'm missing something or am looking in wrong place this patch does not 
look right, at least in KDE repository (version 565268) there is something else:

http://websvn.kde.org/trunk/KDE/kdebase/apps/konsole/konsole/
TEScreen.cpp?r1=565267&r2=565268

         ef_re = cu_re;
 	 
 	   //OLD VERSION:
 	   //ef_re = cu_re & (RE_UNDERLINE | RE_BLINK);

Note You need to log in before you can comment on or make changes to this bug.