Bug 20324 - rp3 dialup does not connect!!!
rp3 dialup does not connect!!!
Status: CLOSED CANTFIX
Product: Red Hat Linux
Classification: Retired
Component: rp3 (Show other bugs)
7.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Nalin Dahyabhai
Aaron Brown
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2000-11-03 19:41 EST by Need Real Name
Modified: 2007-04-18 12:29 EDT (History)
9 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-10-18 10:09:13 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Need Real Name 2000-11-03 19:41:35 EST
When I try to connect I get an error message "Failed to activate interface". I can not get on line to get the priority updates to help fix the bugs. I 
could connect with 6.2 but not 7.0. I need help
Thank you
Comment 1 Alan O 2000-11-10 11:24:41 EST
I'm having the same problem. It looks like rp3 is not calling wvdial, but just
trying to use ifup-ppp. ifup-ppp looks like it can start wvdial under some
conditions, but it's just not doing it when called from rp3. Also, wvdial works
fine from the command line.
Comment 2 ljarno 2000-11-16 16:15:53 EST
G'day,
I  had exactly the same problem ("Failed to activate interface") when using
"rp3".
Here is what I did to fix this trouble :
1) Open the "Dial up Configuration" menu ;
2) Select the "Advanced" tab ;
3) Uncheck "Bring link up and down automatically" option.
Hope it could help.
Ludovic (ljarno@free.fr)
Comment 3 Need Real Name 2000-11-19 15:47:15 EST
Also failing in RH 7.0, but working in 6.2
ifconfig shows a ppp0 interface with local 10.64.64.64
                                     and remote 10.112.112.112

ppp1 is sometimes good, but sometimes similar, ending 
in 65 and 113.

Comment 4 Need Real Name 2000-11-28 21:43:06 EST
Following is an e-mail I posted to the linux.redhat usenet group on the
11/07/2000.  I received a reply to this post advising someone else was having
identical problems even down to the 10.64.64.64 address for the local host.

Original post to linux.redhat

Have recently installed RH7.0, and attempted to configure a dial up connection
to my ISP using RP3 .  However when running the Dialler after selecting
"activate connection to My ISP", I receive the following error:  "Warning:
Failed to activate interface".  This is before any activity on the modem.

I can however dial and connect sucessfully when running the debug option within
the RP3 setup.  Which makes me suspect another application called by RP3?

I have learnt that RP3 uses wvdial for some of it's functions, but after
checking the options for RP3 , wvdial, and pppd I am unable to resolve this
problem.  Although the system log has the following entries - appears to be
assigning itself an IP address before it even dials.

Nov  7 20:05:18 localhost ifup-ppp: pppd started for ppp0 on /dev/ttyS0 at 115200
Nov  7 20:05:18 localhost pppd[8582]: pppd 2.3.11 started by root, uid 0

Nov  7 20:05:18 localhost pppd[8582]: Using interface ppp0
Nov  7 20:05:18 localhost pppd[8582]: local  IP address 10.64.64.64 Nov  7
20:05:18 localhost pppd[8582]: remote IP address 10.112.112.112

Any help would be appreciated.
Comment 5 Jeff Lane 2001-03-27 10:57:59 EST
It may not help you in this case, but I had the same problems as well with an
external modem.

I found that in my case at least, I did not have an lo device when I booted. 
For some reason, there was no lo, and any time I tried to dial using usernet or
rp3, I got the same pppX devices with the 10.x.x.x addresses.  

however, if  I rebooted, and then brought up lo manually (ifup lo) and then ran
rp3 or usernet, then it would dial and connect fine.  so after getting network
services to start on boot seemed to fix the issue.

and for what its worth, I had the same problems, AND, the debug, and manually
running wvdial did work, where rp3 did not.

Comment 6 Changed to DavidTangye@hotmail.com 2001-03-31 00:17:25 EST
This appears to be duplicate of other bugs, eg 18749 is the 1st I see.
Other also follow it. I cannot get the comment box in 18749, so my observations
are here.

When dialing via rp3, I get a error message in a dialog box 'Failed to activate
the interface'.
ps reports this as the actual dialing commmand at the time -

/usr/sbin/pppd lock modem crtscts asyncmap 00000000 defaultroute user xxxxxxxx
remotename ppp1 demand ktune idle 3600 holdoff 30 /dev/ttyS0 115200 ipparam ppp1
linkname ppp1 noauth connect /usr/bin/wvdial --remotename ppp1 --chat Freebiz

If I run this as root from a shell I get the following error -

/usr/sbin/pppd: unrecognized option '--remotename'
pppd version 2.3.11
Usage: /usr/sbin/pppd [ options ], where options are:
	<device>	Communicate over the named device
	<speed>		Set the baud rate to <speed>
	<loc>:<rem>	Set the local and/or remote interface IP
			addresses.  Either one may be omitted.
	asyncmap <n>	Set the desired async map to hex <n>
	auth		Require authentication from peer
        connect <p>     Invoke shell command <p> to set up the serial line
	crtscts		Use hardware RTS/CTS flow control
	defaultroute	Add default route through interface
	file <f>	Take options from file <f>
	modem		Use modem control lines
	mru <n>		Set MRU value to <n> for negotiation
See pppd(8) for more options.

Remotename appears to be not a parameter of pppd nor wvdial. How do I fix this
bug?

Running rp3-config and the Debug button works fine, and the command running then
is -

usr/sbin/pppd modem crtscts defaultroute usehostname -detach user xxxxxxx
noipdefault remotename * call wvdial

Is this the sort of command that rp3 should be runnning?
Comment 7 Changed to DavidTangye@hotmail.com 2001-03-31 01:16:11 EST
Forget my earlier message - this fixed it for me too -

IN Bug#: 20324
------- Additional comments from ljarno@free.fr 2000-11-16 16:15:53 -------

 G'day,
 I  had exactly the same problem ("Failed to activate interface") when using
 "rp3".
 Here is what I did to fix this trouble :
 1) Open the "Dial up Configuration" menu ;
 2) Select the "Advanced" tab ;
 3) Uncheck "Bring link up and down automatically" option.
 Hope it could help.
 Ludovic (ljarno@free.fr)
Comment 8 Bill Nottingham 2006-08-07 13:08:00 EDT
Red Hat Linux is no longer supported by Red Hat, Inc. If you are still
running Red Hat Linux, you are strongly advised to upgrade to a
current Fedora Core release or Red Hat Enterprise Linux or comparable.
Some information on which option may be right for you is available at
http://www.redhat.com/rhel/migrate/redhatlinux/.

Red Hat apologizes that these issues have not been resolved yet. We do
want to make sure that no important bugs slip through the cracks.
Please check if this issue is still present in a current Fedora Core
release. If so, please change the product and version to match, and
check the box indicating that the requested information has been
provided. Note that any bug still open against Red Hat Linux on will be
closed as 'CANTFIX' on September 30, 2006. Thanks again for your help.
Comment 9 Bill Nottingham 2006-10-18 10:09:13 EDT
Red Hat Linux is no longer supported by Red Hat, Inc. If you are still
running Red Hat Linux, you are strongly advised to upgrade to a
current Fedora Core release or Red Hat Enterprise Linux or comparable.
Some information on which option may be right for you is available at
http://www.redhat.com/rhel/migrate/redhatlinux/.

Closing as CANTFIX.

Note You need to log in before you can comment on or make changes to this bug.