Bug 203252 - Missing symbol makes AIGLX fail to start
Missing symbol makes AIGLX fail to start
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: mesa (Show other bugs)
rawhide
powerpc Linux
medium Severity medium
: ---
: ---
Assigned To: Adam Jackson
:
: 203253 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-08-19 16:16 EDT by W. Michael Petullo
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-08-21 09:33:26 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
X configuration file (1.73 KB, text/plain)
2006-08-19 16:16 EDT, W. Michael Petullo
no flags Details

  None (edit)
Description W. Michael Petullo 2006-08-19 16:16:09 EDT
Description of problem:
There seems to be a symbol missing from r200_dri.so.  This results in AIGLX
failing to initialize.

Version-Release number of selected component (if applicable):
mesa-libGL-6.5-20.fc6

How reproducible:
Every time

Steps to Reproduce:
I have a ATI Technologies Inc M9+ 5C63 [Radeon Mobility 9200 (AGP)].  I
configure X using the attached file.  
  
Actual results:
My X logs say:
(EE) AIGLX error: dlopen of /usr/lib/dri/r200_dri.so failed
(/usr/lib/dri/r200_dri.so: cannot open shared object file: No such file or
directory)
(EE) AIGLX: reverting to software rendering

Expected results:
AIGLX should provide hardware rendering

Additional info:
Comment 1 W. Michael Petullo 2006-08-19 16:16:10 EDT
Created attachment 134515 [details]
X configuration file
Comment 2 W. Michael Petullo 2006-08-19 16:20:39 EDT
*** Bug 203253 has been marked as a duplicate of this bug. ***
Comment 3 W. Michael Petullo 2006-08-19 16:21:15 EDT
The log message should be:

(EE) AIGLX error: dlopen of /usr/lib/dri/r200_dri.so failed
(/usr/lib/dri/r200_dri.so: undefined symbol: _glapi_tls_Context)
(EE) AIGLX: reverting to software rendering

Not what is listed above.
Comment 4 Adam Jackson 2006-08-21 09:33:26 EDT
TLS dispatch was turned off in Mesa because it's incompatible with selinux. 
Both the X server and Mesa had to be updated to reflect this.  Whatever X server
version you're running is too old; update to xorg-x11-server 1.1.1-10 or later.

Note You need to log in before you can comment on or make changes to this bug.