Bug 20326 - in cyrus-imapd-2.0.6.-3 lib IMAP.so have undefined functions from libssl.so, but not linked with it
in cyrus-imapd-2.0.6.-3 lib IMAP.so have undefined functions from libssl.so, ...
Status: CLOSED DUPLICATE of bug 19104
Product: Red Hat Powertools
Classification: Retired
Component: cyrus-imapd (Show other bugs)
7.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Nalin Dahyabhai
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2000-11-03 19:54 EST by Maxim Batourine
Modified: 2008-05-01 11:37 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-12-06 00:09:24 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Maxim Batourine 2000-11-03 19:54:50 EST
When try to run cyradm, perl created error:
Can't load '/usr/lib/perl5/site_perl/5.6.0/i386-
linux/auto/Cyrus/IMAP/IMAP.so' for module Cyrus::IMAP: undefined symbol: 
SSL_write at /usr/lib/perl5/5.6.0/i386-linux/DynaLoader.pn line 200.

When do command "#ldd IMAP.so" - no entry for libssl.so, but when try to 
see functions in lib by command "nm -r IMAP.so", this command display 
messages about undefined functions SSL_* and X509* (they placed in 
libssl.so and libcrypto.so).

I think this is mistake in SRPMS for cyrus-imapd, where placed 
patch .nossl, which remove from perl module dependences to libssl

temp solution:
mv IMAP.so IMAP_old.so
ld -lssl -lcrypto -R/path/to/IMAP_old.so -shared -o IMAP_new.so
ln -s IMAP_new.so IMAP.so
Comment 1 Robert J. Berger 2000-12-06 00:09:22 EST
The following worked for me to fix this:
--- cyrus-imapd-2.0.6/perl/imap/Makefile.PL.orig	Thu Nov 30 17:57:14 2000
+++ cyrus-imapd-2.0.6/perl/imap/Makefile.PL	Thu Nov 30 17:54:28 2000
@@ -55,7 +55,7 @@
     'macro'	=> {'IMCLIENT_LIBS' => ''},	# hack
     'clean'	=> {'FILES' => 'libcyrperl.a cyradm'},
     'OBJECT'    => 'IMAP.o ../../lib/libcyrus.a',
-    'LIBS'	=> ["$SASL_LIB"],
+    'LIBS'	=> ["$SASL_LIB -L/usr/lib/sassl -lsasl -L/usr/lib -lssl -lcrypto"],
     'DEFINE'	=> '-DPERL_POLLUTE',     # e.g., '-DHAVE_SOMETHING' 
     'INC'	=> "-I../../lib $SASL_INC", 
     'EXE_FILES' => [cyradm],
Comment 2 Nalin Dahyabhai 2001-02-15 11:13:51 EST
 

*** This bug has been marked as a duplicate of 19104 ***

Note You need to log in before you can comment on or make changes to this bug.