Bug 203278 - keyboard and/or mouse randomly unrecognized via USB hub
keyboard and/or mouse randomly unrecognized via USB hub
Status: CLOSED INSUFFICIENT_DATA
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
5
x86_64 Linux
medium Severity medium
: ---
: ---
Assigned To: Kernel Maintainer List
Brian Brock
MassClosed
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-08-20 08:52 EDT by Tom Horsley
Modified: 2008-01-19 23:37 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-01-19 23:37:09 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Tom Horsley 2006-08-20 08:52:55 EDT
Description of problem:

Boot system with USB keyboard and mouse plugged in via a USB
hub, and sometimes linux seems one or both and sometimes it
doesn't.

Version-Release number of selected component (if applicable):

x86_64 kernel 2.6.17-1.2174_FC5
usbutils-0.71-2
libusb-0.1.11-2.2
udev-084-13

How reproducible:

random, but fails fairly often

Steps to Reproduce:
1. boot system
2. try to type
3. nothing happens
  
Actual results:

randomly nonresponsive keyboard and/or mouse

Expected results:

keyboard and mouse working perfectly

Additional info:

I've tried several things to gather data points:

For one thing, I've never had a problem talking to the motherboard
BIOS via the hub, that is the primary thing that leads me to suspect
linux rather than hub hardware.

If I plug and unplug the keyboard in the hub, nothing happens. It
is like linux isn't noticing new devices via the hub (or isn't paying
the same kind of attention to them that it should - perhaps this is
the same problem as bug 181732).

If, on the other hand, I plug the keyboard into the hub, then unplug
and plug in the hub itself, sometimes linux will then notice the
keyboard (sometimes not :-). I even once had a case where the keyboard
was working via the hub, and then stopped working (but I didn't
plug or unplug anything).

I've never had a problem with the keyboard and mouse plugged directly
into a usb port on the motherboard.

Here's what lsusb says about these devices when they happen to be working:

Bus 002 Device 002: ID 0aa8:8001 TriGem Computer, Inc. 
Bus 002 Device 001: ID 0000:0000  
Bus 001 Device 033: ID 047d:1002 Kensington 
Bus 001 Device 032: ID 06a3:8000 Saitek PLC 
Bus 001 Device 031: ID 04cc:1521 Philips Semiconductors USB 2.0 Hub
Bus 001 Device 003: ID 04a9:221c Canon, Inc. 
Bus 001 Device 001: ID 0000:0000  

The mouse is Kensington, the keyboard is Saitek, and the hub I am
trying to use is Philips.

Same hub and keyboard plugged into a windows box has no problems.
Sometimes it takes windows a few minutes to actually recognize
everything, but it always seems to get it right eventually.

P.S. I'm just guessing that udev may be the component for this bug,
it is hard to know exactly what to classify it as :-).

I'm off to try my FC6t2 boot partition and see if it has the same
problems...
Comment 1 Tom Horsley 2006-08-20 10:32:13 EDT
More data: Booted FC6t2 partition, and it did (once) recognize the mouse
and keyboard via the hub. Decided to try some other stuff with the hub.
Plugged in a littl thumb drive, nothing happened. lsusb shows:

[root@zooty ~]# lsusb
Bus 001 Device 001: ID 0000:0000  
Bus 001 Device 002: ID 0aa8:8001 TriGem Computer, Inc. 
Bus 002 Device 001: ID 0000:0000  
Bus 002 Device 002: ID 04cc:1521 Philips Semiconductors USB 2.0 Hub
Bus 002 Device 003: ID 04a9:221c Canon, Inc. 
Bus 002 Device 005: ID 06a3:8000 Saitek PLC 
Bus 002 Device 006: ID 047d:1002 Kensington 

so the thumb drive doesn't show up at all. Leaving everything plugged
into the hub, I unplug and plug the hub, now lsusb shows:

Bus 001 Device 001: ID 0000:0000  
Bus 001 Device 002: ID 0aa8:8001 TriGem Computer, Inc. 
Bus 002 Device 021: ID 05dc:a430 Lexar Media, Inc. 
Bus 002 Device 019: ID 047d:1002 Kensington 
Bus 002 Device 017: ID 06a3:8000 Saitek PLC 
Bus 002 Device 013: ID 04cc:1521 Philips Semiconductors USB 2.0 Hub
Bus 002 Device 001: ID 0000:0000  
Bus 002 Device 003: ID 04a9:221c Canon, Inc. 

So the thumb drive is there now (Lexar), but it wasn't mounted - opening
the "my computer" in gnome doesn't show the lexar drive as it normally
does when I plug it directly into the motherboard.

I'll try booting FC6 a few more times to see if it suffers from the
random failures like FC5.
Comment 2 Tom Horsley 2006-08-20 11:02:17 EDT
FC6 seems better with the mouse and keyboard. I've booted a few times
now and it always recognized them, but the thumb drive is never recognized
in the same hub (this smacks of someone special casing the keyboard and
mouse somewhere to get them to work rather than fixing the general problem :-).

However, I did have some kind of problem on FC6. I was tying in a gnome
terminal and suddenly an infinite number of hyphen characters started
spewing. Had to unplug the keyboard and plug into motherboard connector
again to solve that one, so FC6, while better at initial recognition,
still has problems when a hub is involved.
Comment 3 Tom Horsley 2006-08-20 15:25:10 EDT
Still never had a problem with initial recognition in FC6, but I also noticed
some additional data points:

The problem on FC6 is mainly that the keyboard will stop working after a while.
I'm wondering if some kind of power management thing is interacting
with usb - it turns everything off, then forget to turn it back on?

The Windows box I tried this on has both usb 1.1 and usb 2.0 ports. It is
definitely much flakier when I plug the hub into a 2.0 port. It takes much
longer to "settle down" and fully recognize the mouse anhd keyboard following
standby, and I can only bring it out of standby with the power switch, when
I'm plugged into the usb 1.1 port, the keyboard will bring it out of standby.
Despite the increased flakiness, everything does eventually work OK on
the Windows box.

Yet another box I tried is an old fedora core 4 system which has only usb 1.1
ports. On this box (still with the same hub) it is absolutely rock solid.
Never once did I have a problem with recognition.

It is beginning to look a lot like whatever is going on has something to
do with usb 2.0 problems (unfortunately I have no usb 1.1 ports in my
main machine, so I can't solve the problem by switching ports).
Comment 4 Tom Horsley 2006-08-20 16:09:45 EDT
My final data point for a while (I'm getting tired of experimenting :-).
On FC6, if I find and turn off every power management option I can
locate going through preferences and screen savers and wot not, the
keyboard apparently works forever, seems as solid as the fedora core 4
box was.

With all the default power management settings, if I leave it for a
while and come back, the keyboard will be inoperative and I'll have
to unplug it from the hub and plug it directly into the motherboard
to get it back.

Since my FC5 and FC6 testing is all on the same machine, it certainly
seems to indicate that something is different at a software level and
it isn't hardware (or not all hardware anyway) causing the problem.
Comment 5 Tom Horsley 2006-08-20 19:13:50 EDT
Well, I tried one more thing after all. I found another hub collecting
dust because it had failed miserably the last time I tried to use it, but
I gave it a whirl anyway, and in this case, it (so far) seems to be working
perfectly. None of the symptoms have cropped up in either FC5 or FC6t2.

This one shows up as:

Bus 002 Device 002: ID 050d:0234 Belkin Components F5U234 USB 2.0 4-Port Hub

instead of the Phillips one I'd been using before (sold as brand name "Targus").

I guess I'll stick with the Belkin for now (but the different behavior
on FC5 and FC6t2 still makes it seem like some software is involved
somewhere).
Comment 6 John (J5) Palmieri 2006-08-21 11:48:36 EDT
This isn't a hal issue.  Most likely a USB driver issue.
Comment 7 Tom Horsley 2006-08-29 19:07:50 EDT
Whereever the bug belongs, I can add that the Belkin hub has been working
almost flawlessly since I added comment 5 above, but I have had it fail
to recognize the mouse once after a reboot. Unpluging and pluging back
in the mouse from the hub fixed that glitch.

I did find that a usb->serial cable that I use for my cellphone doesn't
work in the belkin hub (I think that was the original reason I concluded
the hub was busted). If I plug it into the motherboard, it works fine.
Comment 8 Dave Jones 2006-10-16 16:14:37 EDT
A new kernel update has been released (Version: 2.6.18-1.2200.fc5)
based upon a new upstream kernel release.

Please retest against this new kernel, as a large number of patches
go into each upstream release, possibly including changes that
may address this problem.

This bug has been placed in NEEDINFO state.
Due to the large volume of inactive bugs in bugzilla, if this bug is
still in this state in two weeks time, it will be closed.

Should this bug still be relevant after this period, the reporter
can reopen the bug at any time. Any other users on the Cc: list
of this bug can request that the bug be reopened by adding a
comment to the bug.

In the last few updates, some users upgrading from FC4->FC5
have reported that installing a kernel update has left their
systems unbootable. If you have been affected by this problem
please check you only have one version of device-mapper & lvm2
installed.  See bug 207474 for further details.

If this bug is a problem preventing you from installing the
release this version is filed against, please see bug 169613.

If this bug has been fixed, but you are now experiencing a different
problem, please file a separate bug for the new problem.

Thank you.
Comment 9 Jon Stanley 2008-01-19 23:37:09 EST
(this is a mass-close to kernel bugs in NEEDINFO state)

As indicated previously there has been no update on the progress of this bug
therefore I am closing it as INSUFFICIENT_DATA. Please re-open if the issue
still occurs for you and I will try to assist in its resolution. Thank you for
taking the time to report the initial bug.

If you believe that this bug was closed in error, please feel free to reopen
this bug.

Note You need to log in before you can comment on or make changes to this bug.