Bug 203291 - bind (named) fails when NetworkManager is enabled
bind (named) fails when NetworkManager is enabled
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: bind (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Martin Stransky
Ben Levenson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-08-20 13:35 EDT by Jurgen Kramer
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-09-20 14:01:00 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Jurgen Kramer 2006-08-20 13:35:02 EDT
Description of problem:
When NetworkManager is enabled bind fails to start

Version-Release number of selected component (if applicable):
bind-utils-9.3.2-37.fc6
bind-9.3.2-37.fc6
bind-libs-9.3.2-37.fc6
caching-nameserver-9.3.2-37.fc6
NetworkManager-glib-0.7.0-0.cvs20060529.6
NetworkManager-0.7.0-0.cvs20060529.6
NetworkManager-gnome-0.7.0-0.cvs20060529.6


How reproducible:
always

Steps to Reproduce:
1. Enable NetworkManager to automatically startup in level 5
2. reboot
3. 
  
Actual results:
The bootup screen shows that named fails to start

Expected results:
....

Additional info:
service named status gives: rndc: connect failed: connection refused

When starting named *before* NM named works. Maybe the order in which these
related services are started have to be changed?
Comment 1 Jurgen Kramer 2006-08-28 14:34:11 EDT
With the updated bind packages the problem still exists

bind-9.3.2-39.fc6
bind-libs-9.3.2-39.fc6
bind-utils-9.3.2-39.fc6

[root@macbook init.d]# service named restart
Stopping named:                                            [FAILED]
Starting named:                                            [FAILED]

[after NetworkManager stopped]
Starting named:                                            [FAILED]
[root@macbook init.d]# service named start
Starting named:                                            [FAILED]
[root@macbook init.d]# service named start
Starting named:                                            [FAILED]
[root@macbook init.d]# service named start
Starting named:                                            [  OK  ]

Odd. After that:

[root@macbook init.d]# service NetworkManager start
Setting network parameters... 
Starting NetworkManager daemon:                            [  OK  ]
[root@macbook init.d]# service named status
number of zones: 6
debug level: 0
xfers running: 0
xfers deferred: 0
soa queries in progress: 0
query logging is OFF
recursive clients: 0/1000
tcp clients: 0/100
server is up and running

[root@macbook init.d]# service named restart
Stopping named:                                            [  OK  ]
Starting named:                                            [FAILED]
[root@macbook init.d]# service named restart
Stopping named:                                            [FAILED]
Starting named:                                            [  OK  ]


Comment 2 Jurgen Kramer 2006-09-11 14:07:08 EDT
The problem still persists:
[root@macbook log]# service named restart
Stopping named:                                            [FAILED]
Starting named:                                            [FAILED]
[root@macbook log]# service NetworkManager stop
Stopping NetworkManager daemon:                            [  OK  ]
[root@macbook log]# service named start
Starting named:                                            [FAILED]
[root@macbook log]# 
[root@macbook log]# service named start
Starting named:                                            [FAILED]
[root@macbook log]# service named start
Starting named:                                            [  OK  ]
[root@macbook log]# service named stop
Stopping named:                                            [  OK  ]
[root@macbook log]# service named start
Starting named:                                            [  OK  ]
[root@macbook log]# service NetworkManager start
Setting network parameters... 
Starting NetworkManager daemon:                            [  OK  ]
[root@macbook log]# service NetworkManager status
NetworkManager (pid 3405) is running...
[root@macbook log]# service named status
number of zones: 6
debug level: 0
xfers running: 0
xfers deferred: 0
soa queries in progress: 0
query logging is OFF
recursive clients: 0/1000
tcp clients: 0/100
server is up and running

The system is fully updated 10-sept-2006
Comment 3 Martin Stransky 2006-09-14 03:58:47 EDT
Could you attach a log when named fails to start? (from /var/log/messages)
Comment 4 Jurgen Kramer 2006-09-14 12:54:46 EDT
As requested.

[root@macbook ~]# service named status
rndc: connect failed: connection refused
[root@macbook ~]# service named stop
Stopping named:                                            [FAILED]
[root@macbook ~]# service named start
Starting named:                                            [FAILED]

Results in:

Sep 14 18:48:14 macbook named[3142]: starting BIND 9.3.2 -u named -c
/etc/named.caching-nameserver.conf -D
Sep 14 18:48:14 macbook named[3142]: found 2 CPUs, using 2 worker threads
Sep 14 18:48:14 macbook named[3142]: loading configuration from
'/etc/named.caching-nameserver.conf'
Sep 14 18:48:14 macbook named[3142]: no IPv6 interfaces found
Sep 14 18:48:14 macbook named[3142]: listening on IPv4 interface lo, 127.0.0.1#53
Sep 14 18:48:14 macbook named[3142]: command channel listening on 127.0.0.1#953
Sep 14 18:48:14 macbook named[3142]: zone 0.in-addr.arpa/IN/localhost_resolver:
loaded serial 42
Sep 14 18:48:14 macbook named[3142]: zone
0.0.127.in-addr.arpa/IN/localhost_resolver: loaded serial 1997022700
Sep 14 18:48:14 macbook named[3142]: zone
255.in-addr.arpa/IN/localhost_resolver: loaded serial 42
Sep 14 18:48:14 macbook named[3142]: zone
0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.ip6.arpa/IN/localhost_resolver:
loaded serial 1997022700
Sep 14 18:48:14 macbook named[3142]: zone localdomain/IN/localhost_resolver:
loaded serial 42
Sep 14 18:48:14 macbook named[3142]: zone localhost/IN/localhost_resolver:
loaded serial 42
Sep 14 18:48:14 macbook NetworkManager: <WARNING>        add_ip4_config_to_named
(): Could not set forwarders for zone '.'.  Error: 'Message did not receive a
reply (timeout by message bus)'. 

I issued the following command directly after this, resulting in:

[root@macbook ~]# service named restart
Stopping named:                                            [FAILED]
Starting named:                                            [  OK  ]

Sep 14 18:48:56 macbook named[3183]: starting BIND 9.3.2 -u named -c
/etc/named.caching-nameserver.conf -D
Sep 14 18:48:56 macbook named[3183]: found 2 CPUs, using 2 worker threads
Sep 14 18:48:56 macbook named[3183]: loading configuration from
'/etc/named.caching-nameserver.conf'
Sep 14 18:48:56 macbook named[3183]: no IPv6 interfaces found
Sep 14 18:48:56 macbook named[3183]: listening on IPv4 interface lo, 127.0.0.1#53
Sep 14 18:48:56 macbook named[3183]: command channel listening on 127.0.0.1#953
Sep 14 18:48:56 macbook named[3183]: zone 0.in-addr.arpa/IN/localhost_resolver:
loaded serial 42
Sep 14 18:48:56 macbook named[3183]: zone
0.0.127.in-addr.arpa/IN/localhost_resolver: loaded serial 1997022700
Sep 14 18:48:56 macbook named[3183]: zone
255.in-addr.arpa/IN/localhost_resolver: loaded serial 42
Sep 14 18:48:56 macbook named[3183]: zone
0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.ip6.arpa/IN/localhost_resolver:
loaded serial 1997022700
Sep 14 18:48:56 macbook named[3183]: zone localdomain/IN/localhost_resolver:
loaded serial 42
Sep 14 18:48:56 macbook named[3183]: zone localhost/IN/localhost_resolver:
loaded serial 42
Sep 14 18:48:56 macbook named[3183]: D-BUS dhcdbd subscription enabled.
Sep 14 18:48:56 macbook named[3183]: D-BUS service enabled.
Sep 14 18:48:56 macbook named[3183]: running
Sep 14 18:49:21 macbook NetworkManager: <WARNING>        add_ip4_config_to_named
(): Could not set forwarders for zone '.'.  Error: 'Did not receive a reply.
Possible causes include: the remote application did not send a reply, the
message bus security policy blocked the reply, the reply timeout expired, or the
network connection was broken.'. 

And bind keeps running:

[root@macbook ~]# service named status
number of zones: 6
debug level: 0
xfers running: 0
xfers deferred: 0
soa queries in progress: 0
query logging is OFF
recursive clients: 0/1000
tcp clients: 0/100
server is up and running

Comment 5 Jurgen Kramer 2006-09-14 13:03:25 EDT
Just a question on the side, I've disabled ipv6, why does bind still enable it
on localhost?

Sep 14 18:48:56 macbook named[3183]: zone
255.in-addr.arpa/IN/localhost_resolver: loaded serial 42
Sep 14 18:48:56 macbook named[3183]: zone
0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.ip6.arpa/IN/localhost_resolver:
loaded serial 1997022700
Comment 6 Martin Stransky 2006-09-19 07:37:02 EDT
Have you enabled named to start during boot and does it start before
NetworkManager? (Because it's the default settings)

What do you have in /etc/rc5.d/?
Comment 7 Jurgen Kramer 2006-09-20 14:01:00 EDT
Both services are started on bootup. bind now runs happily together with NM
(as of todays Rawhide):
bind-libs-9.3.2-41.fc6
bind-9.3.2-41.fc6
bind-utils-9.3.2-41.fc6
caching-nameserver-9.3.2-41.fc6
NetworkManager-0.6.4-5.fc6
NetworkManager-glib-0.6.4-5.fc6
NetworkManager-gnome-0.6.4-5.fc6

The major difference is that NM is back to 0.6.x. I'm not sure if NM is the culprit.
Comment 8 Martin Stransky 2006-09-22 06:16:22 EDT
Aha, it could be the problem....

Note You need to log in before you can comment on or make changes to this bug.