Bug 203294 - gdm login does not respect altgr modifier with Finnish keyboard
gdm login does not respect altgr modifier with Finnish keyboard
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: gdm (Show other bugs)
5
All Linux
medium Severity medium
: ---
: ---
Assigned To: Ray Strode [halfline]
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-08-20 15:33 EDT by Ville Herva
Modified: 2008-03-18 14:34 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-03-18 14:34:08 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Ville Herva 2006-08-20 15:33:39 EDT
Description of problem:
gdm does not respect altgr modifier with Finnish keyboard. This makes it 
impossible to enter certain characters (@£${[]}\~ |) in passwords and user 
names. I imagine this affects all keyboard layouts that have altgr (SE, GE, NO, 
DK, ...). I recall running into this problem years ago (but since then, I have 
not used fedora with GDM (runlevel 3) or have not had such chars in my 
password.) Now I had to change my password because of this.

Version-Release number of selected component (if applicable):
gdm-2.14.9-1

How reproducible:
always (on this computer), have seen this on other fedora/redhat boxes in the 
past.


Steps to Reproduce:
1. have a password with altgr chars
2. try to login via gdm
3.
  
Actual results:
altgr is not respected (altgr-2 produces '2', not '@')

Expected results:
@

Additional info:
Comment 1 Ray Strode [halfline] 2008-03-18 14:34:08 EDT
Hi,

We no longer support Fedora Core 5 and I am currently trying to get my open bug
count down to a more manageable state.  I'm going to close this bug as WONTFIX.
 If this issue is still a concern for you, would you mind trying to reproduce on
a supported version of Fedora and reopening?

(this is a mass message)

Note You need to log in before you can comment on or make changes to this bug.