Bug 203299 - Request: Replace lam with OpenMPI in core
Request: Replace lam with OpenMPI in core
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: lam (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Doug Ledford
Brian Brock
:
Depends On: 213662
Blocks:
  Show dependency treegraph
 
Reported: 2006-08-20 20:36 EDT by Jonathan Underwood
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-02-09 14:15:39 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jonathan Underwood 2006-08-20 20:36:41 EDT
Description of problem:
The current situation is that the lam implementation of MPI is shipped as part
of Core, and OpenMPI is in Extras. However, the lam homepage states:

"LAM/MPI is now in a maintenance mode. Bug fixes and critical patches are still
being applied, but little real "new" work is happening in LAM/MPI. This is a
direct result of the LAM/MPI Team spending the vast majority of their time
working on our next-generation MPI implementation -- Open MPI"

Since Fedora policiy is to move with upstream, lam should be replaced with
OpenMPI in core.

Why do I care? Well, as one example, currently it is not possible to build and
ship the Valgrind OpenMPI wrappers, since this would need a
BuildRequires:openmpi in the Valgrind package, and Core packages cannot BR
Extras packages AFAIK.

(For info on the Valgrind MPI wrappers see:
http://www.valgrind.org/docs/manual/manual-core.html#manual-core.mpiwrap)

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Doug Ledford 2006-08-28 19:22:44 EDT
I've started talking to people about doing this.  I'm not sure if it will make
fc6 or not.
Comment 2 Tom "spot" Callaway 2006-09-13 15:23:08 EDT
I'd be happy to take lam into FE.
Comment 3 Orion Poplawski 2007-02-09 14:15:39 EST
OpenMPI is in core.

Note You need to log in before you can comment on or make changes to this bug.