Bug 203312 - suspend to mem don't work with APIC enabled on Compaq 2415LA
suspend to mem don't work with APIC enabled on Compaq 2415LA
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Kernel Maintainer List
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-08-20 22:30 EDT by Ricardo Ariel Gorosito
Modified: 2007-11-30 17:11 EST (History)
2 users (show)

See Also:
Fixed In Version: 2.6.21-1.3189.fc7
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-05-28 19:02:35 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Ricardo Ariel Gorosito 2006-08-20 22:30:16 EDT
Description of problem:
suspend to mem don't work with APIC enabled on Compaq 2415LA

Steps to Reproduce:
1 echo "mem" > /sys/power/state
2 sleep ok
3 wakeup hang (no display/no disk activity/no capslook/no hardware resumed?)

Additional info:
If I boot with noapic, resume work ~ok (I loose tty1-6 with no display, but X
work fine)
With an vanilla 2.4.16+8kstack+ndiswrapper+ati propietary driver, suspend to mem
work 100% ok
I'm not using bc43xx because it is unstable in this hardware
Comment 1 Richard Hughes 2007-05-24 06:32:31 EDT
Can you also try with http://people.freedesktop.org/~hughsient/quirk/ and a
fedora kernel with no ndiswrapper or ati stuff installed. Thanks.
Comment 2 Ricardo Ariel Gorosito 2007-05-24 17:47:06 EDT
With recent kernel from rawhide (2.6.21-1.3189.fc7) wakeup without problems.
I've tested with and without ndiswrapper
Comment 3 Nigel Cunningham 2007-05-28 19:02:35 EDT
Ok. I'll close then as fixed in the current release.

Note You need to log in before you can comment on or make changes to this bug.