Bug 203344 - Anaconda crashes when can't find kickstart file on ISO
Anaconda crashes when can't find kickstart file on ISO
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: anaconda (Show other bugs)
4.0
All Linux
medium Severity medium
: ---
: ---
Assigned To: David Lehman
:
: 237111 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-08-21 08:58 EDT by Bastien Nocera
Modified: 2007-11-30 17:07 EST (History)
1 user (show)

See Also:
Fixed In Version: RHBA-2007-0215
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-05-01 13:25:16 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
anaconda-ks-look-through-cdroms-rhel4.patch (1.05 KB, patch)
2006-08-21 08:58 EDT, Bastien Nocera
no flags Details | Diff

  None (edit)
Description Bastien Nocera 2006-08-21 08:58:49 EDT
anaconda-10.1.1.46-1

When passing "ks=cdrom:/ks.cfg" to anaconda, to make it find a kickstart file on
an ISO image, we get a segfault, after the message:
* getFileFromBlockDevice((null), isolinux/ks.cfg)

This is the same problem that was reported on the anaconda list:
http://www.redhat.com/archives/anaconda-devel-list/2006-May/msg00041.html

Attached is a patch from Paul Dwyer <pdwyer@redhat.com> to backport the
functionality (looking through CD devices, rather than failing if the first one
can't be found, thus avoiding the crash) to RHEL4.
Comment 1 Bastien Nocera 2006-08-21 08:58:50 EDT
Created attachment 134558 [details]
anaconda-ks-look-through-cdroms-rhel4.patch
Comment 2 Jay Turner 2006-08-21 22:35:44 EDT
QE ack for 4.5.
Comment 3 RHEL Product and Program Management 2006-08-23 17:37:44 EDT
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux maintenance release.  Product Management has requested
further review of this request by Red Hat Engineering, for potential
inclusion in a Red Hat Enterprise Linux Update release for currently deployed
products.  This request is not yet committed for inclusion in an Update
release.
Comment 4 RHEL Product and Program Management 2006-08-23 17:37:46 EDT
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux maintenance release.  Product Management has requested
further review of this request by Red Hat Engineering, for potential
inclusion in a Red Hat Enterprise Linux Update release for currently deployed
products.  This request is not yet committed for inclusion in an Update
release.
Comment 5 Don Bodle 2006-12-05 07:49:12 EST
If it matters, this is an issue for me.  We have a customized process for
installing across our customer base, and it is CD based.  We are moving to 64
bit IBM blades (HS21, LS41) and ran into this problem.  There is a workaround
for our situation: using ks=hd:scd0:/ks.cfg, but that reduces our abilitly to
maintain a generic process across platforms.  I'd like to see this resolved
officially sooner rather than later.
Don Bodle
Sr Systems Developer
The Reynolds and Reynolds Company
Comment 8 David Lawrence 2007-04-10 16:32:08 EDT
Verified fixed by QE in latest snapshot release.
Comment 9 David Lehman 2007-04-19 10:40:46 EDT
*** Bug 237111 has been marked as a duplicate of this bug. ***
Comment 11 Red Hat Bugzilla 2007-05-01 13:25:16 EDT
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on the solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2007-0215.html

Note You need to log in before you can comment on or make changes to this bug.