Bug 203349 - /etc/cron.weekly/makewhatis.cron error after installling update 8
/etc/cron.weekly/makewhatis.cron error after installling update 8
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: man (Show other bugs)
3.8
All Linux
medium Severity medium
: ---
: ---
Assigned To: Ivana Varekova
Ben Levenson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-08-21 09:27 EDT by Prentice Bisbal
Modified: 2007-11-16 20:14 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-01-23 12:01:12 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
more verbose version of makewhatis script (10.99 KB, text/plain)
2006-08-22 06:47 EDT, Ivana Varekova
no flags Details
Output of more verbose makewhatis (276.55 KB, text/plain)
2006-08-22 09:49 EDT, Prentice Bisbal
no flags Details

  None (edit)
Description Prentice Bisbal 2006-08-21 09:27:03 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.0.6) Gecko/20060728 Firefox/1.5.0.6

Description of problem:
I'm not sure if this problem belongs to man, awk, or the cron package: After updating from RHEL3,U7 to RHEL3,U8, I now get this error message e-mailed to root  when /etc/cron.d/makewhatis runs:

/etc/cron.weekly/makewhatis.cron:

awk: cmd. line:10: (FILENAME=- FNR=249) fatal: file `./man1' is a directory.

This occurs both with the ES and WS versions of RHEL3, and on both the x86 and AMD64 versions. 

/etc/cron.daily/makewhatis.cron does not cause this error. 



Version-Release number of selected component (if applicable):
man-1.5k-13.rhel3

How reproducible:
Always


Steps to Reproduce:
1. Run up2date or use RHN to bring system to update level 8.
2. Wait for /etc/cron.weekly/makewhatis.cron run automatically, or run it manually simply by typing '/etc/crond.weekly/makewhatis.con'

Actual Results:
I get this error message:

awk: cmd. line:10: (FILENAME=- FNR=249) fatal: file `./man1' is a directory.

Expected Results:
No output - command finishes silently.

Additional info:
Comment 1 Ivana Varekova 2006-08-22 06:47:35 EDT
Created attachment 134628 [details]
more verbose version of makewhatis script

Could you try to reproduce your problem with attached makewhatis (replace
/usr/sbin/makewhatis by this test script or edit
/etc/cron.weekly/makewhatis.cron to use this script), and attach its output
here.
Comment 2 Prentice Bisbal 2006-08-22 09:49:55 EDT
Created attachment 134633 [details]
Output of more verbose makewhatis
Comment 3 Prentice Bisbal 2006-08-22 09:55:15 EDT
Did you test this modified version of makewhatis before attaching it? When I ran
it I got this error:

/usr/sbin/makewhatis.bugzilla 
/usr/sbin/makewhatis.bugzilla: line 2: set: -E: invalid option
set: usage: set [--abefhkmnptuvxBCHP] [-o option] [arg ...]

I changed 

set -xET

to 

set -xT

which produced this error:

/usr/sbin/makewhatis.bugzilla 
/usr/sbin/makewhatis.bugzilla: line 2: set: -T: invalid option
set: usage: set [--abefhkmnptuvxBCHP] [-o option] [arg ...]

I then changed the set statement to 

set -x

And it then ran without errors. 

I ran the script with '-w' since this is the way the cron job invokes it:

/usr/sbin/makewhatis.bugzilla -w > ~pbisbal/makewhatis.bugzilla.out 2>&1 

The output is attached to this issue. 
Comment 5 RHEL Product and Program Management 2007-01-23 12:01:12 EST
Product Management has reviewed and declined this request.  You may appeal this
decision by reopening this request. 

Note You need to log in before you can comment on or make changes to this bug.