Bug 203364 - Norwegian bokmaal locale uses the wrong 1st day of the week
Norwegian bokmaal locale uses the wrong 1st day of the week
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: glibc (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Jakub Jelinek
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-08-21 10:52 EDT by Kjartan Maraas
Modified: 2007-11-30 17:11 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-10-04 03:31:15 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Kjartan Maraas 2006-08-21 10:52:08 EDT
Description of problem:

[kmaraas@rivendell common]$ cal
    august 2006     
sø ma ti on to fr lø
       1  2  3  4  5
 6  7  8  9 10 11 12
13 14 15 16 17 18 19
20 21 22 23 24 25 26
27 28 29 30 31

[kmaraas@rivendell common]$ locale
LANG=nb_NO.UTF-8
LC_CTYPE="nb_NO.UTF-8"
LC_NUMERIC="nb_NO.UTF-8"
LC_TIME="nb_NO.UTF-8"
LC_COLLATE="nb_NO.UTF-8"
LC_MONETARY="nb_NO.UTF-8"
LC_MESSAGES="nb_NO.UTF-8"
LC_PAPER="nb_NO.UTF-8"
LC_NAME="nb_NO.UTF-8"
LC_ADDRESS="nb_NO.UTF-8"
LC_TELEPHONE="nb_NO.UTF-8"
LC_MEASUREMENT="nb_NO.UTF-8"
LC_IDENTIFICATION="nb_NO.UTF-8"
LC_ALL=
[kmaraas@rivendell common]$ 

ma (monday) should be the first day of the week. This affects the clock applet
in gnome etc since gtk uses the locale data to find the first day of the week.


Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Jakub Jelinek 2006-08-21 12:42:13 EDT
Well, that's something that should be resolved by native speakers.
Please read http://std.dkuug.dk/jtc1/SC22/WG20/docs/n690.pdf and supply the
right value of week for the locale.  The starting day of the week is not the
only thing that needs to be known, important is e.g. how are weeks in the year
counted.
Comment 2 Kjartan Maraas 2006-08-22 04:46:56 EDT
- Number of days in the week is seven
- the weekday number to be contained in the first week of the year is 4 (thursday) 

If I read the above right :-)
Comment 3 Kjartan Maraas 2007-01-15 07:55:55 EST
What more information do you need to resolve this? I think we're exactly the
same as Sweden and Denmark in this regard. Does that help? After looking at
those I see that 'cal' shows sunday as the first day of the week for them too.
Why I wonder...

You can see how it should be here:

Norwegian:
http://www.timeanddate.com/norsk/kalender.html

Denmark:
http://www.timeanddate.com/calendar/?year=2007&country=2

Sweden:
http://www.timeanddate.com/calendar/?year=2007&country=21
Comment 4 Kjartan Maraas 2007-02-14 10:50:44 EST
Forgot to reopen this when I supplied the information above.
Comment 5 Kjartan Maraas 2007-03-15 16:30:30 EDT
Any news on this? It's the same for norwegian nynorsk (nn_NO) too
Comment 6 Anton Keks 2007-06-06 15:19:32 EDT
The same problem is with et_EE (Estonian).

But actually I would prefer using the system in English, while having correct
European settings (at least the week must start on Monday!!!)

I couldn't find any English locale with week start on Monday, however en_IE,
en_GB, and en_DK are supposed to have this, but gnome calendar shows weeks from
Sunday, which is irritating.

The only locale I found that has Monday is ru_RU (I tried only languages I know).

So in short: at least these locales must have week start on Monday: et_EE,
en_GB, en_IE, en_DK.
Comment 7 Rasmus Ory Nielsen 2007-07-15 07:23:58 EDT
In Denmark the week should also start on Monday instead of Sunday.

LANG=da_DK.UTF-8
LC_CTYPE="da_DK.UTF-8"
LC_NUMERIC="da_DK.UTF-8"
LC_TIME="da_DK.UTF-8"
LC_COLLATE="da_DK.UTF-8"
LC_MONETARY="da_DK.UTF-8"
LC_MESSAGES="da_DK.UTF-8"
LC_PAPER="da_DK.UTF-8"
LC_NAME="da_DK.UTF-8"
LC_ADDRESS="da_DK.UTF-8"
LC_TELEPHONE="da_DK.UTF-8"
LC_MEASUREMENT="da_DK.UTF-8"
LC_IDENTIFICATION="da_DK.UTF-8"
LC_ALL=

[rasmuson@jupiter ~]$ cal
     juli 2007      
sø ma ti on to fr lø
 1  2  3  4  5  6  7
 8  9 10 11 12 13 14
15 16 17 18 19 20 21
22 23 24 25 26 27 28
29 30 31
Comment 8 Kjartan Maraas 2007-09-24 05:45:06 EDT
Is there anything else I can do to get this moving?
Comment 9 Ulrich Drepper 2007-09-30 14:32:47 EDT
da_DK, et_EE, nb_NO, and nn_NO should be fixed in upstream cvs.
Comment 10 Jakub Jelinek 2007-10-04 03:31:15 EDT
In glibc-2.6.90-17 in rawhide.

Note You need to log in before you can comment on or make changes to this bug.