Bug 203367 - Having issues getting my on-board sound card working
Having issues getting my on-board sound card working
Status: CLOSED UPSTREAM
Product: Fedora
Classification: Fedora
Component: sndconfig (Show other bugs)
5
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Martin Stransky
:
: 203368 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-08-21 11:07 EDT by Richard McLaren
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-10-03 09:18:49 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Richard McLaren 2006-08-21 11:07:00 EDT
Description of problem:

------- System Config Soundcard --------
Mon Aug 21 10:50:08 EDT 2006

------- lspci --------
00:00.0 Host bridge: Intel Corporation 945G/P Memory Controller Hub (rev 02)
00:02.0 VGA compatible controller: Intel Corporation 945G Integrated Graphics 
Controller (rev 02)
00:02.1 Display controller: Intel Corporation 945G Integrated Graphics 
Controller (rev 02)
00:1b.0 Audio device: Intel Corporation 82801G (ICH7 Family) High Definition 
Audio Controller (rev 01)
00:1c.0 PCI bridge: Intel Corporation 82801G (ICH7 Family) PCI Express Port 1 
(rev 01)
00:1c.1 PCI bridge: Intel Corporation 82801G (ICH7 Family) PCI Express Port 2 
(rev 01)
00:1d.0 USB Controller: Intel Corporation 82801G (ICH7 Family) USB UHCI #1 
(rev 01)
00:1d.1 USB Controller: Intel Corporation 82801G (ICH7 Family) USB UHCI #2 
(rev 01)
00:1d.2 USB Controller: Intel Corporation 82801G (ICH7 Family) USB UHCI #3 
(rev 01)
00:1d.3 USB Controller: Intel Corporation 82801G (ICH7 Family) USB UHCI #4 
(rev 01)
00:1d.7 USB Controller: Intel Corporation 82801G (ICH7 Family) USB2 EHCI 
Controller (rev 01)
00:1e.0 PCI bridge: Intel Corporation 82801 PCI Bridge (rev e1)
00:1f.0 ISA bridge: Intel Corporation 82801GB/GR (ICH7 Family) LPC Interface 
Bridge (rev 01)
00:1f.2 IDE interface: Intel Corporation 82801GB/GR/GH (ICH7 Family) Serial 
ATA Storage Controllers cc=IDE (rev 01)
00:1f.3 SMBus: Intel Corporation 82801G (ICH7 Family) SMBus Controller (rev 01)
02:00.0 Ethernet controller: Intel Corporation 82573E Gigabit Ethernet 
Controller (Copper) (rev 03)

------- lsmod --------
Module                  Size  Used by
i915                   22465  1 
drm                    68181  2 i915
ip_conntrack_ftp       11697  0 
ip_conntrack_netbios_ns     6977  0 
xt_state                6209  5 
ip_conntrack           54040  3 
ip_conntrack_ftp,ip_conntrack_netbios_ns,xt_state
nfnetlink              10457  1 ip_conntrack
iptable_filter          7105  1 
ip_tables              16389  1 iptable_filter
ppdev                  12741  0 
autofs4                22981  1 
hidp                   24001  2 
rfcomm                 42709  0 
l2cap                  31681  10 hidp,rfcomm
bluetooth              52901  3 hidp,rfcomm,l2cap
sunrpc                140925  1 
ipt_REJECT              9536  1 
xt_tcpudp               7233  7 
x_tables               16965  4 xt_state,ip_tables,ipt_REJECT,xt_tcpudp
acpi_cpufreq           10949  0 
video                  18885  0 
button                 10577  0 
battery                13253  0 
ac                      8901  0 
ipv6                  246433  14 
lp                     16265  0 
parport_pc             29413  1 
parport                38281  3 ppdev,lp,parport_pc
floppy                 61829  0 
nvram                  12617  0 
uhci_hcd               33233  0 
ehci_hcd               33229  0 
sg                     36317  0 
snd_hda_intel          21329  1 
snd_hda_codec         116033  1 snd_hda_intel
snd_seq_dummy           7749  0 
snd_seq_oss            33345  0 
snd_seq_midi_event     11073  1 snd_seq_oss
snd_seq                52401  5 snd_seq_dummy,snd_seq_oss,snd_seq_midi_event
snd_seq_device         12877  3 snd_seq_dummy,snd_seq_oss,snd_seq
e1000                 103853  0 
snd_pcm_oss            49105  0 
snd_mixer_oss          20417  2 snd_pcm_oss
snd_pcm                81093  3 snd_hda_intel,snd_hda_codec,snd_pcm_oss
hw_random               9817  0 
i2c_i801               12365  0 
i2c_core               24897  1 i2c_i801
snd_timer              26693  2 snd_seq,snd_pcm
snd                    55109  9 
snd_hda_intel,snd_hda_codec,snd_seq_oss,snd_seq,snd_seq_device,snd_pcm_oss,snd_
mixer_oss,snd_pcm,snd_timer
soundcore              13345  2 snd
snd_page_alloc         14537  2 snd_hda_intel,snd_pcm
dm_snapshot            19949  0 
dm_zero                 6081  0 
dm_mirror              23825  0 
dm_mod                 54233  6 dm_snapshot,dm_zero,dm_mirror
ext3                  121417  2 
jbd                    56917  1 ext3
ata_piix               13893  2 
libata                 58065  1 ata_piix
sd_mod                 20417  3 
scsi_mod              129001  3 sg,libata,sd_mod

------- /etc/modprobe.conf --------
alias eth0 e1000
alias scsi_hostadapter ata_piix
alias snd-card-0 snd-hda-intel
options snd-card-0 index=0 
options snd-hda-intel index=0 
remove snd-hda-intel { /usr/sbin/alsactl store 0 >/dev/null 2>&1 
|| : ; }; /sbin/modprobe -r --ignore-remove snd-hda-intel

------- /etc/asound.conf --------


------- aplay -l --------
**** List of PLAYBACK Hardware Devices ****
card 0: Intel [HDA Intel], device 0: AD198x Analog [AD198x Analog]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 0: Intel [HDA Intel], device 1: AD198x Digital [AD198x Digital]
  Subdevices: 1/1
  Subdevice #0: subdevice #0

------- amixer --------
Simple mixer control 'Headphone',0
  Capabilities: pvolume pswitch
  Playback channels: Front Left - Front Right
  Limits: Playback 0 - 63
  Mono:
  Front Left: Playback 29 [46%] [on]
  Front Right: Playback 29 [46%] [on]
Simple mixer control 'PCM',0
  Capabilities: pvolume pswitch
  Playback channels: Front Left - Front Right
  Limits: Playback 0 - 31
  Mono:
  Front Left: Playback 14 [45%] [on]
  Front Right: Playback 14 [45%] [on]
Simple mixer control 'Front',0
  Capabilities: pvolume pswitch
  Playback channels: Front Left - Front Right
  Limits: Playback 0 - 63
  Mono:
  Front Left: Playback 29 [46%] [on]
  Front Right: Playback 29 [46%] [on]
Simple mixer control 'Front Mic',0
  Capabilities: pvolume pswitch cswitch cswitch-joined cswitch-exclusive
  Capture exclusive group: 0
  Playback channels: Front Left - Front Right
  Capture channels: Mono
  Limits: Playback 0 - 31
  Mono: Capture [off]
  Front Left: Playback 0 [0%] [off]
  Front Right: Playback 0 [0%] [off]
Simple mixer control 'Front Mic Boost',0
  Capabilities: volume
  Playback channels: Front Left - Front Right
  Capture channels: Front Left - Front Right
  Limits: 0 - 3
  Front Left: 0 [0%]
  Front Right: 0 [0%]
Simple mixer control 'Line',0
  Capabilities: pvolume pswitch cswitch cswitch-joined cswitch-exclusive
  Capture exclusive group: 0
  Playback channels: Front Left - Front Right
  Capture channels: Mono
  Limits: Playback 0 - 31
  Mono: Capture [off]
  Front Left: Playback 0 [0%] [off]
  Front Right: Playback 0 [0%] [off]
Simple mixer control 'CD',0
  Capabilities: pvolume pswitch cswitch cswitch-joined cswitch-exclusive
  Capture exclusive group: 0
  Playback channels: Front Left - Front Right
  Capture channels: Mono
  Limits: Playback 0 - 31
  Mono: Capture [on]
  Front Left: Playback 14 [45%] [on]
  Front Right: Playback 14 [45%] [on]
Simple mixer control 'Mic',0
  Capabilities: pvolume pswitch cswitch cswitch-joined cswitch-exclusive
  Capture exclusive group: 0
  Playback channels: Front Left - Front Right
  Capture channels: Mono
  Limits: Playback 0 - 31
  Mono: Capture [off]
  Front Left: Playback 0 [0%] [off]
  Front Right: Playback 0 [0%] [off]
Simple mixer control 'Mic Boost',0
  Capabilities: volume
  Playback channels: Front Left - Front Right
  Capture channels: Front Left - Front Right
  Limits: 0 - 3
  Front Left: 0 [0%]
  Front Right: 0 [0%]
Simple mixer control 'IEC958',0
  Capabilities: pswitch pswitch-joined enum
  Items: 'PCM' 'ADC'
  Item0: 'PCM'
Simple mixer control 'PC Speaker',0
  Capabilities: pvolume pvolume-joined pswitch pswitch-joined
  Playback channels: Mono
  Limits: Playback 0 - 15
  Mono: Playback 0 [0%] [off]
Simple mixer control 'Aux',0
  Capabilities: pvolume pswitch cswitch cswitch-joined cswitch-exclusive
  Capture exclusive group: 0
  Playback channels: Front Left - Front Right
  Capture channels: Mono
  Limits: Playback 0 - 31
  Mono: Capture [off]
  Front Left: Playback 0 [0%] [off]
  Front Right: Playback 0 [0%] [off]
Simple mixer control 'Mono',0
  Capabilities: pvolume pvolume-joined pswitch pswitch-joined
  Playback channels: Mono
  Limits: Playback 0 - 63
  Mono: Playback 0 [0%] [off]
Simple mixer control 'Capture',0
  Capabilities: cvolume cswitch
  Capture channels: Front Left - Front Right
  Limits: Capture 0 - 15
  Front Left: Capture 0 [0%] [off]
  Front Right: Capture 0 [0%] [off]
Simple mixer control 'Mix',0
  Capabilities: cswitch cswitch-joined cswitch-exclusive
  Capture exclusive group: 0
  Capture channels: Mono
  Mono: Capture [off]
Simple mixer control 'Mix Mono',0
  Capabilities: cswitch cswitch-joined cswitch-exclusive
  Capture exclusive group: 0
  Capture channels: Mono
  Mono: Capture [off]

------- /proc/asound/version --------
Advanced Linux Sound Architecture Driver Version 1.0.11rc2 (Wed Jan 04 
08:57:20 2006 UTC).

------- rpm -q alsa-lib --------
alsa-lib-1.0.11-3.rc2.2

------- rpm -q alsa-utils --------
alsa-utils-1.0.11-3.rc2

------- /proc/asound/modules --------
 0 snd_hda_intel

------- /proc/asound/pcm --------
00-01: AD198x Digital : AD198x Digital : playback 1
00-00: AD198x Analog : AD198x Analog : playback 1 : capture 1

------- system-config-soundcard --------

/usr/share/system-config-soundcard/soundcard.py:273: DeprecationWarning: use 
gtk.ComboBox
  self.primarySubDeviceOptionMenu = gtk.OptionMenu()
/usr/share/system-config-soundcard/soundcard.py:308: GtkDeprecationWarning: 
gtk.timeout_add is deprecated, use gobject.timeout_add instead
  self.timer = gtk.timeout_add (100, self.checkStatus, self)
/usr/share/system-config-soundcard/soundcard.py:548: GtkDeprecationWarning: 
gtk.TRUE is deprecated, use True instead
  gtk.main()
Playing WAVE '/usr/share/system-config-soundcard/sound-sample.wav' : Signed 16 
bit Little Endian, Rate 44100 Hz, Stereo



Version-Release number of selected component (if applicable):


How reproducible:

Tried re-install still same issue


Steps to Reproduce:
1.reinstall
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Richard McLaren 2006-08-22 09:00:07 EDT
*** Bug 203368 has been marked as a duplicate of this bug. ***
Comment 2 Martin Stransky 2006-08-31 08:43:50 EDT
Okay, so what is the problem? If your card doesn't work, please check my how-to:

http://people.redhat.com/stransky/alsa/
Comment 3 Sibi Antony 2006-08-31 09:41:52 EDT
hi Martin,
      I am also experiencing a problem similar to the above.. Me too have an
'Intel Corporation 82801G (ICH7 Family)' audio controller and the problem
descriptions and COMMAND O/Ps ARE SAME AS THE ABOVE.. and I get no sound ouput
in FC5. 
      I tried your instructions in the how-to. Neither aplay nor alsamixer
settings work for me. I also tried rebuilding and upgrading with
alsa-lib-1.0.12-2 and alsa-utils-1.0.12-2 , but that too doesnt work!
Comment 4 Sibi Antony 2006-09-04 08:50:37 EDT
hi martin,
        thanks that worked!.. sorry to say that initially i dint try compiling
the source.. I straight away went for rpms. But I experienced some difficulty in
compiling the code too. There were some build errors with pcmcia , usbaudio
modules etc.. I commented those lines and recompiled ;) Specifcally the errors
were related to unknown options in driver operations structures in pcmcia and
usbaudio modules.
        Also I had to do an unmute on 'ispeaker' option in the alsamixer.
Earlier this option was not there.



Note You need to log in before you can comment on or make changes to this bug.