Bug 203414 - Prefs dialog issues
Prefs dialog issues
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: compiz (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Kristian Høgsberg
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-08-21 15:10 EDT by Bill Nottingham
Modified: 2014-03-16 23:01 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-08-28 13:43:13 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Bill Nottingham 2006-08-21 15:10:38 EDT
1) a button for enabling? Not a checkbox?
2) The 'do you want to keep this' dialog appears a good 2-3 seconds before
compiz finishes starting
3) You don't get the 'do you want to keep this' dialog when you turn it off.

compiz-0.0.13-0.16.20060817git.fc6
Comment 1 Søren Sandmann Pedersen 2006-08-23 14:52:19 EDT
Let me comment in reverse order:

3. The reason we have the "Do you want to keep this" in the first place is that
compiz might cause the computer to lock up. If that happens and the setting was
already changed, the same lockup would happen on the next login, hence the cop
out dialog box.

When you turn it off, there isn't the same risk, because we assume that metacity
works. Although I should probably change it apply the setting *before*
attempting to start metacity (if compiz should lock up when it shuts down).

2. Is hard to fix without heuristically waiting a good 2-3 seconds before
showing the dialog.

1. Weird, admittedly. The reason is that it is really unexpected to have a
checkbox pop up a dialog box.



The reason is that a togglebutton signals an 'action' rather than a toggle. 
Comment 2 Søren Sandmann Pedersen 2006-08-23 14:57:51 EDT
Erh, ignore the last line of that comment ...
Comment 3 Bill Nottingham 2006-08-23 15:01:28 EDT
One other note - it's very likely that, when switching, the popup will be
*under* the prefs dialog. Not sure how you fix this in the absence of a WM at
the time it appears.

As for #2, you could do some really gross 'have compiz send dialog a signal when
it's fully initialized', or something.
Comment 4 Søren Sandmann Pedersen 2006-08-25 11:27:08 EDT
Hmm, I guess we could wait until compiz registers itself as the window manager,
and only then show the dialog. That might also take care of the modal dialog box
showing up below the box.
Comment 5 Matthias Clasen 2006-08-25 14:01:33 EDT
I was just about to propose watching the _WM_S0 selection for ownerchip changes
Comment 6 Søren Sandmann Pedersen 2006-08-28 13:43:13 EDT
Fixed in rawhide.

Note You need to log in before you can comment on or make changes to this bug.