Bug 203466 - ESC error codes : need to be refined better
ESC error codes : need to be refined better
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: esc (Show other bugs)
5.0
All Linux
high Severity medium
: ---
: ---
Assigned To: Jack Magne
Chandrasekar Kannan
RHEL5.0NACK
:
Depends On:
Blocks: 202042
  Show dependency treegraph
 
Reported: 2006-08-21 18:42 EDT by Orla Hegarty
Modified: 2015-01-04 18:20 EST (History)
4 users (show)

See Also:
Fixed In Version: RHBA-2007-0634
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-11-07 11:57:26 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Orla Hegarty 2006-08-21 18:42:25 EDT
Moved from Raidzilla
http://raidzilla.sfbay.redhat.com/show_bug.cgi?id=58044

Currently the error messages that we get during enrollment failures are
not very clear. Please refine these error messages to reflect the exact 
error.


------- Additional Comment #1 From Chandrasekar Kannan 2006-03-14 14:58 [reply]
-------

changing status/target per last bug council on 03/10
Comment 2 Chandrasekar Kannan 2006-09-20 01:56:21 EDT
per bug council on 09/19/2006, priority = high
Comment 3 Jack Magne 2006-09-20 15:23:29 EDT
Working with Thomas on this one. Better and more useful error messages will be
the output.
Comment 4 Chandrasekar Kannan 2006-09-29 21:49:19 EDT
moving high/normal bugs to Target milestone 7.2(GA)
Comment 5 Chandrasekar Kannan 2006-10-17 13:41:46 EDT
per bug council on 10/17 - tfv=future
Comment 6 Chandrasekar Kannan 2006-11-21 00:53:17 EST
per bug council on 11/17, these bugs are not targeted for RHEL 5.0 Smart card
login work. These bugs will now be targeted for RHEL 5.1. 

Comment 7 Chandrasekar Kannan 2007-03-20 07:06:15 EDT
per the last bug meeting, we decided this would be targeted in the rhel 5.1
release. 
Comment 8 Bob Lord 2007-03-28 13:23:24 EDT
This bug was proposed for RHEL 5, but wasn't resolved in time.
    devel_ack+ for RHEL 5.1.
Comment 9 Jack Magne 2007-06-08 21:03:26 EDT
Addresssed in esc-1.0.0-27.el5 .

I got together with Thomas with TPS to decide upon more useful error messages.
The messages displayed by the internal ESC Xul application have been changed.
The error messages to be displayed during the guided enrollment portion external
HTML UI will have to be changed in TPS.
Comment 10 Jack Magne 2007-06-27 13:47:56 EDT
Modifying this one because ESC's own error strings have been changed as requested.
Comment 12 Jack Magne 2007-06-27 19:57:22 EDT
Test:

1. Launch esc.
2. Attempt the operations known to result in errors.
   *Attempt a format but type in incorrect LDAP auth credentials.
   *Attempt to enroll two unique tokens.
   * Attempt to perform an operation with no network.
   * Abort an operation by pulling out the token.

3. Observe that the error messages are clearer and more useful.
Comment 14 Jack Magne 2007-08-16 17:38:48 EDT
Yes you are correct. This bug was to overhaul many of the error messages in ESC.
Bug#206781 was a complaint about that one specific error. The error is , the
user already has an enrolled token and attempts to enroll a completely different
one.
Comment 17 Chandrasekar Kannan 2007-08-23 13:51:51 EDT
Verified on x86_64. rhel5 u1 snapshot#2- 20070809.5. 

1. Launch esc.
2. Attempt the operations known to result in errors.
   *Attempt a format but type in incorrect LDAP auth credentials.
   *Attempt to enroll two unique tokens.
   * Attempt to perform an operation with no network. 
   * Abort an operation by pulling out the token.

3. Observe that the error messages are clearer and more useful.

Also noticed that when trying to launch the phoneHome UI, by inserting a token,
without network caused no error messages. Filing a separate bug for that.


Comment 19 errata-xmlrpc 2007-11-07 11:57:26 EST
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on the solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2007-0634.html

Note You need to log in before you can comment on or make changes to this bug.