Bug 203472 - Crash on File->Properties change
Crash on File->Properties change
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: gnucash (Show other bugs)
rawhide
All Linux
medium Severity urgent
: ---
: ---
Assigned To: Bill Nottingham
:
: 212566 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-08-21 18:53 EDT by Frank de Lange
Modified: 2014-03-16 23:01 EDT (History)
2 users (show)

See Also:
Fixed In Version: 2.0.4-1.fc6
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-01-15 11:23:41 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
GNOME Desktop 352324 None None None Never

  None (edit)
Description Frank de Lange 2006-08-21 18:53:52 EDT
Gnucash 2.0.1 goes boom when I try to change the file properties using
File->Properties.

How to reproduce:
1. open gnucash (and load a file if needed)
2. open file properties window: File->Properties
3. enter something (what does not matter) in the 'Company Name' field (first
field in window)
4. activate the 'Apply' button

*BOOM* with the following backtrace:

In unknown file:
   ?:  0* [apply-cb]
In /usr/share/gnucash/guile-modules/gnucash/gnome-utils.scm:
  29:  1* [gnc:options-scm->kvp #<procedure dispatch #> # # ...]
In /usr/share/gnucash/scm/options.scm:
1471:  2  [scm->kvp #<gw:wcp <gnc:kvp-frame*> 0x9b53be8> ("options")]
In unknown file:
    ...
   ?:  3  [hash-for-each #<procedure #f (section hash)> #(() () (#) () ...)]
In /usr/share/guile/site/slib/hashtab.scm:
 120:  4  (do ((i (+ -1 #) (+ -1 i))) ((negative? i)) ...)
 122:  5* [alist-for-each #<procedure #f (section hash)> (("Business" . #))]
In /usr/share/guile/site/slib/alist.scm:
 117:  6  [for-each #<procedure #f (pair)> (("Business" . #(# # # ...)))]
In unknown file:
   ?:  7* [#<procedure #f (pair)> ("Business" . #((#) (#) (#) ...))]
In /usr/share/guile/site/slib/alist.scm:
 117:  8* [#<procedure #f (section hash)> "Business" #((#) (#) (#) () ...)]
In /usr/share/gnucash/scm/options.scm:
1299:  9  [section-for-each #((#) (#) (#) () ...) #<procedure #f (option)>]
In unknown file:
    ...
   ?: 10  [hash-for-each #<procedure #f (name option)> #((#) (#) (#) () ...)]
In /usr/share/guile/site/slib/hashtab.scm:
 120: 11  (do ((i (+ -1 #) (+ -1 i))) ((negative? i)) ...)
 122: 12* [alist-for-each #<procedure #f (name option)> (("Company Name" . #))]
In /usr/share/guile/site/slib/alist.scm:
 117: 13  [for-each #<procedure #f (pair)> (("Company Name" . #))]
In unknown file:
   ?: 14* [#<procedure #f (pair)> ("Company Name" . #)]
In /usr/share/guile/site/slib/alist.scm:
 117: 15* [#<procedure #f #> "Company Name" #]
In /usr/share/gnucash/scm/options.scm:
1295: 16  [#<procedure #f (option)> #("Business" "Company Name" "a" ...)]
    ...
 199: 17  [gnc:kvp-frame-set-slot-path # {"NUNX"} #]

/usr/share/gnucash/scm/options.scm:199:20: In procedure exact? in expression
(gnc:kvp-frame-set-slot-path f value ...):
/usr/share/gnucash/scm/options.scm:199:20: Wrong type argument in position 1: "NUNX"

Restarting gnucash gives a file lock warning, the lock file has to be deleted
manually to get everything back to normal. The file property change is not recorded.

expected result: no boom (duh)

Results obtained using latest fedora core development version running gnucash
2.0.1 built from r14585 on 2006-08-11.
Comment 1 Bill Nottingham 2006-08-22 12:01:26 EDT
Reproduced, comments added upstream.
Comment 2 Bill Nottingham 2006-10-27 11:24:57 EDT
*** Bug 212566 has been marked as a duplicate of this bug. ***
Comment 3 Fedora Update System 2007-01-09 11:54:22 EST
gnucash-2.0.4-1.fc6 has been pushed for fc6, which should resolve this issue.  If these problems are still present in this version, then please make note of it in this bug report.
Comment 4 Fedora Update System 2007-01-15 11:21:30 EST
gnucash-2.0.4-1.fc6 has been pushed for fc6, which should resolve this issue.  If these problems are still present in this version, then please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.