Bug 203487 - Too many files owned by piranha group
Summary: Too many files owned by piranha group
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: piranha (Show other bugs)
(Show other bugs)
Version: 5.0
Hardware: All Linux
medium
medium
Target Milestone: ---
: ---
Assignee: Stanko Kupcevic
QA Contact: Cluster QE
URL:
Whiteboard:
Keywords:
: 203939 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2006-08-21 23:42 UTC by Stanko Kupcevic
Modified: 2013-01-10 04:02 UTC (History)
5 users (show)

Fixed In Version: 5.0.0
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-11-28 21:07:20 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Stanko Kupcevic 2006-08-21 23:42:35 UTC
/etc/sysconfig/ha (with many files within) was owned by root:piranha
while the only file actualy modifiable by piranha was /etc/sysconfig/ha/lvs.cf

piranha.spec was updated from: 

%attr(-,root,piranha) %config(noreplace)  /etc/sysconfig/ha

to:

%dir                                            /etc/sysconfig/ha
%config(noreplace)                              /etc/sysconfig/ha/conf
%config(noreplace)                              /etc/sysconfig/ha/logs
%config(noreplace)                              /etc/sysconfig/ha/modules
%config(noreplace)                              /etc/sysconfig/ha/web
%attr(-,root,piranha) %config(noreplace)        /etc/sysconfig/ha/lvs.cf

with %defattr being (-,root,root)


This bug is to expose a change to broader audience.


This issue was fixed in 0.8.4-6

Comment 3 Stanko Kupcevic 2006-08-23 20:22:01 UTC
Fixed in piranha-0.8.4-7.el5

Comment 4 Stanko Kupcevic 2006-09-05 18:20:00 UTC
*** Bug 203939 has been marked as a duplicate of this bug. ***

Comment 5 Stanko Kupcevic 2006-09-05 18:23:50 UTC
Requesting fix for inclusion to RHEL5 Beta2

Comment 7 Benjamin Kahn 2006-09-14 19:09:32 UTC
The cluster-5.0 flag is going away....

Comment 11 Nate Straz 2007-12-13 17:30:54 UTC
Moving all RHCS ver 5 bugs to RHEL 5 so we can remove RHCS v5 which never existed.


Note You need to log in before you can comment on or make changes to this bug.