Bug 20361 - Cannot login to machine in multiuser mode after upgrade
Cannot login to machine in multiuser mode after upgrade
Status: CLOSED WORKSFORME
Product: Red Hat Linux
Classification: Retired
Component: authconfig (Show other bugs)
7.0
i686 Linux
high Severity high
: ---
: ---
Assigned To: Nalin Dahyabhai
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2000-11-05 09:21 EST by Tom Connelly
Modified: 2005-10-31 17:00 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-11-20 15:50:08 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Tom Connelly 2000-11-05 09:21:02 EST
Cannot login to machine in multiuser mode after upgrade from a Redhat 6.x
based system.  I have a dual processor system, 2 Celeron 400, Abit BP6 m/b,
192mb RAM, Adaptec aha1540CP scsi, isa modem, 3COM pci nic, Nvidia agp 32mb
TNT2 video, 8.4gb eide disk.

When I try to login after a successful upgrade, it flashes something like
invalid passwd and won't let root or anyone else login.  It shuts incoming
telnet out before can login, and rlogins too.  Rlogin message:

[tom@red-dwarf tom]$ rlogin beowulf
Password: 

Authentication service cannot retrieve user credentials
rlogin: connection closed.

-----
I can login in Single User mode, tried to change passwd, not fixed upon
reboot into multiuser.

THIS IS A MAJOR UPGRADE BUG!

Check your support forums.  I also see people getting this with a new
install and also upgrading from 5.x to 6.x.

Please let me know the fix?
Comment 1 Michael Fulbright 2000-11-07 14:15:37 EST
This is most likely a problem with authconfig.  If the system reboots then the
installer was successful.

Reassigning bug.
Comment 2 damonp 2000-11-20 12:31:46 EST
I am having this same problem after upgrading from 6.2 to 7.0.  The upgrade 
died at about 95% the first time(in x mode).  I re-ran in text mode and it 
completed.  However, now it will accept a username but never asks for a 
password and the screen clears and gives the login prompt again.  Telnet never 
gives a login prompt, only prints out the server sig.  SSH refuses all 
connections as well as samba, but ftp and email logins still work.

Several other problems on upgrade:

I was missing some required libraries (libgd for apache, I reinstalled it from 
an RPM and finally got apache up)

There were several errors about renaming files during the upgrade.

Samba config files were completely overwritten.



Basically the server is up and running serving html and email just fine, but no 
logins are allowed.  The only type of administration I can do is with Webmin 
(thank god for that!)
Comment 3 damonp 2000-11-20 13:05:35 EST
I fixed the problem! (for me at least)

/etc/pam.d/login no longer existed.  It was renamed as login.rpmsave.  I used 
webmin file manger to rename the file 'login' and it worked fine (not even a 
reboot needed).

This seems to be a problem with the installer renaming the file and then never 
saving the original file.
Comment 4 Nalin Dahyabhai 2000-11-20 15:50:05 EST
authconfig doesn't touch /etc/pam.d/login; this particular problem must be
occurring elsewhere.  Please see if applying the PAM update candidate in
http://people.redhat.com/nalin/test/ fixes this.
Comment 5 Nalin Dahyabhai 2001-06-26 02:01:35 EDT
Closed due to inactivity.

Note You need to log in before you can comment on or make changes to this bug.