Bug 203628 - some .so should be in -devel
some .so should be in -devel
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: kdepim (Show other bugs)
6
All Linux
medium Severity medium
: ---
: ---
Assigned To: Ngo Than
Ben Levenson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-08-22 15:29 EDT by Patrice Dumas
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-10-30 06:29:12 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Patrice Dumas 2006-08-22 15:29:11 EDT
Description of problem:

some .so should certainly be in -devel, like libkode.so and libkmime.so
and also some others.

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Ngo Than 2006-10-30 06:29:12 EST
it's fixed in kdepim-3.5.5-0.1.fc6 which is available in rawhide.
Comment 2 Patrice Dumas 2006-10-30 07:35:32 EST
There are still some .so in %_libdir, but since they have unversionned
soname, I guess the are here to be dlopened (like libremotekonnector.so).
I think they shouldn't be in %_libdir but somewhere below a subdir,
however this is more an upstream issue.

Note You need to log in before you can comment on or make changes to this bug.