Bug 203631 - gedit crashes
gedit crashes
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: gedit (Show other bugs)
5
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Ray Strode [halfline]
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-08-22 15:34 EDT by Marius ROMAN
Modified: 2008-01-08 08:12 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-01-08 08:12:21 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Marius ROMAN 2006-08-22 15:34:43 EDT
Description of problem:
I've made some RPM's by rebuilding (with -03 and -march=athlon64) some all gnome
-* packages.
All gnome-* packages (SRPMS) are from FC5/updates.

ex : 
libgnome-2.14.0-1
gnome-panel-devel-2.14.0-1
gnome-terminal-2.14.2-1

Also I've recompiled gtk2-2.8.20-1 with the same optimizations.
After this I wanted to open some file but gedit just crashes.

I run FC5/i386.

Version-Release number of selected component (if applicable):
gedit-2.14.3-1

How reproducible:
Always

Steps to Reproduce:
1.Compile all gnome-* packages with -O3 and other athlon64 specific
optimizations , after this launch gedit.
2.
3.
  
Actual results:
gedit crashes

Expected results:
gedit to work just fine.

Additional info:

Here is an backtrace : 
(gdb) bt
#0  0x0032a836 in gtk_text_insert () from /usr/lib/libgtk-x11-2.0.so.0
#1  0x0034494c in gtk_text_iter_ends_line () from /usr/lib/libgtk-x11-2.0.so.0
#2  0x00342d38 in gtk_text_iter_forward_to_line_end () from
/usr/lib/libgtk-x11-2.0.so.0
#3  0x00eea0b0 in init_gtk () from
/usr/lib/python2.4/site-packages/gtk-2.0/gtk/_gtk.so
#4  0x04932504 in PyEval_EvalFrame () from /usr/lib/libpython2.4.so.1.0
#5  0x049321d7 in PyEval_EvalFrame () from /usr/lib/libpython2.4.so.1.0
#6  0x049332c6 in PyEval_EvalCodeEx () from /usr/lib/libpython2.4.so.1.0
#7  0x048e507a in PyClassMethod_New () from /usr/lib/libpython2.4.so.1.0
#8  0x048cd507 in PyObject_Call () from /usr/lib/libpython2.4.so.1.0
#9  0x0492ca30 in PyEval_CallObjectWithKeywords () from /usr/lib/libpython2.4.so.1.0
#10 0x048ce08c in PyObject_CallObject () from /usr/lib/libpython2.4.so.1.0
#11 0x00e181a7 in initgobject () from
/usr/lib/python2.4/site-packages/gtk-2.0/gobject.so
#12 0x00bcff6d in g_closure_invoke () from /usr/lib/libgobject-2.0.so.0
#13 0x00be0a3d in g_signal_override_class_closure () from
/usr/lib/libgobject-2.0.so.0
#14 0x00be1f47 in g_signal_emit_valist () from /usr/lib/libgobject-2.0.so.0
#15 0x00be2109 in g_signal_emit () from /usr/lib/libgobject-2.0.so.0
#16 0x0806ed28 in gedit_debug_init ()
#17 0x00bcff6d in g_closure_invoke () from /usr/lib/libgobject-2.0.so.0
#18 0x00be0a3d in g_signal_override_class_closure () from
/usr/lib/libgobject-2.0.so.0
#19 0x00be1f47 in g_signal_emit_valist () from /usr/lib/libgobject-2.0.so.0
#20 0x00be2109 in g_signal_emit () from /usr/lib/libgobject-2.0.so.0
#21 0x0807248c in gedit_document_new ()
#22 0x08072a9b in gedit_document_new ()
#23 0x00a4c7b6 in g_source_get_current_time () from /usr/lib/libglib-2.0.so.0
#24 0x00a4c09d in g_main_context_dispatch () from /usr/lib/libglib-2.0.so.0
#25 0x00a4f32f in g_main_context_check () from /usr/lib/libglib-2.0.so.0
#26 0x00a4f6d9 in g_main_loop_run () from /usr/lib/libglib-2.0.so.0
#27 0x0029ed53 in gtk_main () from /usr/lib/libgtk-x11-2.0.so.0
#28 0x0806729b in main ()
Comment 1 Marius ROMAN 2006-08-24 15:12:52 EDT
It seems like a gtk2 bug , I've installed gtk2 (the official Fedora package from
updates) and gedit works again.

Comment 2 Till Maas 2008-01-08 08:12:21 EST
Imho this is not a bug within Fedora. Maybe gtk2 can be fixed by upstream, to
make compiling with -O3 work, but iirc, -O3 may break software, that works with -O2.

Note You need to log in before you can comment on or make changes to this bug.