Bug 203636 - recursive locking on bluetooth pairing
recursive locking on bluetooth pairing
Status: CLOSED WORKSFORME
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
rawhide
x86_64 Linux
medium Severity medium
: ---
: ---
Assigned To: Red Hat Kernel Manager
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-08-22 15:47 EDT by sean
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-08-22 19:24:44 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description sean 2006-08-22 15:47:38 EDT
Description of problem:
I'm trying to pair a nokia 770 with my desktop, updated to rawhide today. It fails.

/var/log/messages:

Aug 22 15:41:57 localhost hcid[24880]: pin_code_request (sba=00:02:72:C4:26:F1,
dba=00:12:37:46:DB:31)
Aug 22 15:41:57 localhost hcid[24880]: link_key_notify (sba=00:02:72:C4:26:F1,
dba=00:12:37:46:DB:31)
Aug 22 15:41:59 localhost kernel: 
Aug 22 15:41:59 localhost kernel: =============================================
Aug 22 15:41:59 localhost kernel: [ INFO: possible recursive locking detected ]
Aug 22 15:41:59 localhost kernel: 2.6.17-1.2573.fc6 #1
Aug 22 15:41:59 localhost kernel: ---------------------------------------------
Aug 22 15:41:59 localhost kernel: sdpd/24884 is trying to acquire lock:
Aug 22 15:41:59 localhost kernel:  (sk_lock-AF_BLUETOOTH){--..}, at:
[<ffffffff885622b8>] bt_accept_dequeue+0x37/0xfa [bluetooth]
Aug 22 15:41:59 localhost kernel: 
Aug 22 15:41:59 localhost kernel: but task is already holding lock:
Aug 22 15:41:59 localhost kernel:  (sk_lock-AF_BLUETOOTH){--..}, at:
[<ffffffff88584464>] l2cap_sock_accept+0x52/0x162 [l2cap]
Aug 22 15:41:59 localhost kernel: 
Aug 22 15:41:59 localhost kernel: other info that might help us debug this:
Aug 22 15:41:59 localhost kernel: 1 lock held by sdpd/24884:
Aug 22 15:41:59 localhost kernel:  #0:  (sk_lock-AF_BLUETOOTH){--..}, at:
[<ffffffff88584464>] l2cap_sock_accept+0x52/0x162 [l2cap]
Aug 22 15:41:59 localhost kernel: 
Aug 22 15:41:59 localhost kernel: stack backtrace:
Aug 22 15:41:59 localhost kernel: 
Aug 22 15:41:59 localhost kernel: Call Trace:
Aug 22 15:41:59 localhost kernel:  [<ffffffff8026e8fd>] show_trace+0xae/0x319
Aug 22 15:41:59 localhost kernel:  [<ffffffff8026eb7d>] dump_stack+0x15/0x17
Aug 22 15:41:59 localhost kernel:  [<ffffffff802a8278>] __lock_acquire+0x135/0xa64
Aug 22 15:41:59 localhost kernel:  [<ffffffff802a914a>] lock_acquire+0x4b/0x69
Aug 22 15:41:59 localhost kernel:  [<ffffffff802360ca>] lock_sock+0xd5/0xe7
Aug 22 15:41:59 localhost kernel:  [<ffffffff885622b8>]
:bluetooth:bt_accept_dequeue+0x37/0xfa
Aug 22 15:41:59 localhost kernel:  [<ffffffff88584528>]
:l2cap:l2cap_sock_accept+0x116/0x162
Aug 22 15:41:59 localhost kernel:  [<ffffffff8041f9cd>] sys_accept+0x102/0x1af
Aug 22 15:41:59 localhost kernel:  [<ffffffff8026058e>] system_call+0x7e/0x83
Aug 22 15:41:59 localhost kernel: DWARF2 unwinder stuck at system_call+0x7e/0x83
Aug 22 15:41:59 localhost kernel: Leftover inexact backtrace:
Aug 22 15:41:59 localhost kernel: 


Version-Release number of selected component (if applicable):

kernel-2.6.17-1.2573.fc6.x86_64

How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 sean 2006-08-22 19:24:44 EDT
turns out if you turn on ftp, no kernel error.

OTOH, the kernel shouldn't give serious errors for this.

sean

Note You need to log in before you can comment on or make changes to this bug.