Bug 203646 - PATCH: fix googleearth (and other apps) slowness on r300 driver using cards.
PATCH: fix googleearth (and other apps) slowness on r300 driver using cards.
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: mesa (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Adam Jackson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-08-22 16:24 EDT by Hans de Goede
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-08-22 18:20:59 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
PATCH fixing the described problems (584 bytes, patch)
2006-08-22 16:24 EDT, Hans de Goede
no flags Details | Diff
Improved version of the patch (722 bytes, patch)
2006-09-01 16:10 EDT, Hans de Goede
no flags Details | Diff

  None (edit)
Description Hans de Goede 2006-08-22 16:24:41 EDT
The attached patch comments this 1 line in r300_renderer.c:
FALLBACK_IF(ctx->Line.SmoothFlag); // GL_LINE_SMOOTH

the result of this is that if an application has requested anti-aliased lines,
which currently are not implemented in the r300 driver, the application gets
normal (not antialiased) lines instead of falling back to the software renderer.

This patch is needed to make googleearth and smc (http://www.secretmaryo.org/)
usable IMHO having none antialiased lines is way better then 2 fps.

The same could be argued for anti-aliased points (the line below this one), but
I haven't encountered any apps using this one yet.

Notice that this change was suggested by upstream and that upstream has even
concidered doing this themselves, they haven't however because they are planning
to fix this by actually implementing antialiased lines soon. In the mean time
however this is way way beter then 2 fps (or something around that speed).
Comment 1 Hans de Goede 2006-08-22 16:24:45 EDT
Created attachment 134669 [details]
PATCH fixing the described problems
Comment 2 Adam Jackson 2006-08-22 18:20:59 EDT
Ack!  Totally forgot about merging this.  Added in 6.5-25.*, thanks!
Comment 3 Hans de Goede 2006-08-23 00:03:07 EDT
Thanks!

I just wanted to say you rock! Now I (and hopefully lots of others) can enjoy
good working opensource hw accel 3D out of the box, yeah!
Comment 4 Hans de Goede 2006-09-01 16:10:34 EDT
Created attachment 135409 [details]
Improved version of the patch

As I was already afraid that would happen I've just encountered my first 2 apps
using GL_POINT_SMOOTH, causing once again 2-4 fps speeds. This is an updated
version of the patch adding the same workaround for points (iow draw them
aliased instead of SLOOOWWWWW) as the previous revision did for lines only.

Please replace the patch with this one, thanks!

Note You need to log in before you can comment on or make changes to this bug.