Bug 203663 - mount.ncp (mount -t ncp) cannot mount netware volumes
mount.ncp (mount -t ncp) cannot mount netware volumes
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
6
i386 Linux
medium Severity high
: ---
: ---
Assigned To: Dave Jones
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-08-22 17:13 EDT by claude
Modified: 2015-01-04 17:28 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-11-12 00:48:29 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description claude 2006-08-22 17:13:44 EDT
Description of problem:
Cannot mount a netware (6) volume; produces a message like: 

"mount.ncp: No such device in mount(2)"


Version-Release number of selected component (if applicable):
Tried older versions (from FC5 release) with same result.

How reproducible:
Yes. 

Steps to Reproduce:
1. Install actual ncpmount via yum or rpm
2. Have a nds netware server "SERVER1" running at ip address ADDRESS, a volume
SYS and a user USER1 with  password PWD

3. Try to mount a netware volume by:

> mount.ncp -S SERVER1 -A ADDRESS -V SYS -U USER1 -m -C -P PWD /mnt/tmp
  
Actual results:
Error as above: "mount.ncp: No such device in mount(2)"

Expected results:

a mounted volume  :-)

Additional info:
This works fine with FC5. The NCPFS version seems to be irrelevant, looks like a
kernel problem.
Comment 1 Martin Stransky 2006-08-28 08:33:51 EDT
okay, I'll check it.
Comment 2 claude 2006-09-15 14:28:40 EDT
(In reply to comment #1)
> okay, I'll check it.

can i provide further information or something helpful? 

tx,
Comment 3 Martin Stransky 2006-09-18 03:46:47 EDT
Thanks, but this package isn't included in RHEL-5 so it has quite low priority
now...
Comment 4 Martin Stransky 2006-09-19 04:07:29 EDT
reassigning to kernel...
Comment 5 Daniela Jung 2006-10-20 06:15:11 EDT
This bug seems to be the same as bug 211325.
The Kernel-Module "ncpfs.ko" is missing. 
Comment 6 Dave Jones 2006-10-21 02:06:12 EDT
fixed in cvs, will be in next update.
Comment 7 Dave Jones 2006-11-12 00:48:29 EST
should be fixed in 2.6.18-1.2849.fc6 now in updates

Note You need to log in before you can comment on or make changes to this bug.