Bug 203663 - mount.ncp (mount -t ncp) cannot mount netware volumes
Summary: mount.ncp (mount -t ncp) cannot mount netware volumes
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: kernel   
(Show other bugs)
Version: 6
Hardware: i386
OS: Linux
medium
high
Target Milestone: ---
Assignee: Dave Jones
QA Contact: Brian Brock
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2006-08-22 21:13 UTC by claude
Modified: 2015-01-04 22:28 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-11-12 05:48:29 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description claude 2006-08-22 21:13:44 UTC
Description of problem:
Cannot mount a netware (6) volume; produces a message like: 

"mount.ncp: No such device in mount(2)"


Version-Release number of selected component (if applicable):
Tried older versions (from FC5 release) with same result.

How reproducible:
Yes. 

Steps to Reproduce:
1. Install actual ncpmount via yum or rpm
2. Have a nds netware server "SERVER1" running at ip address ADDRESS, a volume
SYS and a user USER1 with  password PWD

3. Try to mount a netware volume by:

> mount.ncp -S SERVER1 -A ADDRESS -V SYS -U USER1 -m -C -P PWD /mnt/tmp
  
Actual results:
Error as above: "mount.ncp: No such device in mount(2)"

Expected results:

a mounted volume  :-)

Additional info:
This works fine with FC5. The NCPFS version seems to be irrelevant, looks like a
kernel problem.

Comment 1 Martin Stransky 2006-08-28 12:33:51 UTC
okay, I'll check it.

Comment 2 claude 2006-09-15 18:28:40 UTC
(In reply to comment #1)
> okay, I'll check it.

can i provide further information or something helpful? 

tx,

Comment 3 Martin Stransky 2006-09-18 07:46:47 UTC
Thanks, but this package isn't included in RHEL-5 so it has quite low priority
now...

Comment 4 Martin Stransky 2006-09-19 08:07:29 UTC
reassigning to kernel...

Comment 5 Daniela Jung 2006-10-20 10:15:11 UTC
This bug seems to be the same as bug 211325.
The Kernel-Module "ncpfs.ko" is missing. 


Comment 6 Dave Jones 2006-10-21 06:06:12 UTC
fixed in cvs, will be in next update.


Comment 7 Dave Jones 2006-11-12 05:48:29 UTC
should be fixed in 2.6.18-1.2849.fc6 now in updates


Note You need to log in before you can comment on or make changes to this bug.