Bug 203755 - frequent crashes in oowriter
frequent crashes in oowriter
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: openoffice.org (Show other bugs)
5
x86_64 Linux
medium Severity high
: ---
: ---
Assigned To: Caolan McNamara
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-08-23 12:22 EDT by Neal Becker
Modified: 2007-11-30 17:11 EST (History)
4 users (show)

See Also:
Fixed In Version: FC-6
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-01-04 10:48:05 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Crash information from 2174_FC5 kernel (17.77 KB, text/plain)
2006-09-06 03:17 EDT, Billy Lieurance
no flags Details
Crash information from 2157_FC5 kernel (12.81 KB, text/plain)
2006-09-06 03:18 EDT, Billy Lieurance
no flags Details
debugging info generated by OpenOffice upon crash (3.55 KB, text/plain)
2006-09-06 11:53 EDT, Jonathan Slavin
no flags Details
ooo-writer crash on kernel 2.6.17-1.2174_FC (6.07 KB, text/plain)
2006-09-07 11:03 EDT, David Johnston
no flags Details
32-bit OpenOffice crash log (6.18 KB, text/plain)
2006-09-08 22:09 EDT, TonyCrouch
no flags Details

  None (edit)
Description Neal Becker 2006-08-23 12:22:01 EDT
Description of problem:

oowriter is crashing frequently.
Video Driver is probably: ati
Desktop is: not GNOME
libgcj version is: libgcj-4.1.1-1.fc5 libgcj-4.1.1-1.fc5
kernel is: Linux 2.6.17-1.2174_FC5 #1 SMP Tue Aug 8 15:30:44 EDT 2006 x86_64 
x86_64 x86_64
OpenOffice.org core rpm version is: openoffice.org-core-2.0.2-5.17.2
accessibility is: false
...start sestatus details ...
SELinux status:                 disabled
...end sestatus details ...
0x2cb8640: /usr/lib/openoffice.org2.0/program/libuno_sal.so.3 + 0x1e640
0x2cb8e80: /usr/lib/openoffice.org2.0/program/libuno_sal.so.3 + 0x1ee80
0xffffe500:  + 0x500 (__kernel_sigreturn + 0x0)

Version-Release number of selected component (if applicable):
openoffice.org-writer-2.0.2-5.17.2

How reproducible:

Frequent, but not sure how to trigger.

Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Caolan McNamara 2006-08-29 15:18:27 EDT
Does this happen to you still ? Sometimes I wonder about e.g. interrupted
prelinking operations, e.g. remove OOo and reinstall it. Otherwise I'll sit down
and do a valgrind of OOo startup
Comment 2 Caolan McNamara 2006-09-04 09:16:55 EDT
202165 is a similar bug, and there we've discovered that ldd
/usr/lib/openoffice.org/program/soffice.bin shows that it's linked to a
different libstdc++ in /usr/local/lib, not the correct one in
/usr/lib/libstdc++, can you check this in your install ?
Comment 3 Neal Becker 2006-09-04 19:23:23 EDT
No, nothing like that here.
Comment 4 Caolan McNamara 2006-09-05 04:29:21 EDT
So your crash..
a) happens only on startup of office
b) happens sometimes but not always
c) and is a 32bit OOo on x86_64
Comment 5 Eryk Laskowski 2006-09-05 17:27:52 EDT
The same problem has appeared in my system recently. OpenOffice started to crash
about two days ago, the log messages are similar:
Video Driver is probably: fglrx
Desktop is: GNOME
libgcj version is: libgcj-4.1.1-1.fc5 libgcj-4.1.1-1.fc5
kernel is: Linux 2.6.17-1.2174_FC5 #1 SMP Tue Aug 8 15:30:44 EDT 2006 x86_64
x86_64 x86_64
OpenOffice.org core rpm version is: openoffice.org-core-2.0.2-5.17.2
accessibility is: false
...start sestatus details ...
SELinux status:                 enabled
SELinuxfs mount:                /selinux
Current mode:                   permissive
Mode from config file:          permissive
Policy version:                 20
Policy from config file:        targeted
...end sestatus details ...
0xf65d7640: /usr/lib/openoffice.org2.0/program/libuno_sal.so.3 + 0x1e640
0xf65d7e80: /usr/lib/openoffice.org2.0/program/libuno_sal.so.3 + 0x1ee80
0xffffe500:  + 0x500 (__kernel_sigreturn + 0x0)

It is not closely related to my current ooffice version: when it started to
crash I had the previous version (2.0.2-5.9), then I updated but it didn't help.
Comment 6 Billy Lieurance 2006-09-06 03:16:06 EDT
I am having a suspiciously similar problem, but with a few key differences:

1.  It's in the spreadsheet component of openoffice.  The crash happens when I
try to right-click on a chart I'm editing.  I've gotten it to repeat several
times at the same point.  I start, recover my saved file, choose to edit the
chart, and right click.  OOO hangs for about 5 seconds, then crashes.
2.  I am running a 32-bit system (athlon).
3.  I've replicated the problem as root, and on the 2154_FC5 kernel.
4.  I can verify that the binary is linked to /usr/lib/libstdc++

Otherwise, it seems to be the same routine in libuno_sal.so.3.  Dumps are
attached below, one for each kernel version.

Comment 7 Billy Lieurance 2006-09-06 03:17:44 EDT
Created attachment 135630 [details]
Crash information from 2174_FC5 kernel
Comment 8 Billy Lieurance 2006-09-06 03:18:28 EDT
Created attachment 135631 [details]
Crash information from 2157_FC5 kernel
Comment 9 Caolan McNamara 2006-09-06 03:33:05 EDT
caolanm->Billy: no, your traces are quite different entirely. Your problem is an
OOo one trigged by a new db4 I believe. see bug 205315
Comment 10 Jonathan Slavin 2006-09-06 11:53:58 EDT
Created attachment 135663 [details]
debugging info generated by OpenOffice upon crash
Comment 11 Caolan McNamara 2006-09-06 12:14:34 EDT
caolanm->Jonathan Slavin: no, your traces are quite different entirely. Your
problem is triggered by the new db4, see bug 205315
Comment 12 David Johnston 2006-09-07 11:00:22 EDT
I just updated to openoffice.org-writer-2.0.2-5.17.2.i386.rpm and now I'm seeing
crashes.  This is the first time I've used this version.  I started writer,
pasted text from evolution, selected all text, cut, "pasted special" as
unformatted text, did some minor formatting, and hit print.  When the printer
started, I closed the window (by clicking on the X in the windowframe, if it
matters).  When the "save-discard-cancel" popup appeared, I clicked on "Discard."  

I got an "OOo has crashed!  Please paste this text into your bugreport" popup; I
will attach it here.
Comment 13 David Johnston 2006-09-07 11:03:12 EDT
Created attachment 135774 [details]
ooo-writer crash on kernel 2.6.17-1.2174_FC
Comment 14 Caolan McNamara 2006-09-07 11:16:42 EDT
caolanm->David: Sorry, but everyone seems to be jumping onto this bug with their
recent crasher, probably because it's the only open OOo crasher bug. But
actually whatever this original bugzilla problem is preceeds the recent ucbhelp
problem which is triggered by db4 and fixed in db4 again for FC-5, see bug 205315
Comment 15 TonyCrouch 2006-09-08 22:09:36 EDT
Created attachment 135895 [details]
32-bit OpenOffice crash log

Hi All, 
Thought I would add my OpenOffice.org crash log to help with fixing this bug.
While the report specifies 64bit systems, as mine is a 32bit system. I thought
it may help.

If you prefer I clone this bug and create a 32bit version just let me know and
I will.

Cheers, 
TC
Comment 16 Caolan McNamara 2006-09-09 07:56:27 EDT
caolanm->TonyCrouch: Sorry, but everyone seems to be jumping onto this bug with
their recent crasher, probably because it's the only open OOo crasher bug. But
actually whatever this original bugzilla problem is preceeds the recent ucbhelp
problem which is triggered by db4 and fixed in db4 again for FC-5, see bug 205315

Comment 17 Caolan McNamara 2007-01-04 10:48:05 EST
re: comments #1 to #4, i.e. the orig problem. I've been unable to ever reproduce
this problem, or otherwise find a solution to it. Nevertheless in the meantime
FC-6 was released which has a native x86_64 64bit OOo, and there haven't been
any similar reports there. So hopefully the problem from that perspective has
"gone away". 

Feel free to reopen (re comments #1->#4) if there is more information or any new
insights.

Note You need to log in before you can comment on or make changes to this bug.