Bug 203782 - Error updating to setroubleshoot-0.30-1
Error updating to setroubleshoot-0.30-1
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: setroubleshoot (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: John Dennis
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-08-23 14:15 EDT by Pete Graner
Modified: 2007-11-30 17:11 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-09-28 14:35:15 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Pete Graner 2006-08-23 14:15:01 EDT
Description of problem: running yum update setroubleshoot reports error


Version-Release number of selected component (if applicable): (
setroubleshoot-0.30-1


How reproducible: Only if setroubleshoot is previously installed. 

[pgraner@meatwad ~]$ yum update setroubleshoot
Loading "installonlyn" plugin
Setting up Update Process
Setting up repositories
extras-development        100% |=========================| 1.1 kB    00:00     
development               100% |=========================| 1.1 kB    00:00     
Reading repository metadata in from local files
Resolving Dependencies
--> Populating transaction set with selected packages. Please wait.
---> Downloading header for setroubleshoot to pack into transaction set.
setroubleshoot-0.30-1.noa 100% |=========================|  49 kB    00:00     
---> Package setroubleshoot.noarch 0:0.30-1 set to be updated
--> Running transaction check

Dependencies Resolved

=============================================================================
 Package                 Arch       Version          Repository        Size 
=============================================================================
Updating:
 setroubleshoot          noarch     0.30-1           development       248 k

Transaction Summary
=============================================================================
Install      0 Package(s)         
Update       1 Package(s)         
Remove       0 Package(s)         

Total download size: 248 k
Downloading Packages:
(1/1): setroubleshoot-0.3 100% |=========================| 248 kB    00:01     
Running Transaction Test
Finished Transaction Test
Transaction Test Succeeded
Running Transaction
  Updating  : setroubleshoot               ######################### [1/2] 
error: %post(setroubleshoot-0.30-1.noarch) scriptlet failed, exit status 1

Updated: setroubleshoot.noarch 0:0.30-1
Complete!
Comment 1 John Dennis 2006-08-25 14:39:04 EDT
I wonder if this could be caused by the %postuntrigger which may not return a 0
status thus the script appears to fail, I'll have to investigate. I think one
can get bitten by the last command executed by any scriptlet should it not return 0.
Comment 2 Daniel Walsh 2006-09-28 14:35:15 EDT
We are not seeing this now.  Possibly selinux related.

Note You need to log in before you can comment on or make changes to this bug.