Bug 203800 - sitedir should point to /usr/lib/site_ruby and not /usr/lib64/site_ruby
sitedir should point to /usr/lib/site_ruby and not /usr/lib64/site_ruby
Status: CLOSED DEFERRED
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: ruby (Show other bugs)
4.4
x86_64 Linux
medium Severity medium
: ---
: ---
Assigned To: Akira TAGOH
BaseOS QE
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-08-23 15:45 EDT by Kostas Georgiou
Modified: 2010-06-22 02:41 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-06-22 02:41:33 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Kostas Georgiou 2006-08-23 15:45:08 EDT
sitedir should point to /usr/lib/site_ruby, as it is it's impossible to have a
ruby noarch rpm.

$ ruby -rrbconfig -e "puts Config::CONFIG['sitedir']"
/usr/lib64/site_ruby
Comment 1 Kostas Georgiou 2006-10-20 08:38:06 EDT
ping
Comment 2 Matt Hyclak 2006-11-21 16:59:12 EST
Seems this was fixed in Fedora (#184199). Any chance this will be fixed in a
future release of RHEL?

Comment 3 Kostas Georgiou 2006-11-21 17:28:54 EST
Yes it's already fixed in Fedora so RHEL5 should be OK (I haven't checked yet
though). For RHEL4 I am recompiling the Fedora rpms which solves the problem but
obviously a "supported" fix from RedHat would be nice. 
Comment 4 Akira TAGOH 2006-11-21 23:27:12 EST
Yes, RHEL5's ruby is exactly the same as FC6's. so that should works as I didn't
get any bugs on FC6 :)
For RHEL4 updates, it's too late to propose an update for RHEL4.5 now. so we'll
propose this for next next update. just FYI.
Comment 6 RHEL Product and Program Management 2008-02-01 14:12:32 EST
This request was evaluated by Red Hat Product Management for
inclusion, but this component is not scheduled to be updated in
the current Red Hat Enterprise Linux release. If you would like
this request to be reviewed for the next minor release, ask your
support representative to set the next rhel-x.y flag to "?".
Comment 7 Jens Petersen 2010-06-22 02:41:33 EDT
Closing since looks like this will not get fixed in RHEL4 longlife.

Note You need to log in before you can comment on or make changes to this bug.