This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 203814 - Error after reinstallation of Eclipse - "No application id has been found"
Error after reinstallation of Eclipse - "No application id has been found"
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: eclipse (Show other bugs)
5
All Linux
medium Severity medium
: ---
: ---
Assigned To: Ben Konrath
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-08-23 16:27 EDT by Alexey Titov
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-09-06 15:19:00 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
Log file of eclipse (18.39 KB, text/plain)
2006-08-23 16:27 EDT, Alexey Titov
no flags Details
Eclipse's log file with gcj (18.21 KB, text/plain)
2006-08-26 04:44 EDT, Alexey Titov
no flags Details

  None (edit)
Description Alexey Titov 2006-08-23 16:27:57 EDT
Created attachment 134754 [details]
Log file of eclipse
Comment 1 Alexey Titov 2006-08-23 16:27:57 EDT
Description of problem:
I installed Eclipse on Fedora 5. After the first installation all worked fine.
But then I removed eclipse's rpms and installed them again. Now when I try to
start Eclipse the following error occurs:
java.lang.RuntimeException: No application id has been found

Version-Release number of selected component (if applicable):
3.1.2

Steps to Reproduce:
1.Install eclipse
2.Uninstall eclipse
3.Install again
4.Try to run
  
Actual results:
The following error message:
An error has occurred. See the log file
/home/alex/.eclipse/org.eclipse.platform_3.1.2/configuration/1156355313645.log

Expected results:
Running Eclipse..

Additional info:
Here is the list of packages that I installed:
eclipse-platform-3.1.2-1jpp_15fc 
eclipse-rcp-3.1.2-1jpp_15fc 
eclipse-jdt-3.1.2-1jpp_15fc 
eclipse-ecj-3.1.2-1jpp_15fc 
tomcat5-common-lib-5.5.15-1jpp_6fc.i386 
tomcat5-5.5.15-1jpp_6fc.i386
Comment 2 Ben Konrath 2006-08-25 11:20:18 EDT
Can you try running Eclipse with GCJ and post the error log? We don't support
running Eclipse with proprietary VMs. Thanks. 
Comment 3 Alexey Titov 2006-08-26 04:43:04 EDT
I don't think this is because of java...
But here it is. 
Comment 4 Alexey Titov 2006-08-26 04:44:05 EDT
Created attachment 134973 [details]
Eclipse's log file with gcj
Comment 5 Ben Konrath 2006-09-05 18:29:23 EDT
Can you try removing all of the eclipse packages:

yum remove libswt3-gtk2 eclipse-ecj

After you do that make sure that /usr/share/eclipse and /usr/lib/eclipse have
been removed. If they haven't been, remove them. Finally reinstall everything:

yum install eclipse-pde-devel

If you still have problems, try running 'rpm --verify' on all of the eclipse
packages to ensure they are installed correctly. Let know how this goes. 
Comment 6 Alexey Titov 2006-09-06 00:52:58 EDT
After installation of eclipse-platform-3.1.2-1jpp_13fc,
eclipse-rcp-3.1.2-1jpp_13fc, eclipse-jdt-3.1.2-1jpp_13fc and
eclipse-ecj-3.1.2-1jpp_13fc everything works. But now pup suggests me updates of
these packages to "newer" versions (_15fc instead of _13fc). I do not want to
experiment any more! I think, these versions will never work!
Are you planing to include Eclipse 3.2 packages in Fedora?
Comment 7 Ben Konrath 2006-09-06 09:43:03 EDT
(In reply to comment #6)
> After installation of eclipse-platform-3.1.2-1jpp_13fc,
> eclipse-rcp-3.1.2-1jpp_13fc, eclipse-jdt-3.1.2-1jpp_13fc and
> eclipse-ecj-3.1.2-1jpp_13fc everything works. But now pup suggests me updates of
> these packages to "newer" versions (_15fc instead of _13fc). 

Great! If you are satisfied can you please close the bug?

> I do not want to
> experiment any more! I think, these versions will never work!

They work for me, so 'never' is a little strong ;)

> Are you planing to include Eclipse 3.2 packages in Fedora?

Yes, FC-6 will have Eclipse 3.2.

Note You need to log in before you can comment on or make changes to this bug.