Bug 203834 - logged in as a local user, smartcard is inserted, screen locks, unlocking wants smartcard password rather than local user password
logged in as a local user, smartcard is inserted, screen locks, unlocking wan...
Status: CLOSED DUPLICATE of bug 203335
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: pam_pkcs11 (Show other bugs)
5.0
All Linux
medium Severity medium
: ---
: ---
Assigned To: Bob Relyea
:
Depends On:
Blocks: 181509
  Show dependency treegraph
 
Reported: 2006-08-23 17:57 EDT by Suzanne Hillman
Modified: 2007-11-30 17:07 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-09-13 02:57:57 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Suzanne Hillman 2006-08-23 17:57:31 EDT
Description of problem:
If logged in as a local user, with a smartcard inserted later (such as in the
case of wanting to enroll a new card), and the screen locks, unlocking wants
smartcard password rather than local user password. This seems very bad! It
should ask for the password of the person who actually logged in, not of the
card that it can't yet handle (note: the card in question was enrolled with a
previously existing Cert server, which may have confused things).

Version-Release number of selected component (if applicable):
gdm-2.15.10-1.fc6

How reproducible:
Always

Steps to Reproduce:
1. get a smartcard which has been enrolled, but not with the cert server whose
info is known to esc
2. log in as a local user, and then insert the smartcard
3. have the screen lock, and try to log back in
  
Actual results:
It'll ask for the smartcard password (which is unlikely to work, since it's not
yet correctly enrolled).

Expected results:
Ask for the password of the local user who actually logged in!

Additional info:
Comment 1 Bob Relyea 2006-09-12 19:48:03 EDT
This is an unintended side effect of the semantic in bug 204978. In this case it
is a bug.
Comment 2 Tomas Mraz 2006-09-13 02:57:57 EDT
This is clearly a duplicate.


*** This bug has been marked as a duplicate of 203335 ***

Note You need to log in before you can comment on or make changes to this bug.