This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 203889 - D-Link DGE-528T PCI Gigabit network adapter not supported
D-Link DGE-528T PCI Gigabit network adapter not supported
Status: CLOSED DUPLICATE of bug 181653
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: kernel (Show other bugs)
4.4
All Linux
medium Severity medium
: ---
: ---
Assigned To: John W. Linville
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-08-24 04:29 EDT by Juanjo Villaplana
Modified: 2007-11-16 20:14 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-11-30 10:33:35 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Juanjo Villaplana 2006-08-24 04:29:19 EDT
Description of problem:

D-Link DGE-528T PCI Gigabit network adapter not supported by kernel. This is a
Realtek 8169 based card and should be supported by r8169 kernel module.

Version-Release number of selected component (if applicable):

2.6.9-42.0.2.EL

How reproducible:

Install a DGE-528T on a system and run "modprobe r8169", this card is not
recognized.

Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:

Adding the PCI ids to r8169.c solves this problem:

-------------------------------------------------------
--- linux-2.6.9/drivers/net/r8169.c.orig        2006-07-08 10:19:16.000000000 +0200
+++ linux-2.6.9/drivers/net/r8169.c     2006-08-10 13:16:00.000000000 +0200
@@ -150,6 +150,7 @@

 static struct pci_device_id rtl8169_pci_tbl[] = {
        {0x10ec, 0x8169, PCI_ANY_ID, PCI_ANY_ID, 0, 0, 0},
+       {0x1186, 0x4300, PCI_ANY_ID, PCI_ANY_ID, 0, 0, 0},
        {0,},
 };

-------------------------------------------------------
Comment 1 Jason Baron 2006-11-30 10:33:35 EST

*** This bug has been marked as a duplicate of 181653 ***

Note You need to log in before you can comment on or make changes to this bug.