Bug 203899 - [C syntax coloring] Local variable returning macro breaks syntax coloring.
[C syntax coloring] Local variable returning macro breaks syntax coloring.
Status: CLOSED DUPLICATE of bug 203577
Product: Fedora
Classification: Fedora
Component: vim (Show other bugs)
5
All Linux
medium Severity medium
: ---
: ---
Assigned To: Karsten Hopp
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-08-24 07:33 EDT by Gilboa Davara
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-08-24 09:08:37 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
Sample header file. (545 bytes, text/plain)
2006-08-24 07:33 EDT, Gilboa Davara
no flags Details

  None (edit)
Description Gilboa Davara 2006-08-24 07:33:56 EDT
Description of problem:
Both vim6.x and vim7 seem to generate invalid syntax coloring once a
local value returning macro is used.(E.g. #define XXX(X) ({ int __x = X;
__x; }) )
Please view the attached header file.

Version-Release number of selected component (if applicable):
vim-enhanced-7.0.042-0.fc5.x86_64

How reproducible:
Always.

Steps to Reproduce:
1. Open attached header file.
2.
3.
  
Actual results:
Invalid syntax coloring post macro definition.

Expected results:
Valid syntax (and match brace checking) post macro definition.

Additional info:
Also reported upstream to vim@vim.org
No BZ number. (Do they have BZ?)
Comment 1 Gilboa Davara 2006-08-24 07:33:58 EDT
Created attachment 134800 [details]
Sample header file.
Comment 2 Karsten Hopp 2006-08-24 09:08:37 EDT

*** This bug has been marked as a duplicate of 203577 ***
Comment 3 Gilboa Davara 2006-08-24 09:41:48 EDT
I should really improve my search skills :(

Note You need to log in before you can comment on or make changes to this bug.