Bug 203951 - Wrong texture target for power-of-two pixmaps with aiglx tfp
Summary: Wrong texture target for power-of-two pixmaps with aiglx tfp
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: compiz   
(Show other bugs)
Version: rawhide
Hardware: All Linux
medium
medium
Target Milestone: ---
Assignee: Kristian Høgsberg
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2006-08-24 17:29 UTC by Kristian Høgsberg
Modified: 2007-11-30 22:11 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-08-29 00:11:55 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Kristian Høgsberg 2006-08-24 17:29:03 UTC
ARGB Windows that have power-of-two dimensions comes up white, because aiglx and
compiz disagree on the texture target the pixmap should be bound to.

Comment 1 Kristian Høgsberg 2006-08-29 00:11:55 UTC
Fixed (worked-around) in rawhide.  Need to fix properly upstream so that the GLX
provider can communicate GLX drawable attributes back to the GLX dispatch code.


Note You need to log in before you can comment on or make changes to this bug.