Bug 203987 - When id/pass authentication fails for RH bugzilla, internal error occures and can't re-enter id/pass
When id/pass authentication fails for RH bugzilla, internal error occures and...
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: eclipse-bugzilla (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Jonathan Blandford
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-08-24 16:23 EDT by Kyu Lee
Modified: 2013-04-02 00:21 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-09-11 10:20:55 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Kyu Lee 2006-08-24 16:23:41 EDT
Description of problem:

If wrong id/pass information is entered to a dialog that appears 
when clicking on a bug, Internal error occures. Then I was expecting
a id/pass dialog for re-trying, but it throws internal error instead.

To re enter id/pass, have to remove the bug system and re-add it with
correct id/pass.


How reproducible:

Always.

Steps to Reproduce:
1. Add a Red Hat bug system without id/password.
2. Create a query(any query with at leat one bug).
3. Click on a bug to refresh and fetch data.
4. Enter wrong id/password.
  
Actual results:

An internal error occured during:"Background Refresh".

Expected results:

An option to re-enter id/pass with informing the user
that id/pass is incorrect.
Comment 1 Kyu Lee 2006-08-24 16:28:54 EDT
org.apache.xmlrpc.XmlRpcClientException: Error decoding XML-RPC response
        at org.apache.xmlrpc.XmlRpcClientResponseProcessor.decodeResponse(Ljava.
io.InputStream;)Ljava.lang.Object;(Unknown Source)
        at org.apache.xmlrpc.XmlRpcClientWorker.execute(Lorg.apache.xmlrpc.XmlRp
cClientRequest;Lorg.apache.xmlrpc.XmlRpcTransport;)Ljava.lang.Object;(Unknown So
urce)
        at org.apache.xmlrpc.XmlRpcClient.execute(Lorg.apache.xmlrpc.XmlRpcClien
tRequest;Lorg.apache.xmlrpc.XmlRpcTransport;)Ljava.lang.Object;(Unknown Source)
        at org.apache.xmlrpc.XmlRpcClient.execute(Lorg.apache.xmlrpc.XmlRpcClien
tRequest;)Ljava.lang.Object;(Unknown Source)
        at org.apache.xmlrpc.XmlRpcClient.execute(Ljava.lang.String;Ljava.util.V
ector;)Ljava.lang.Object;(Unknown Source)
        at org.eclipse.team.bugzilla.operations.BugzillaOperations_RH.getReportD
ata(Lorg.eclipse.core.runtime.IProgressMonitor;Lorg.eclipse.team.bugzilla.model.
BugzillaConfiguration;Ljava.lang.String;)Lorg.eclipse.team.bugzilla.datatypes.Re
portData;(Unknown Source)
        at org.eclipse.team.bugzilla.operations.CachedOperations.getReportData(L
org.eclipse.core.runtime.IProgressMonitor;Ljava.lang.String;)Lorg.eclipse.team.b
ugzilla.datatypes.ReportData;(Unknown Source)
        at org.eclipse.team.bugzilla.datatypes.DataCache.refreshReports([Ljava.l
ang.String;Lorg.eclipse.core.runtime.IProgressMonitor;)V(Unknown Source)
        at org.eclipse.team.bugzilla.model.BugzillaReport.refresh(Lorg.eclipse.c
ore.runtime.IProgressMonitor;)V(Unknown Source)
        at org.eclipse.team.bugzilla.operations.RefreshOperation.fetch(Lorg.ecli
pse.team.bugzilla.model.IRemoteModel;Lorg.eclipse.core.runtime.IProgressMonitor;
)V(Unknown Source)
        at org.eclipse.team.bugzilla.operations.RefreshOperation.fetchElement(Lo
rg.eclipse.team.bugzilla.model.IRemoteModel;Lorg.eclipse.core.runtime.IProgressM
onitor;)V(Unknown Source)
        at org.eclipse.team.bugzilla.operations.RefreshOperation.run(Lorg.eclips
e.core.runtime.IProgressMonitor;)V(Unknown Source)
        at org.eclipse.team.bugzilla.view.DelayedRefreshPresenter.doDispatchEven
ts(Lorg.eclipse.core.runtime.IProgressMonitor;)Z(Unknown Source)
        at org.eclipse.team.internal.core.BackgroundEventHandler.dispatchEvents(
BackgroundEventHandler.java:354)
        at org.eclipse.team.internal.core.BackgroundEventHandler.processEvents(B
ackgroundEventHandler.java:334)
        at org.eclipse.team.internal.core.BackgroundEventHandler$1.run(Backgroun
dEventHandler.java:173)
        at org.eclipse.core.internal.jobs.Worker.run(Worker.java:58)
Caused by: org.apache.xmlrpc.XmlRpcClientException: Error decoding XML-RPC excep
tion response
        at org.apache.xmlrpc.XmlRpcClientResponseProcessor.decodeException(Ljava
.lang.Object;)Lorg.apache.xmlrpc.XmlRpcException;(Unknown Source)
        ... 17 more
Caused by: java.lang.NumberFormatException: For input string: "Server"
        at java.lang.NumberFormatException.forInputString(NumberFormatException.
java:48)
        at java.lang.Integer.parseInt(Integer.java:468)
        at java.lang.Integer.parseInt(Integer.java:518)
        ... 18 more
org.apache.xmlrpc.XmlRpcClientException: Error decoding XML-RPC response
        at org.apache.xmlrpc.XmlRpcClientResponseProcessor.decodeResponse(Ljava.
io.InputStream;)Ljava.lang.Object;(Unknown Source)
        at org.apache.xmlrpc.XmlRpcClientWorker.execute(Lorg.apache.xmlrpc.XmlRp
cClientRequest;Lorg.apache.xmlrpc.XmlRpcTransport;)Ljava.lang.Object;(Unknown So
urce)
        at org.apache.xmlrpc.XmlRpcClient.execute(Lorg.apache.xmlrpc.XmlRpcClien
tRequest;Lorg.apache.xmlrpc.XmlRpcTransport;)Ljava.lang.Object;(Unknown Source)
        at org.apache.xmlrpc.XmlRpcClient.execute(Lorg.apache.xmlrpc.XmlRpcClien
tRequest;)Ljava.lang.Object;(Unknown Source)
        at org.apache.xmlrpc.XmlRpcClient.execute(Ljava.lang.String;Ljava.util.V
ector;)Ljava.lang.Object;(Unknown Source)
        at org.eclipse.team.bugzilla.operations.BugzillaOperations_RH.getReportD
ata(Lorg.eclipse.core.runtime.IProgressMonitor;Lorg.eclipse.team.bugzilla.model.
BugzillaConfiguration;Ljava.lang.String;)Lorg.eclipse.team.bugzilla.datatypes.Re
portData;(Unknown Source)
        at org.eclipse.team.bugzilla.operations.CachedOperations.getReportData(L
org.eclipse.core.runtime.IProgressMonitor;Ljava.lang.String;)Lorg.eclipse.team.b
ugzilla.datatypes.ReportData;(Unknown Source)
        at org.eclipse.team.bugzilla.datatypes.DataCache.refreshReports([Ljava.l
ang.String;Lorg.eclipse.core.runtime.IProgressMonitor;)V(Unknown Source)
        at org.eclipse.team.bugzilla.model.BugzillaReport.refresh(Lorg.eclipse.c
ore.runtime.IProgressMonitor;)V(Unknown Source)
        at org.eclipse.team.bugzilla.operations.RefreshOperation.fetch(Lorg.ecli
pse.team.bugzilla.model.IRemoteModel;Lorg.eclipse.core.runtime.IProgressMonitor;
)V(Unknown Source)
        at org.eclipse.team.bugzilla.operations.RefreshOperation.fetchElement(Lo
rg.eclipse.team.bugzilla.model.IRemoteModel;Lorg.eclipse.core.runtime.IProgressM
onitor;)V(Unknown Source)
        at org.eclipse.team.bugzilla.operations.RefreshOperation.run(Lorg.eclips
e.core.runtime.IProgressMonitor;)V(Unknown Source)
        at org.eclipse.team.bugzilla.view.DelayedRefreshPresenter.doDispatchEven
ts(Lorg.eclipse.core.runtime.IProgressMonitor;)Z(Unknown Source)
        at org.eclipse.team.internal.core.BackgroundEventHandler.dispatchEvents(
BackgroundEventHandler.java:354)
        at org.eclipse.team.internal.core.BackgroundEventHandler.processEvents(B
ackgroundEventHandler.java:334)
        at org.eclipse.team.internal.core.BackgroundEventHandler$1.run(Backgroun
dEventHandler.java:173)
        at org.eclipse.core.internal.jobs.Worker.run(Worker.java:58)
Caused by: org.apache.xmlrpc.XmlRpcClientException: Error decoding XML-RPC excep
tion response
        at org.apache.xmlrpc.XmlRpcClientResponseProcessor.decodeException(Ljava
.lang.Object;)Lorg.apache.xmlrpc.XmlRpcException;(Unknown Source)
        ... 17 more
Caused by: java.lang.NumberFormatException: For input string: "Server"
        at java.lang.NumberFormatException.forInputString(NumberFormatException.
java:48)
        at java.lang.Integer.parseInt(Integer.java:468)
        at java.lang.Integer.parseInt(Integer.java:518)
        ... 18 more
Comment 2 Red Hat Bugzilla 2007-09-11 00:05:43 EDT
User klee@redhat.com's account has been closed
Comment 3 Andrew Overholt 2007-09-11 10:20:55 EDT
We are now shipping Mylyn which obsoletes the old bugzilla plugin.

Note You need to log in before you can comment on or make changes to this bug.