Bug 203991 - Missing requirement on xorg-x11-server-Xorg
Missing requirement on xorg-x11-server-Xorg
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: xorg-x11-server (Show other bugs)
5
All Linux
medium Severity medium
: ---
: ---
Assigned To: X/OpenGL Maintenance List
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-08-24 16:53 EDT by Leonard den Ottolander
Modified: 2007-11-30 17:11 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-09-09 15:18:08 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Leonard den Ottolander 2006-08-24 16:53:03 EDT
xorg-x11-xdm misses a requirement on xorg-x11-base.

As a result yum groupinstall "KDE (...)" fails to install X as a dependency.
Comment 1 Adam Jackson 2006-08-25 11:35:51 EDT
'repoquery --whatprovides xorg-x11-base' returns no matches in rawhide, and I
don't have a package by that name in CVS for any release of the OS.  Where are
you getting the name 'xorg-x11-base' from?
Comment 2 Leonard den Ottolander 2006-08-28 17:06:57 EDT
I must have made a silly assumption when comparing against RHEL-4 where X is
provided by xorg-x11.

Original report should be read as:

"Missing requirement on xorg-x11-server-Xorg

xorg-x11-xdm misses a requirement on xorg-x11-server-Xorg.

As a result yum groupinstall "KDE (...)" fails to install X as a dependency."

Sorry for the confusion.
Comment 3 Adam Jackson 2006-08-29 13:26:33 EDT
That's intentional though.  xdm doesn't need an X server installed in order to
work; it just needs an X server to talk to.  Firefox doesn't require apache.

My understanding is this is the sort of thing comps files are for, rather than
RPM dependencies.
Comment 4 Leonard den Ottolander 2006-08-30 15:40:54 EDT
Well, then you please tell me which dependency is missing.

If I yum groupinstall KDE *something* should pull in an X server. This doesn't
happen though.

(Maybe the dependency should be on kdebase?)
Comment 5 Hans de Goede 2006-08-30 15:50:00 EDT
(In reply to comment #4)
> Well, then you please tell me which dependency is missing.
> 
> If I yum groupinstall KDE *something* should pull in an X server. This doesn't
> happen though.
> 
> (Maybe the dependency should be on kdebase?)
> 

no it shouldn't maybe you want to run kde through vnc, maybe to ssh X
forwarding, maybe you only want it to build packages (as on a build server)

I think this should be closed as not a bug.


Note You need to log in before you can comment on or make changes to this bug.