Bug 204033 - *** glibc detected *** /usr/bin/perl: corrupted double-linked list: 0x08d1bec8 ***
*** glibc detected *** /usr/bin/perl: corrupted double-linked list: 0x08d1bec...
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: perl (Show other bugs)
rawhide
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Robin Norwood
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-08-25 03:40 EDT by Caolan McNamara
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version: F-7
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-07-27 10:28:31 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Caolan McNamara 2006-08-25 03:40:46 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8.0.6) Gecko/20060822 Fedora/1.5.0.6-4 Firefox/1.5.0.6 pango-text

Description of problem:
crash during rpmbuild of openoffice.org

Version-Release number of selected component (if applicable):
perl-5.8.8-8

How reproducible:
Always


Steps to Reproduce:
1. 8 hours into rpmbuild -bb openoffice.org.spec

ok, not easy to reproduce :-)

Actual Results:
*** glibc detected *** /usr/bin/perl: corrupted double-linked list: 0x08d1bec8 ***
======= Backtrace: =========
/lib/libc.so.6[0xf7d3653a]
/lib/libc.so.6[0xf7d37f0e]
/lib/libc.so.6(cfree+0x90)[0xf7d38360]
/usr/lib/perl5/5.8.8/i386-linux-thread-multi/CORE/libperl.so(Perl_safesysfree+0x21)[0xf7f259e1]
/usr/lib/perl5/5.8.8/i386-linux-thread-multi/CORE/libperl.so(Perl_av_undef+0x83)[0xf7f33923]
/usr/lib/perl5/5.8.8/i386-linux-thread-multi/CORE/libperl.so(Perl_sv_clear+0x5b3)[0xf7f40153]
/usr/lib/perl5/5.8.8/i386-linux-thread-multi/CORE/libperl.so(Perl_sv_free+0x85)[0xf7f40485]
/usr/lib/perl5/5.8.8/i386-linux-thread-multi/CORE/libperl.so(Perl_sv_unref_flags+0x4f)[0xf7f4058f]
/usr/lib/perl5/5.8.8/i386-linux-thread-multi/CORE/libperl.so(Perl_sv_force_normal_flags+0x1be)[0xf7f40fbe]
/usr/lib/perl5/5.8.8/i386-linux-thread-multi/CORE/libperl.so(Perl_leave_scope+0xc55)[0xf7f64db5]
/usr/lib/perl5/5.8.8/i386-linux-thread-multi/CORE/libperl.so(Perl_pop_scope+0x35)[0xf7f64e95]
/usr/lib/perl5/5.8.8/i386-linux-thread-multi/CORE/libperl.so(Perl_pp_leave+0xe1)[0xf7f35a21]
/usr/lib/perl5/5.8.8/i386-linux-thread-multi/CORE/libperl.so(Perl_runops_standard+0x1f)[0xf7f347bf]
/usr/lib/perl5/5.8.8/i386-linux-thread-multi/CORE/libperl.so(perl_run+0x2ee)[0xf7eda21e]
/usr/bin/perl(main+0x13e)[0x80491ee]
/lib/libc.so.6(__libc_start_main+0xdc)[0xf7ce823c]
/usr/bin/perl[0x8049021]
======= Memory map: ========
08048000-0804b000 r-xp 00000000 09:01 6556913                            /usr/bin/perl
0804b000-0804c000 rwxp 00002000 09:01 6556913                            /usr/bin/perl
0804c000-0976a000 rwxp 0804c000 00:00 0
f7800000-f7821000 rwxp f7800000 00:00 0
f7821000-f7900000 ---p f7821000 00:00 0
f797f000-f798a000 r-xp 00000000 09:01 6357114                            /lib/libgcc_s-4.1.1-20060818.so.1
f798a000-f798b000 rwxp 0000a000 09:01 6357114                            /lib/libgcc_s-4.1.1-20060818.so.1
f798b000-f7b8c000 rwxp f7b8c000 00:00 0
f7c55000-f7c5e000 r-xp 00000000 09:01 6357173                            /lib/libnss_files-2.4.90.so
f7c5e000-f7c5f000 r-xp 00008000 09:01 6357173                            /lib/libnss_files-2.4.90.so
f7c5f000-f7c60000 rwxp 00009000 09:01 6357173                            /lib/libnss_files-2.4.90.so
f7c5e000-f7c5f000 r-xp 00008000 09:01 6357173                            /lib/libnss_files-2.4.90.so
f7c5f000-f7c60000 rwxp 00009000 09:01 6357173                            /lib/libnss_files-2.4.90.so
f7c69000-f7c9e000 r-xs 00000000 09:00 229551                             /var/db/nscd/passwd
f7c9e000-f7ca2000 r-xp 00000000 09:01 7325373                            /usr/lib/perl5/5.8.8/i386-linux-thread-multi/auto/IO/IO.so
f7ca2000-f7ca3000 rwxp 00003000 09:01 7325373                            /usr/lib/perl5/5.8.8/i386-linux-thread-multi/auto/IO/IO.so
f7ca3000-f7ca8000 r-xp 00000000 09:01 7325548                            /usr/lib/perl5/5.8.8/i386-linux-thread-multi/auto/Socket/Socket.so
f7ca8000-f7ca9000 rwxp 00004000 09:01 7325548                            /usr/lib/perl5/5.8.8/i386-linux-thread-multi/auto/Socket/Socket.so
f7ca9000-f7cab000 r-xp 00000000 09:01 7325315                            /usr/lib/perl5/5.8.8/i386-linux-thread-multi/auto/Cwd/Cwd.so
f7cab000-f7cac000 rwxp 00001000 09:01 7325315                            /usr/lib/perl5/5.8.8/i386-linux-thread-multi/auto/Cwd/Cwd.so
f7cac000-f7ccf000 rwxp f7cac000 00:00 0 
f7ccf000-f7e06000 r-xp 00000000 09:01 6357157                            /lib/libc-2.4.90.so
f7e06000-f7e08000 r-xp 00137000 09:01 6357157                            /lib/libc-2.4.90.so
f7e08000-f7e09000 rwxp 00139000 09:01 6357157                            /lib/libc-2.4.90.so
f7e09000-f7e0c000 rwxp f7e09000 00:00 0 
f7e0c000-f7e1f000 r-xp 00000000 09:01 6357181                            /lib/libpthread-2.4.90.so
f7e1f000-f7e20000 r-xp 00012000 09:01 6357181                            /lib/libpthread-2.4.90.so
f7e20000-f7e21000 rwxp 00013000 09:01 6357181                            /lib/libpthread-2.4.90.so
f7e21000-f7e23000 rwxp f7e21000 00:00 0 
f7e23000-f7e25000 r-xp 00000000 09:01 6357189                            /lib/libutil-2.4.90.so
f7e25000-f7e26000 r-xp 00001000 09:01 6357189                            /lib/libutil-2.4.90.so
f7e26000-f7e27000 rwxp 00002000 09:01 6357189                            /lib/libutil-2.4.90.so
f7e27000-f7e2c000 r-xp 00000000 09:01 6357161                            /lib/libcrypt-2.4.90.so
f7e2c000-f7e2d000 r-xp 00004000 09:01 6357161                            /lib/libcrypt-2.4.90.so
f7e2d000-f7e2e000 rwxp 00005000 09:01 6357161                            /lib/libcrypt-2.4.90.so
f7e2e000-f7e55000 rwxp f7e2e000 00:00 0 
f7e55000-f7e7a000 r-xp 00000000 09:01 6357165                            /lib/libm-2.4.90.so
f7e7a000-f7e7b000 r-xp 00024000 09:01 6357165                            /lib/libm-2.4.90.so
f7e7a000-f7e7b000 r-xp 00024000 09:01 6357165                            /lib/libm-2.4.90.so
f7e7b000-f7e7c000 rwxp 00025000 09:01 6357165                            /lib/libm-2.4.90.so
f7e7c000-f7e7e000 r-xp 00000000 09:01 6357163                            /lib/libdl-2.4.90.so
f7e7e000-f7e7f000 r-xp 00001000 09:01 6357163                            /lib/libdl-2.4.90.so
f7e7f000-f7e80000 rwxp 00002000 09:01 6357163                            /lib/libdl-2.4.90.so
f7e80000-f7e81000 rwxp f7e80000 00:00 0
f7e81000-f7e93000 r-xp 00000000 09:01 6357167                            /lib/libnsl-2.4.90.so
f7e93000-f7e94000 r-xp 00011000 09:01 6357167                            /lib/libnsl-2.4.90.so
f7e94000-f7e95000 rwxp 00012000 09:01 6357167                            /lib/libnsl-2.4.90.so
f7e95000-f7e97000 rwxp f7e95000 00:00 0
f7e97000-f7ea6000 r-xp 00000000 09:01 6357183                            /lib/libresolv-2.4.90.so
f7ea6000-f7ea7000 r-xp 0000e000 09:01 6357183                            /lib/libresolv-2.4.90.so
f7ea7000-f7ea8000 rwxp 0000f000 09:01 6357183                            /lib/libresolv-2.4.90.so
f7ea8000-f7eaa000 rwxp f7ea8000 00:00 0
f7eb3000-f7fdd000 r-xp 00000000 09:01 7325177                            /usr/lib/perl5/5.8.8/i386-linux-thread-multi/CORE/libperl.so
f7fdd000-f7fe2000 rwxp 00129000 09:01 7325177                            /usr/lib/perl5/5.8.8/i386-linux-thread-multi/CORE/libperl.so
f7fe2000-f7fe5000 rwxp f7fe2000 00:00 0
f7fe5000-f7ffe000 r-xp 00000000 09:01 6357150                            /lib/ld-2.4.90.so
f7ffe000-f7fff000 r-xp 00018000 09:01 6357150                            /lib/ld-2.4.90.so
f7fff000-f8000000 rwxp 00019000 09:01 6357150                            /lib/ld-2.4.90.so
fffe8000-ffffe000 rw-p fffe8000 00:00 0
ffffe000-fffff000 ---p 00000000 00:00 0
Abort


Expected Results:


Additional info:
There was a glibc bugfix recently which affected evolution, perhaps that's relevent
Comment 1 Stepan Kasal 2007-07-27 10:14:30 EDT
It's 11 months since the problem was reported.
Is it still reproducible?
Comment 2 Caolan McNamara 2007-07-27 10:28:31 EDT
Indeed, at the time I was able to workaround it with _MALLOC_CHECK or whatever,
but in the year since it disappeared along the line.

Note You need to log in before you can comment on or make changes to this bug.