Bug 204042 - vimdiff wrong color commented strings
vimdiff wrong color commented strings
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: vim (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Karsten Hopp
David Lawrence
: Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-08-25 04:13 EDT by Maxim Britov
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-09-19 08:26:05 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Maxim Britov 2006-08-25 04:13:43 EDT
Description of problem:
Creating 1.txt and 2.txt.
1:
12345
54321

2:
12345
#dfkdjfkjd
#dlfjkdfjkd
54321

Check it by: $ vimdiff 1.txt 2.txt
I see only blue background between 12345 and 54321 in 2.txt file.

Version-Release number of selected component (if applicable):
vim-minimal-7.0.063-1
vim-X11-7.0.063-1
vim-common-7.0.063-1
vim-enhanced-7.0.063-1
Comment 1 Maxim Britov 2006-08-25 04:15:10 EDT
gvimdiff 1.txt 2.txt
show this fine for me.
Comment 2 Karsten Hopp 2006-08-25 06:56:54 EDT
vim -d shows this bug, gvim doesn't.
temporary fix until the new package is on the mirrors is
:hi Comment    cterm=NONE ctermfg=DarkRed     gui=NONE guifg=red2

or
:colorscheme delek
Comment 3 Deji Akingunola 2006-08-26 20:59:46 EDT
The resolution to this bug changes gvim color display for me. Using the default
color scheme, comment lines used to be in blue and numerics were in red (at
least for fortran files) since i've been using gvim.
Can this be reverted, please? It's difficult getting used to this change
(really, it's only been a few hours of use ;)
Comment 4 Maxim Britov 2006-08-28 13:04:10 EDT
This still wrong here:
$ cat 11.txt 
#!/bin/sh

test --test ewewe
$ cat 22.txt 
#!/bin/sh

test --test test
$vimdiff 11.txt 22.txt
Comment 5 Deji Akingunola 2006-08-31 16:59:04 EDT
Ping. Why not please drop the vim-7.0-syncolor.patch, since it does not seem to
even solve the original issue here. Thanks
Comment 6 Deji Akingunola 2006-09-18 20:00:18 EDT
Hi Karsten,

I see you're not too keen on reverting the change you made to vim based on this
bug, but can you please advise on something I can put in my vimrc to allow the
old behaviour. Thank you.
Comment 7 Karsten Hopp 2006-09-19 08:26:05 EDT
I've built vim-7.0.109-1 which should solve those issues. It changes the colors of 
added lines in diff mode instead of the colors of all comments.
I'm not sure if this will make it into FC6, grab the packages from rawhide instead.
Comment 8 Deji Akingunola 2006-09-26 21:49:21 EDT
vim-7.0.109-1 has not appeared in rawhide yet, maybe because we're FC6 release
mode. I hope it can make it into FC6, at least as an update.

Note You need to log in before you can comment on or make changes to this bug.