Bug 2041085 - SELinux is preventing tumblerd from 'write' accesses on the sock_file bus.
Summary: SELinux is preventing tumblerd from 'write' accesses on the sock_file bus.
Keywords:
Status: CLOSED DUPLICATE of bug 2042696
Alias: None
Product: Fedora
Classification: Fedora
Component: selinux-policy
Version: rawhide
Hardware: x86_64
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Zdenek Pytela
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: abrt_hash:4e7a5eb65a0ba67d8e23022db61...
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2022-01-15 22:01 UTC by Ian Laurie
Modified: 2022-01-26 15:49 UTC (History)
9 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2022-01-26 15:49:34 UTC
Type: ---
Embargoed:


Attachments (Terms of Use)

Description Ian Laurie 2022-01-15 22:01:09 UTC
Description of problem:
Logged into Xfce.
SELinux is preventing tumblerd from 'write' accesses on the sock_file bus.

*****  Plugin catchall (100. confidence) suggests   **************************

If you believe that tumblerd should be allowed write access on the bus sock_file by default.
Then you should report this as a bug.
You can generate a local policy module to allow this access.
Do
allow this access for now by executing:
# ausearch -c 'tumblerd' --raw | audit2allow -M my-tumblerd
# semodule -X 300 -i my-tumblerd.pp

Additional Information:
Source Context                unconfined_u:unconfined_r:thumb_t:s0-s0:c0.c1023
Target Context                unconfined_u:object_r:session_dbusd_tmp_t:s0
Target Objects                bus [ sock_file ]
Source                        tumblerd
Source Path                   tumblerd
Port                          <Unknown>
Host                          (removed)
Source RPM Packages           
Target RPM Packages           
SELinux Policy RPM            selinux-policy-targeted-35.9-1.fc36.noarch
Local Policy RPM              selinux-policy-targeted-35.9-1.fc36.noarch
Selinux Enabled               True
Policy Type                   targeted
Enforcing Mode                Permissive
Host Name                     (removed)
Platform                      Linux (removed) 5.17.0-
                              0.rc0.20220112gitdaadb3bd0e8d.63.fc36.x86_64 #1
                              SMP PREEMPT Wed Jan 12 18:54:57 UTC 2022 x86_64
                              x86_64
Alert Count                   1
First Seen                    2022-01-16 08:57:03 AEDT
Last Seen                     2022-01-16 08:57:03 AEDT
Local ID                      ab4cfbd1-e2ec-444e-91aa-170db8cfb062

Raw Audit Messages
type=AVC msg=audit(1642283823.843:330): avc:  denied  { write } for  pid=5131 comm="tumblerd" name="bus" dev="tmpfs" ino=49 scontext=unconfined_u:unconfined_r:thumb_t:s0-s0:c0.c1023 tcontext=unconfined_u:object_r:session_dbusd_tmp_t:s0 tclass=sock_file permissive=1


Hash: tumblerd,thumb_t,session_dbusd_tmp_t,sock_file,write

Version-Release number of selected component:
selinux-policy-targeted-35.9-1.fc36.noarch

Additional info:
component:      selinux-policy
reporter:       libreport-2.15.2
hashmarkername: setroubleshoot
kernel:         5.17.0-0.rc0.20220112gitdaadb3bd0e8d.63.fc36.x86_64
type:           libreport

Potential duplicate: bug 2039546

Comment 1 Zdenek Pytela 2022-01-26 15:49:34 UTC

*** This bug has been marked as a duplicate of bug 2042696 ***


Note You need to log in before you can comment on or make changes to this bug.