Bug 204116 - Application Stack & JBoss Channel Request
Application Stack & JBoss Channel Request
Status: CLOSED CURRENTRELEASE
Product: Red Hat Network
Classification: Red Hat
Component: RHN/Channels (Show other bugs)
RHN Stable
All Linux
medium Severity medium
: ---
: ---
Assigned To: Bret McMillan
Brandon Perkins
:
Depends On: 82114
Blocks:
  Show dependency treegraph
 
Reported: 2006-08-25 13:50 EDT by Matt Webbink
Modified: 2007-04-18 13:48 EDT (History)
6 users (show)

See Also:
Fixed In Version: rhn500
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-03-28 10:53:53 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Matt Webbink 2006-08-25 13:50:03 EDT
Two sets of new channels need to be created:  1. Red Hat Application Stack
channels; 2. JBoss channels.

Please create the new Red Hat Application Stack channels in QA, per revision #
101157 of rh-stack-channels.csv.

Please also create the new JBoss channels in QA, per revision # 101158 of
jboss-channels.csv.  Parent channel "jboss-jems" will need to be created.

If you have any questions related to these product offerings, please contact
Aaron Darcy (adarcy@redhat.com) for additional details.
Comment 1 Aaron Darcy 2006-08-29 10:01:32 EDT
Hi guys, how is this request progressing? Please let me know if you have any
questions. Thanks
Comment 2 Bret McMillan 2006-08-29 15:30:34 EDT
Channels for both csv files have been created on webqa.

[root@scripts tmp]# python create-channel.py --verbose --db=CENSORED@webqa
--csv=./rh-stack-channels.csv --create-family --commit
Connecting to rhnuser/rhnuser@webqa
Creating channel rhel-i386-as-4-appstk-1
  Channel rhel-i386-as-4-appstk-1 membership updated
Creating channel rhel-i386-es-4-appstk-1
  Channel rhel-i386-es-4-appstk-1 membership updated
Creating channel rhel-x86_64-as-4-appstk-1
  Channel rhel-x86_64-as-4-appstk-1 membership updated
Creating channel rhel-x86_64-es-4-appstk-1
  Channel rhel-x86_64-es-4-appstk-1 membership updated
Committing
[root@scripts tmp]# python create-channel.py --verbose --db=CENSORED@webqa
--csv=./jboss-channels.csv --create-family --commit
Connecting to rhnuser/rhnuser@webqa
Creating channel jboss-jems
  Channel jboss-jems membership updated
Creating channel jboss-jems-jbas
  Channel jboss-jems-jbas membership updated
Creating channel jboss-jems-clus
  Channel jboss-jems-clus membership updated
Creating channel jboss-jems-hib
  Channel jboss-jems-hib membership updated
Creating channel jboss-jems-port
  Channel jboss-jems-port membership updated
Creating channel jboss-jems-jbpm
  Channel jboss-jems-jbpm membership updated
Creating channel jboss-jems-jbrl
  Channel jboss-jems-jbrl membership updated
Creating channel jboss-jems-jbca
  Channel jboss-jems-jbca membership updated
Creating channel jboss-jems-jts
  Channel jboss-jems-jts membership updated
Creating channel jboss-jems-trxw
  Channel jboss-jems-trxw membership updated
Creating channel jboss-jems-jbon
  Channel jboss-jems-jbon membership updated
Committing
[root@scripts tmp]#
Comment 3 Aaron Darcy 2006-08-30 14:59:09 EDT
Thanks. Can you please grant access to these channels to the following:
qa@redhat.com
adarcy@redhat.com (rhn id = aarondarcy)
bkahn@redhat.com
Comment 4 Bret McMillan 2006-08-30 16:11:04 EDT
I spoke w/ adarcy on the phone, but I'll need entitlement mappings to run
against webqa before I can grant access to these channels.
Comment 5 Matt Webbink 2006-08-30 17:29:22 EDT
The channel mappings have been committed to svn.  Please run revision # 101508
of rh-stack-mappings.csv in webqa.
Comment 6 Bret McMillan 2006-08-31 09:43:18 EDT
Mappings have been run against webqa.

[root@scripts tmp]# python entitlement-mapper.py --verbose --db=CENSORED@qa
--csv=./rh-stack-mappings-101508.csv --all --commit
Processing CSV ./rh-stack-mappings-101508.csv
  found 6 items
    SER0247US SVC0239 SVC0240 SVC0241 WAR0302 WAR0303
Creating item mappings
  processing item SVC0239
  processing item WAR0302
  processing item WAR0303
  processing item SER0247US
  processing item SVC0241
  processing item SVC0240
Scheduling org repolls
  0 orgs have active SVC0239 lines
  0 orgs have active WAR0302 lines
  0 orgs have active WAR0303 lines
  0 orgs have active SER0247US lines
  0 orgs have active SVC0241 lines
  0 orgs have active SVC0240 lines
Committing
[root@scripts tmp]#


Users "qa@redhat.com" & "aadarcy" have been granted 10 SVC0240's each.  There is
no user "bkahn@redhat.com" on webqa, and there doesn't seem to be any active
sku's for either the "jboss" or "jboss-jems" channel families.
Comment 7 Benjamin Kahn 2006-08-31 09:53:25 EDT
Ahem.  My account is probably xkahn@zoned.net .  Sorry.
Comment 8 Bret McMillan 2006-08-31 10:00:24 EDT
Entitlement granter sez no such user... probably easiest just to go to
http://rhn.webqa.redhat.com/ and create 'bkahn@redhat.com'
Comment 9 Aaron Darcy 2006-09-06 12:01:05 EDT
Matt, are the channel mappings ready for the JBoss channels?
Comment 10 Matt Webbink 2006-09-11 15:10:08 EDT
Yes - The channel mappings are ready.  Please push revision # 102071 of
jboss-mappings.csv to QA.
Comment 11 Aaron Darcy 2006-09-12 12:36:14 EDT
The following channels have been verified in webqa & can be pushed to rhn prod:
rhel-i386-as-4-appstk-1
rhel-i386-es-4-appstk-1
rhel-x86_64-as-4-appstk-1
rhel-x86_64-es-4-appstk-1

Comment 14 Aaron Darcy 2006-09-13 10:03:54 EDT
Re: Comment #12 -- the appstack channels and the jboss channels are separate.
Teh appstack channels are ready to go to rhn prod. As you indicated, the JBoss
channels (i.e. comment #10) have not been signed off and are not yet ready to go
to rhn prod.

Please push the following channels (and only these) to rhn prod:
rhel-i386-as-4-appstk-1
rhel-i386-es-4-appstk-1
rhel-x86_64-as-4-appstk-1
rhel-x86_64-es-4-appstk-1

Thanks
Comment 15 Bret McMillan 2006-09-13 10:32:43 EDT
Looks like rh-stack-mappings.csv changed from rev 101508 to rev 101696.  I'm
concerned that blindly running 101508 like we did in qa will blow away access to
the rhel5 beta for those skus.  I'm investigating this, but Matt, it'd help if
you could review that file and ensure that 101508 is for certain the rev you
want to go out the door.
Comment 16 Matt Webbink 2006-09-13 10:49:13 EDT
Aaron - Please confirm RHEL 5 Beta channels should be included with the
Application Stack.

If so, rev 101696 should be used.  If not, rev 101508 should be used.
Comment 17 Matt Webbink 2006-09-13 12:00:38 EDT
Bret - Spoke with Aaron, please use rev 101696.
Comment 18 Bret McMillan 2006-09-14 10:56:28 EDT
RT filed for appstk channels: 
https://rt.corp.redhat.com/rt3/Ticket/Display.html?id=251097
Comment 19 Matt Webbink 2006-09-14 14:10:38 EDT
Aaron - When should the JBoss mappings be pushed to Production?
Comment 20 Bret McMillan 2006-09-14 14:24:44 EDT
appstk RT #251097 is resolved in production, so those channels & mappings should
be live.  Leaving this bug in ON_QA until the jboss channels are dealt with.
Comment 21 Dennis Gregorovic 2006-09-14 14:53:28 EDT
How do get the necessary entitlements to see the channels?
Comment 23 Ben Levenson 2006-09-19 01:01:23 EDT
are we finished with this?
Comment 24 Bret McMillan 2006-09-19 09:37:40 EDT
No, we don't have any mappings for the JBoss channels.  So, either we clone this
for the jboss mappings, and close this one; or we leave this one open...
Comment 25 Brandon Perkins 2006-10-17 22:27:55 EDT
Reopening so that Comment #24 gets addressed.
Comment 26 Bret McMillan 2007-03-28 10:53:53 EDT
Closing this due to lack of updates

Note You need to log in before you can comment on or make changes to this bug.