Bug 204118 - scim-bridge outputting IOException on cursor movement
scim-bridge outputting IOException on cursor movement
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: scim-bridge (Show other bugs)
rawhide
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Jens Petersen
: i18n
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-08-25 14:13 EDT by charles harris
Modified: 2007-11-30 17:11 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-08-28 05:03:27 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description charles harris 2006-08-25 14:13:12 EDT
Description of problem:

When started from a console gvim throws the error:
An IOException occured at scim_bridge_client_imcontext_set_cursor_location ()
Whenever the cursor is repositioned.

Version-Release number of selected component (if applicable):

vim-X11-7.0.066-1

How reproducible:

always

Steps to Reproduce:
1. start gvim
2. reposition cursor
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 charles harris 2006-08-25 14:23:09 EDT
The following messages are printed on file save:

Unknown message: Unknown
The socket is borken at scim_bridge_messenger_receive_message ()
Failed to receive messages at scim_bridge_client_read_and_dispatch ()
An IOException at scim_bridge_client_set_preedit_mode ()
An IOException occured at scim_bridge_client_imcontext_set_preedit_enabled ()
An IOException at scim_bridge_messenger_send_message (): Broken pipe
Failed to send a message at scim_bridge_client_set_preedit_mode ()
An IOException occured at scim_bridge_client_imcontext_set_preedit_enabled ()
The messenger is now down
Comment 2 Karsten Hopp 2006-08-25 14:49:10 EDT
gvim doesn't use scim directly, this most likely is a bug in the input method
user interface
Comment 3 Jens Petersen 2006-08-25 16:29:29 EDT
I believe this is already fixed in upstream cvs.
Comment 4 Jens Petersen 2006-08-28 05:03:27 EDT
Fixed in scim-bridge-0.4.1.
Comment 5 Ryo Dairiki 2006-08-31 02:49:15 EDT
Not, really.
This bug still exists.

Fortunately, scim-bridge-0.4.1 has auto reconneciton feature, 
which reopens the socket automatically on errors.
So this is not serious bug for users, because it repairs the connection as soon
as they type something on it.
I'll fix this on 0.4.3; Dealying 0.4.2 is not necessary I think.
Comment 6 Ryo Dairiki 2006-08-31 03:14:24 EDT
Fixed on 0.4.2. :)

Note You need to log in before you can comment on or make changes to this bug.