Bug 204129 - raise_window_key binding is not available
raise_window_key binding is not available
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: compiz (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Kristian Høgsberg
: Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-08-25 14:59 EDT by Thomas J. Baker
Modified: 2007-11-30 17:11 EST (History)
3 users (show)

See Also:
Fixed In Version: F7
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-09-06 10:35:31 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
screenshot of window keybindings control center option (82.81 KB, image/jpeg)
2006-10-01 20:32 EDT, Thomas J. Baker
no flags Details
raise_window patch (5.60 KB, patch)
2006-11-01 10:02 EST, Oskari Saarenmaa
no flags Details | Diff

  None (edit)
Description Thomas J. Baker 2006-08-25 14:59:19 EDT
Description of problem:

The raise window keybinding seems to be missing. I believe it was there in
earlier versions but I can't find it now. Lower is there but not raise.

Version-Release number of selected component (if applicable):

compiz-0.0.13-0.17.20060817git.fc6
Comment 1 Søren Sandmann Pedersen 2006-09-28 12:05:01 EDT
What do you mean it's missing? Where is it missing from?
Comment 2 Søren Sandmann Pedersen 2006-09-28 12:25:08 EDT
It's missing from the keybinding capplet alright. Will be fixed in
control-center-2.16.0-8.fc6
Comment 3 Thomas J. Baker 2006-09-28 13:09:06 EDT
FWIW, at the time I reported it, it was missing from the gconf settings for
compiz. Compiz essentially didn't have a keybinding control for raise window in
it's gconf schema. Does that make sense?
Comment 4 Søren Sandmann Pedersen 2006-09-28 19:01:35 EDT
Hmm, not really ... Please try the new packages when they appear in rawhide and,
if you still have the problem, please reopen this bug.
Comment 5 Thomas J. Baker 2006-10-01 20:32:45 EDT
Created attachment 137516 [details]
screenshot of window keybindings control center option
Comment 6 Thomas J. Baker 2006-10-01 20:33:34 EDT
I've got the new control center and it now shows Window Management options where
it didn't before but there is still no raise window option. It looks to me like
compiz doesn't have the ability to bind a key raise a window. If you look at
compiz options with gconf-editor, in compiz/general/allscreens/options where
most of the other keybindings are, there is no raise window option.
Comment 7 Søren Sandmann Pedersen 2006-10-03 17:41:09 EDT
Hmmm, looks like you are right. That option simply isn't in compiz' schema,
patched or not.

Comment 8 Søren Sandmann Pedersen 2006-10-03 17:43:41 EDT
Very weird. It definitely used to be there.
Comment 9 Oskari Saarenmaa 2006-11-01 10:02:03 EST
Created attachment 139985 [details]
raise_window patch

Attached a patch that adds raise_window options to gconf.
Comment 10 Oskari Saarenmaa 2006-11-01 10:05:42 EST
I just wrote the attached patch so I could switch from metacity.  It works for
me, but the gconf schema has no translations and the RAISE_WINDOW_BUTTON_DEFAULT
value is probably invalid.
Comment 11 Thomas J. Baker 2007-09-06 10:18:05 EDT
This is fixed in >= F7 versions of compiz.
Comment 12 Matěj Cepl 2007-09-06 10:35:31 EDT
Closing per reporter's request.

Note You need to log in before you can comment on or make changes to this bug.