Bug 204133 - libsepol-devel rpms
Summary: libsepol-devel rpms
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: libsepol   
(Show other bugs)
Version: 5
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Daniel Walsh
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2006-08-25 19:17 UTC by Kevin Carr
Modified: 2007-11-30 22:11 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-08-31 15:33:43 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Kevin Carr 2006-08-25 19:17:34 UTC
Description of problem:
The files installed from the libsepol and libsepol-devel packages seem to be
incorrect.

Version-Release number of selected component (if applicable):
$ rpm -q libsepol
libsepol-1.12.17-1.fc5

$ rpm -q libsepol-devel
libsepol-devel-1.12.17-1.fc5

How reproducible:
Always.

Steps to Reproduce:
1. install libsepol and libsepol-devel via yum/rpm
2. type the following commands to see installed files:
$ rpm -ql libsepol
$ rpm -ql libsepol-devel
  
Actual results:

The current behavior has the libsepol package installing the private header
files in "include/sepol/policydb" which definately seems strange since the
static archive is not installed in that package making the headers useless. 

$ rpm -ql libsepol
/lib/libsepol.so.1
/usr/include/sepol
/usr/include/sepol/policydb
/usr/include/sepol/policydb/avrule_block.h
/usr/include/sepol/policydb/avtab.h
/usr/include/sepol/policydb/conditional.h
/usr/include/sepol/policydb/constraint.h
/usr/include/sepol/policydb/context.h
/usr/include/sepol/policydb/ebitmap.h
/usr/include/sepol/policydb/expand.h
/usr/include/sepol/policydb/flask.h
/usr/include/sepol/policydb/flask_types.h
/usr/include/sepol/policydb/hashtab.h
/usr/include/sepol/policydb/hierarchy.h
/usr/include/sepol/policydb/link.h
/usr/include/sepol/policydb/mls_types.h
/usr/include/sepol/policydb/module.h
/usr/include/sepol/policydb/policydb.h
/usr/include/sepol/policydb/services.h
/usr/include/sepol/policydb/sidtab.h
/usr/include/sepol/policydb/symtab.h
/usr/include/sepol/policydb/util.h

In the libsepol-devel package the private headers in "include/sepol/policydb"
are not installed, which doesn't make sence for static users that need to
compile and like agains the .a file.

$ rpm -ql libsepol-devel
/usr/include/sepol/boolean_record.h
/usr/include/sepol/booleans.h
/usr/include/sepol/context.h
/usr/include/sepol/context_record.h
/usr/include/sepol/debug.h
/usr/include/sepol/handle.h
/usr/include/sepol/iface_record.h
/usr/include/sepol/interfaces.h
/usr/include/sepol/module.h
/usr/include/sepol/node_record.h
/usr/include/sepol/nodes.h
/usr/include/sepol/policydb.h
/usr/include/sepol/port_record.h
/usr/include/sepol/ports.h
/usr/include/sepol/roles.h
/usr/include/sepol/sepol.h
/usr/include/sepol/user_record.h
/usr/include/sepol/users.h
/usr/lib/libsepol.a
/usr/lib/libsepol.so
/usr/share/man/man3/sepol_check_context.3.gz
/usr/share/man/man3/sepol_genbools.3.gz
/usr/share/man/man3/sepol_genusers.3.gz

Expected results:
I expect that the libsepol package just installs the .so file. I expect that the
libsepol-devel package installs the .so file, the .a file, and all headers for
both shared users and static users. 

Additional info:
The next release of setools will depend upon libsepol-devel and will require the
.a file and the header files in "include/sepol/policydb".

Comment 1 Daniel Walsh 2006-08-31 15:33:43 UTC
Fixed in rawhide libsepol-1.12.25-3

Will back port only if necessary.


Note You need to log in before you can comment on or make changes to this bug.