Bug 204148 - php-eaccelerator.i386 5.1.4_0.9.5-0.3.rc1.fc appears to break PHP mime type config
php-eaccelerator.i386 5.1.4_0.9.5-0.3.rc1.fc appears to break PHP mime type c...
Status: CLOSED WORKSFORME
Product: Fedora
Classification: Fedora
Component: php-eaccelerator (Show other bugs)
5
All Linux
medium Severity high
: ---
: ---
Assigned To: Matthias Saou
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-08-25 16:56 EDT by Elan Kaplan
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-11-13 07:52:08 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Elan Kaplan 2006-08-25 16:56:11 EDT
Description of problem:

Upon installing php-eaccelerator.i386 5.1.4_0.9.5-0.3.rc1.fc5,
when accessing php scripts, one is often prompted asking whether to download 
the file or open it with a program. This suggests the Apache MIME type
configuration is getting messed up.

Upon uninstalling this update, everything seems fine.


Version-Release number of selected component (if applicable):

php-eaccelerator.i386 5.1.4_0.9.5-0.3.rc1.fc5

How reproducible:

Every time

Steps to Reproduce:
1.Install above package
2.I noticed it the problem right away with webmail (sqirrelmail)
3.I imagine the same symptom would show up with any PHP script accessed through
Apache.
  
Actual results:

Download/Open Dialog

Expected results:

Render in browser

Additional info:
Comment 1 Matthias Saou 2006-08-29 08:39:30 EDT
Please note that this is unfortunately still a pre-release, since nothing else
is compatible with PHP 5.1. Check your apache error_log for any errors, possibly
segfaults, any try disabling some of the features in your eaccelerator.ini to
narrow down the cause of the failures.

Please see http://eaccelerator.net/ for more information on how to debug the
problem, and eventually report it directly there too.
Comment 2 Matthias Saou 2006-10-19 08:54:43 EDT
I've pushed the 5.1.4 final release for FC5. Can you please tell me if the
problem persists or if it's now fixed?
Comment 3 Elan Kaplan 2006-10-19 17:06:10 EDT
My apologies, I no longer have it installed on my system since it was causing 
the problems and it was not critical to my operations.

If the release notes claim to fix this issue, it is probably safe to resolve.
Comment 4 Matthias Saou 2006-10-20 04:40:54 EDT
The release notes mention lots of fixes, but none directly related to mime
types, so either the underlying problem was different, either it might not be fixed.
Please let me know if you can try again, and if not I'll simply close the bug
for now since my own tests worked.

Note You need to log in before you can comment on or make changes to this bug.