Bug 204159 - [KDE] Keyboard Shortcut Shift F12 (Bullets On) Fails
[KDE] Keyboard Shortcut Shift F12 (Bullets On) Fails
Status: CLOSED CANTFIX
Product: Fedora
Classification: Fedora
Component: openoffice.org (Show other bugs)
5
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Caolan McNamara
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-08-26 01:47 EDT by Stan Cook
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-08-29 09:32:35 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
OpenOffice.org 68944 None None None Never

  None (edit)
Description Stan Cook 2006-08-26 01:47:40 EDT
Description of problem: <Shift><F12> Bullets On feature in writer does not function.


Version-Release number of selected component (if applicable):
Writer Open Office 2.0.2

How reproducible:
Open any existing document or new document.  Keyboard Shortcut for Bullet On is
<Shift><F12>.  <Contrl><Shift><F12> turns bullets off.  Select <Shift><F12> and
observe results

Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Caolan McNamara 2006-08-26 10:23:11 EDT
This works for me in fc-5 updates openoffice.org 2.0.2-5.17.2, so it might be
related to a particular translation, what locale do you run in ? e.g. open a
gnome-terminal and paste in here the output of 

> locale

I have shift+12 giving me a bullet, and ctrl+shift+21 removing it in locale LANG
of e.g. en_IE.UTF-8
Comment 2 Stan Cook 2006-08-26 13:42:40 EDT
LANG=en_US.UTF-8
LC_CTYPE="en_US.UTF-8"
LC_NUMERIC="en_US.UTF-8"
LC_TIME="en_US.UTF-8"
LC_COLLATE="en_US.UTF-8"
LC_MONETARY="en_US.UTF-8"
LC_MESSAGES="en_US.UTF-8"
LC_PAPER="en_US.UTF-8"
LC_NAME="en_US.UTF-8"
LC_ADDRESS="en_US.UTF-8"
LC_TELEPHONE="en_US.UTF-8"
LC_MEASUREMENT="en_US.UTF-8"
LC_IDENTIFICATION="en_US.UTF-8"
LC_ALL=
Comment 3 Caolan McNamara 2006-08-28 06:10:02 EDT
Well, that's very strange. It works for me on FC-5 with openoffice.org
2.0.2-5.17.2 and the same locale. i.e. shift+F12 gives me a bullet, F12 gives me
numering, and ctrl+shift+12 removes both/either.

In tools->customize->Keyboard the keyboard short-cuts are listed, for F12 is
"Numbering On/Off" as expected, shift+12 "Bullets On/Off" is listed as expected,
and "ctrl+shift+12" is remove numbering as expected. Do you have the same
keyboard shortcuts listed for those keys ?

When you said "observe results", were your results "nothing happened", or did
something else happen, e.g. "Insert Table", listed on ctrl + F12.
Comment 4 Stan Cook 2006-08-29 08:50:32 EDT
I have the same.  When I said observe results, nothing happened at all.
Comment 5 Caolan McNamara 2006-08-29 08:57:39 EDT
What's your desktop environment ? GNOME/KDE/Something else. Perhaps the
keystroke is being intercepted by the window manager somehow.
Comment 6 Stan Cook 2006-08-29 09:05:40 EDT
I'm running KDE.
Comment 7 Stan Cook 2006-08-29 09:11:48 EDT
I went through the regional shortcuts assigned for KDE and nothing shows as
assigned for [SHIFT][F12].
Comment 8 Caolan McNamara 2006-08-29 09:25:47 EDT
I see it now, KDE only, not in GNOME
Comment 9 Caolan McNamara 2006-08-29 09:32:35 EDT
There you go: http://lists.kde.org/?t=115503074800001&r=1&w=2 and specifically
http://lists.kde.org/?l=kde&m=115642234006699&w=2
KDE is eating it for voice recognition.

I don't think there's anything I can do about that.

Note You need to log in before you can comment on or make changes to this bug.