Bug 204160 - Upgrade to 0.5.0 with included patch and spec
Upgrade to 0.5.0 with included patch and spec
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: gnome-sudoku (Show other bugs)
5
All Linux
medium Severity medium
: ---
: ---
Assigned To: Paul W. Frields
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-08-26 03:24 EDT by Aaron Schlaegel
Modified: 2007-11-30 17:11 EST (History)
2 users (show)

See Also:
Fixed In Version: 0.5.0-1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-09-23 09:15:15 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Example 0.5.0 Spec File (3.31 KB, text/plain)
2006-08-26 03:24 EDT, Aaron Schlaegel
no flags Details
Patch to not load Glade at build (398 bytes, patch)
2006-08-26 03:26 EDT, Aaron Schlaegel
no flags Details | Diff

  None (edit)
Description Aaron Schlaegel 2006-08-26 03:24:50 EDT
Description of problem:
Version 0.5.0 came out in June, but has not hit Extras yet. Included is a spec
file and small patch to allow it to "build".

Additional info:
The source does not build in rpm without a patch because the pristine source
loads "glade" on build. The attached patch removes that superfluous load.

I also had to remove the old "sed" hacks as they will break the new release and
do not seem to be needed anymore.

I also had to add "lang" macros, which I am totally unfamiliar with.

I also deleted the old patch as I don't have any "fedora" macro on my system.
Since FC4 is no longer supported you probably don't need this FC4 hack anymore.

PS.
I don't expect you to keep my internal release tag or version note.
Comment 1 Aaron Schlaegel 2006-08-26 03:24:50 EDT
Created attachment 134969 [details]
Example 0.5.0 Spec File
Comment 2 Aaron Schlaegel 2006-08-26 03:26:22 EDT
Created attachment 134970 [details]
Patch to not load Glade at build
Comment 3 Aaron Schlaegel 2006-08-26 03:29:01 EDT
The patch is dependent upon the following line in the example spec file:

grep VERSION src/lib/defaults.py > src/lib/defaults_version.py
Comment 4 Paul W. Frields 2006-09-23 09:15:15 EDT
This has been built and released.

Note You need to log in before you can comment on or make changes to this bug.